WD2002: Problembehandlung bei beschädigten Dokumenten

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 290932 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel wurde zuvor veröffentlicht unter D290932
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
290932 WD2002: Troubleshooting Damaged Documents
Für eine Microsoft Word 2000-Version dieses Artikels siehe 211634.
Alles erweitern | Alles schließen

Auf dieser Seite

Zusammenfassung

Beschädigte Dokumentdateien können die Ursache dafür sein, dass ein Programm ein ungewöhnliches Verhalten zeigt. Ein solches Verhalten tritt auf, weil das Programm auf der Grundlage fehlerhafter Informationen in der Datei versucht, zu entscheiden, was es tun soll.
Der beste Weg, sich gegen beschädigte Dokumente zu schützen, besteht darin, Sicherungskopien dieser Dokumente zu speichern. Für den Fall, dass Sie über keine Sicherungskopie Ihres Dokuments verfügen, finden Sie in diesem Artikel einige Verfahren zur Problembehandlung, mit denen Sie beschädigte Microsoft Word für Windows-Dokumente identifizieren und möglicherweise wiederherstellen können.

Wichtiger Hinweis: Microsoft Word 2002 versucht eine automatische Wiederherstellung eines beschädigten Dokuments, wenn ein Problem in Bezug auf die Datei erkannt wird. Sie können Word auch "zwingen", die Wiederherstellung eines Dokuments zu versuchen, wenn Sie es wie folgt öffnen:
  1. Klicken Sie im Menü Datei auf Öffnen.
  2. Im Dialogfeld Öffnen klicken Sie bitte auf Ihr Word-Dokument, um es auszuwählen.
  3. Klicken Sie auf den Pfeil neben der Schaltfläche Öffnen und klicken Sie danach auf Öffnen und Reparieren.
Weitere Informationen zur Wiederherstellung von Dokumenten finden Sie in der integrierten Hilfe von Microsoft Word. Klicken Sie im Menü ? auf Microsoft Word-Hilfe und geben Sie Wiederherstellung in den Office- oder Hilfe-Assistenten ein. Klicken Sie danach auf Suchen, um das Thema anzuzeigen.

Falls Microsoft Word Ihr Dokument nicht öffnen oder wiederherstellen kann, finden Sie im nachstehenden Abschnitt "Weitere Informationen" in diesem Artikel nützliche Hinweise dazu, wie Sie Ihr Word-Dokument eventuell wiederherstellen können.

Weitere Informationen

Die folgenden Themen werden in diesem Artikel behandelt:

Identifizieren eines beschädigten Dokuments

Beschädigte Dokumente verhalten sich häufig in einer Art und Weise, die nicht der normalen Funktion des jeweiligen Programms entspricht (zum Beispiel unzählige Seitenumbrüche, inkorrektes Dokumentlayout und fehlerhafte Formatierung, nicht lesbare Zeichen auf dem Bildschirm, Fehlermeldungen während der Verarbeitung, System reagiert beim Laden oder Einsehen der Datei nicht mehr oder stürzt ab, oder es kommt zu einem anderen ungewöhnlichen Verhalten, das nicht der normalen Funktion des Programms zugeschrieben werden kann). Einige dieser Symptome können auch andere Ursachen als ein beschädigtes Dokument haben. Verwenden Sie die folgenden Problembehandlungsschritte, um solche anderen Ursachen auszuschließen:
  1. Öffnen Sie das Dokument, in dem das Problem auftritt.
  2. Klicken Sie im Menü Extras auf Vorlagen und Add-Ins.
  3. Ist im Feld Dokumentvorlage eine andere Vorlage als Normal aufgeführt, klicken Sie auf Anhängen.
  4. Im Ordner Vorlagen klicken Sie bitte auf Normal (Normal.dot). Klicken Sie dann auf Öffnen.
  5. Klicken Sie auf OK, um das Dialogfeld Vorlagen und Add-Ins zu schließen.
  1. Klicken Sie auf Start, zeigen Sie auf Einstellungen und klicken Sie dann auf Drucker.
  2. Klicken Sie mit der rechten Maustaste auf den Drucker, den Sie entfernen möchten, und klicken Sie danach auf Löschen.
  3. Wenn Sie gefragt werden, ob Sie alle diesem Drucker zugeordneten Dateien entfernen möchten, klicken Sie auf Ja.
  4. Klicken Sie auf Start, zeigen Sie auf Einstellungen und klicken Sie dann auf Drucker.
  5. Klicken Sie doppelt auf Neuer Drucker und befolgen Sie dann die Anweisungen des Assistenten für die Druckerinstallation, um Ihren Windows-Druckertreiber neu zu installieren.
  • Prüfen Sie, ob andere Dokumente ein ähnliches Verhalten aufweisen.
  • Prüfen Sie, ob andere Programme ein ähnliches Verhalten aufweisen.
  • Nehmen Sie das Dokument und prüfen Sie, ob das jeweilige Verhalten auch auf einem anderen Computer auftritt.
  • Ändern Sie die dem Dokument zugeordnete Vorlage und verwenden Sie die globale Vorlage (Normal.dot). Ist dem Dokument die Vorlage Normal.dot zugeordnet, beenden Sie Word und benennen Sie die Vorlage Normal.dot um. Starten Sie Word neu und versuchen Sie, das Verhalten zu reproduzieren.
  • Führen Sie die folgenden Schritte aus, um die zugeordnete Vorlage durch die globale Vorlage zu ersetzen:


  • Starten Sie Word mit seinen Standardeinstellungen. Sie können die Befehlszeilenoption "/a" verwenden, um Word zu starten und zu verhindern, dass Word Add-Ins lädt oder die vorhandene Vorlage Normal.dot verwendet. Nachdem Sie Word mit der Befehlszeilenoption "/a" gestartet haben, versuchen Sie, das Verhalten zu reproduzieren.
  • Verwenden Sie einen anderen Druckertreiber und versuchen Sie, das Verhalten zu reproduzieren. Tritt das Verhalten auch bei Verwendung eines anderen Druckertreibers auf, müssen Sie Ihren vorhandenen Druckertreiber möglicherweise trotzdem vollständig entfernen und neu installieren.

    -oder-

    Ersetzen Sie den vorhanden Druckertreiber wie folgt: Weitere Informationen zur Behandlung von Druckerproblemen in Microsoft Windows finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
    128345 Troubleshooting Printing Problems in Windows 95/98
    93503 Isolating General Printing Problems
    163551 Troubleshooting Printing Problems in Windows NT 4.0
    132460 Troubleshooting Windows NT Print Server Alteration of Print Jobs
  • Ändern Sie andere Systemkomponenten (wie z.B. Videotreiber oder Schriftarten) und beenden Sie alle laufenden Drittanbieterprogramme (wie zum Beispiel speicherresidente Programme [TSRs], Schriftarten-Manager, Bildschirmschoner und System-Shells) und versuchen Sie dann, das Verhalten zu reproduzieren. Weitere Informationen zum Deaktivieren von Programmen, die mit Windows gestartet werden, finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
    192926 How to Perform Clean-Boot Troubleshooting for Windows 98
    180902 How to Start a Windows 98-Based Computer in Safe Mode
    155681 Troubleshooting Display Problems in Windows NT 4.0
Tritt das Problem nur bei einem einzigen Dokument oder einer kleinen Gruppe ähnlicher Dokumente auf, nachdem Sie die vorstehend beschriebenen Schritte durchgeführt haben, liegt wahrscheinlich eine Beschädigung dieses Dokuments bzw. dieser Gruppe von Dokumenten vor.



Was Sie tun können, wenn das Dokument zwar geöffnet wird, aber ein unerwartetes Verhalten zeigt

Methode 1: Speichern Sie das Dokument in einem anderen Format und konvertieren Sie es dann zurück zu Word

Dies ist die einfachste und umfassendste Methode zur Wiederherstellung eines Dokuments, die Sie daher immer zuerst probieren sollten. Speichern Sie die Datei im Rich Text-Format (*.rtf) oder als Webseite (*.htm; *.html); in diesem Format werden die Formatierungen in Ihrem Word-Dokument beibehalten.

Nachdem Sie die Datei in einem anderen Format gespeichert haben, schließen Sie diese, öffnen Sie sie in Word für Windows neu, und speichern Sie die Datei dann als Word-Dokument (*.doc). Ist dieses Verfahren erfolgreich, wurde der Schaden an der Datei während des Konvertierungsvorgangs behoben. Ist der Schaden noch nicht behoben, speichern Sie die Datei in einem anderen Format.

Wir empfehlen, Ihre Datei in den folgenden Formaten zu speichern (halten Sie bitte die angegebene Reihenfolge ein):
  1. Rich Text-Format (*/rtf)
  2. Webseite (*.htm; *.html)
  3. Im Format eines beliebigen anderen Textverarbeitungsprogramms
  4. Nur Text (*.txt)
Wichtiger Hinweis: Durch das Speichern im Format "Nur Text" wird zwar in vielen Fällen der Schaden an einem Dokument behoben, es gehen jedoch auch alle Formatierungen, Grafiken und Makrocodes verloren. Sie haben bei diesem Verfahren also mehr Arbeit mit der Neuformatierung und sollten es nur dann anwenden, wenn das Problem nicht durch das Speichern in anderen Dateiformaten behoben werden kann.

Methode 2: Kopieren Sie das gesamte Dokument mit Ausnahme der letzten Absatzmarke in ein neues Dokument

Word für Windows assoziiert eine breite Palette von Formatierungsmerkmalen mit der letzten Absatzmarke, insbesondere Abschnitts- und Formatformatierungen. Wenn Sie alles mit Ausnahme der letzten Absatzmarke in ein neues Dokument kopieren, wird der Schaden also möglicherweise im Originaldokument zurückgelassen. Stellen Sie dann im neuen Dokument die ursprünglichen Abschnitts- und Formatformatierungen wieder her.

Anmerkung: Sie können das gesamte Dokument mit Ausnahme der letzten Absatzmarke auswählen, indem Sie [Strg]+[Ende] und dann [Strg]+[Umschalttaste]+[Pos1] drücken. Falls Ihr Dokument Abschnittswechsel enthält, kopieren Sie nur den Text zwischen den Abschnittswechseln (Sie sollten die Abschnittswechsel nicht kopieren und einfügen, weil Sie so möglicherweise den Schaden in Ihr neues Dokument übertragen).

Arbeiten Sie mit Ihrem Word-Dokument bitte in der Normalansicht, wenn Sie in verschiedenen Dokumenten Abschnitte kopieren und einfügen, um zu vermeiden, dass Sie Abschnittswechsel von einem Dokument in das andere übertragen. Um in die Normalansicht zu wechseln, klicken Sie bitte im Menü Ansicht auf Normal.

Methode 3: Kopieren Sie die unbeschädigten Teile des Dokuments in ein neues Dokument

In manchen Fällen können Sie die Stelle ermitteln, an der Ihr Dokument beschädigt ist. In einem solchen Fall kopieren Sie das gesamte Dokument mit Ausnahme des beschädigten Teils in eine neue Datei und rekonstruieren Sie dann den beschädigten Teil Ihres Dokuments.

Anmerkung: Falls Ihr Dokument Abschnittswechsel enthält, kopieren Sie nur den Text zwischen den Abschnittswechseln (Sie sollten die Abschnittswechsel nicht kopieren und einfügen, weil Sie so möglicherweise den Schaden in Ihr neues Dokument übertragen).

Arbeiten Sie mit Ihrem Word-Dokument bitte in der Normalansicht, wenn Sie in verschiedenen Dokumenten Abschnitte kopieren und einfügen, um zu vermeiden, dass Sie Abschnittswechsel von einem Dokument in das andere übertragen. Um in die Normalansicht zu wechseln, klicken Sie bitte im Menü Ansicht auf Normal.



Was Sie versuchen können, wenn das Dokument nicht geöffnet werden kann

Es gibt diverse Techniken, die Sie einsetzen können, um ein Dokument zu öffnen, das auf normalem Wege nicht geöffnet wurde. Welches dieser Verfahren Sie anwenden sollten, ist davon abhängig, welcher Art und wie schwerwiegend die Beschädigung Ihres Dokuments ist und welches Verhalten das Dokument zeigt. Obwohl viele dieser Verfahren häufig erfolgreich sind, kann nicht jedes beschädigte Dokument wiederhergestellt werden.

Methode 1: Öffnen Sie das beschädigte Word-Dokument im Konzeptmodus ohne Verknüpfungsaktualisierung

Manchmal können Sie ein Dokument im Konzeptmodus ohne Verknüpfungsaktualisierung öffnen, wenn es auf andere Art und Weise nicht geöffnet werden kann. Führen Sie hierzu die folgenden Schritte aus:
  1. Klicken Sie im Menü Ansicht auf Normal.
  2. Klicken Sie im Menü Extras auf Optionen.
  3. In der Registerkarte Ansicht aktivieren Sie bitte die Kontrollkästchen Konzeptschriftart und Platzhalter für Grafiken.
  4. In der Registerkarte Allgemein deaktivieren Sie bitte das Kontrollkästchen Automatische Verknüpfungen beim Öffnen aktualisieren. Klicken Sie auf OK.
Ist der Versuch, das Dokument zu öffnen, jetzt erfolgreich, können Sie die Datei möglicherweise wiederherstellen oder reparieren, indem Sie die Schritte aus dem Abschnitt "Was Sie tun können, wenn das Dokument zwar geöffnet wird, aber ein unerwartetes Verhalten zeigt" in diesem Artikel ausführen.

Methode 2: Fügen Sie das Dokument als Datei in ein neues Dokument ein

Die letzte Absatzmarke in einem Word-Dokument enthält Informationen über das Dokument. Ist das Dokument beschädigt, können Sie den Text des Dokuments möglicherweise retten, wenn es Ihnen gelingt, diese letzte Absatzmarke wegzulassen.

Um auf ein Dokument zuzugreifen und dabei die letzte Absatzmarke wegzulassen, gehen Sie bitte wie folgt vor:
  1. Klicken Sie im Menü Datei auf Neu.
  2. Auf der Registerkarte Allgemein klicken Sie bitte auf die Option Leeres Dokument. Klicken Sie dann auf OK.
  3. Klicken Sie im Menü Einfügen auf Datei.
  4. Wählen Sie im Dialogfeld Datei einfügen das beschädigte Dokument aus und klicken Sie dann auf Einfügen.
Anmerkung: Sie müssen möglicherweise einige Formatierungen für den letzten Abschnitt Ihres neuen Dokuments erneut vornehmen.

Methode 3: Öffnen Sie die Datei, indem Sie eine Verknüpfung zu ihr herstellen

Falls das Einfügen des Dokuments als Datei in ein neues Dokument (Methode 2) nicht erfolgreich ist, versuchen Sie es mit der folgenden Methode.

Mit diesem Verfahren können Sie die Datei öffnen, wenn sich ein Teil der Kopfzeile oder die letzte Absatzmarke im beschädigten Teil des Dokuments befinden.

Mit den folgenden Schritten erstellen Sie eine Verknüpfung zu einer unbeschädigten Datei und ändern die Verknüpfung dann so, dass sie auf die beschädigte Datei verweist:
  1. Klicken Sie im Menü Datei auf Neu.
  2. Auf der Registerkarte Allgemein klicken Sie bitte auf die Option Leeres Dokument. Klicken Sie dann auf OK.
  3. In dem neuen Dokument geben Sie bitte Dies ist ein Test ein und speichern dann das Dokument.
  4. Markieren Sie den Text und klicken Sie dann im Menü Bearbeiten auf Kopieren.
  5. Klicken Sie im Menü Datei auf Neu.
  6. Auf der Registerkarte Allgemein klicken Sie bitte auf die Option Leeres Dokument. Klicken Sie dann auf OK.
  7. In diesem neuen Dokument klicken Sie im Menü Bearbeiten auf Inhalte einfügen.
  8. Klicken Sie auf die Optionen Formatierter Text und Verknüpfung einfügen und dann auf OK.
  9. Klicken Sie im Menü Bearbeiten auf Verknüpfungen.
  10. Wählen Sie im Dialogfeld Verknüpfungen den Dateinamen des verknüpften Dokuments aus und klicken Sie dann auf Quelle ändern.
  11. Wählen Sie im Dialogfeld Quelle ändern das Dokument aus, das Sie nicht mehr öffnen können, und klicken Sie dann auf Öffnen.
  12. Klicken Sie auf OK, um das Dialogfeld Verknüpfungen zu schließen.

    Anmerkung: Die Daten/der Text aus dem beschädigten Dokument sollten jetzt angezeigt werden (sofern es wiederherstellbare Daten/Text enthielt).
  13. Klicken Sie im Menü Bearbeiten auf Verknüpfungen.
  14. Klicken Sie im Dialogfeld Verknüpfungen auf Verknüpfung lösen. Wenn die folgende Meldung erscheint, klicken Sie auf Ja.
  15. Sind Sie sicher, dass Sie die ausgewählten Verknüpfungen aufheben möchten?
Sie können das wiederhergestellte Dokument jetzt neu formatieren und speichern.

Methode 4: Verwenden Sie den Konverter "Text aus beliebiger Datei wiederherstellen"

Der Konverter Text aus beliebiger Datei wiederherstellen bietet Ihnen die Möglichkeit, den Text aus einer beliebigen Datei zu extrahieren. Bei dieser Datei muss es sich nicht um eine Word-Datei handeln. Es gibt jedoch Einschränkungen bei der Verwendung des Konverters Text aus beliebiger Datei wiederherstellen. Die Formatierung des Dokuments und alle seine Bestandteile, bei denen es sich nicht um Text handelt, gehen verloren. So zum Beispiel Grafiken, Felder, Zeichnungsobjekte, usw. Kopfzeilen, Fußzeilen, Fußnoten, Endnoten und Feldtext, bleiben jedoch als einfacher Text erhalten.

Nachdem das Dokument unter Verwendung des Konverters Text aus beliebiger Datei wiederherstellen wiederhergestellt worden ist, verbleiben vor allem oben und unten in dem Dokument einige binäre Daten, die nicht konvertiert werden konnten. Diese binären Daten müssen gelöscht werden, bevor Sie Ihre Datei neu formatieren und als Word-Dokument speichern. Weitere Informationen über die Verwendung des Konverters "Text aus beliebiger Datei wiederherstellen" finden Sie im folgenden Artikel in der Microsoft Knowledge Base:
290946 WD2002: How to Recover Text from Any File

Methode 5: Öffnen Sie die Datei in WordPad

Wenn ein beschädigtes Dokument nicht in Word für Windows geöffnet werden kann (in der Regel aufgrund einer Beschädigung im Dateikopf), können Sie den Dateikopf löschen und die Datei als Text öffnen. Wenn Sie die Kopfinformationen löschen, gehen alle Formatierungsmerkmale verloren. Bei dem nachstehend beschriebenen Verfahren werden die Informationen im Dateikopf gelöscht.
  1. Klicken Sie auf Start, zeigen Sie auf Programme und auf Zubehör, und klicken Sie dann auf WordPad.
  2. Klicken Sie im Menü Datei auf Öffnen. Öffnen Sie das beschädigte Word-Dokument.

    Das Word-Dokument müsste jetzt als Textdatei geöffnet werden. Sie sehen möglicherweise binäre (fremd aussehende) Zeichen am Anfang und am Ende des Dokuments. Sie können diese Zeichen und sonstige Zeichen, die nicht zu Ihrem beschädigten Word-Dokument gehören, jetzt löschen.
  3. Klicken Sie im Menü Datei auf Speichern unter. In das Feld Dateiname geben Sie einen neuen Dateinamen mit der Dateinamenerweiterung .doc ein. Bevor Sie auf die Schaltfläche OK klicken, notieren Sie sich den Ordner, in dem die Datei gespeichert wird, damit Sie diesen leicht wiederfinden können, wenn Sie Word neu starten.
  4. Klicken Sie im Menü Datei auf Beenden.
  5. Starten Sie Word neu und öffnen Sie die Datei, die Sie in WordPad gespeichert haben (die Datei hat den Namen, den Sie ihr in Schritt 3 gegeben haben).
  6. Klicken Sie im Menü Datei auf Speichern unter und speichern Sie dann die Datei im Format Word-Dokument (*.doc).
Sie können Ihr neues Dokument jetzt neu formatieren und Grafiken, Felder oder sonstige Formatierungsmerkmale wieder hinzufügen, die Ihr beschädigtes Dokument enthalten hatte.



Microsoft-Supportoptionen

Falls Sie das Problem nicht selbst beheben können, stehen Ihnen diverse Supportoptionen offen.

Finden Sie online schnell Antworten auf Ihre Fragen

Mit dem Microsoft Online Support können Sie die Microsoft Knowledge Base und andere technische Ressourcen nach schnell verfügbaren und exakten Antworten auf Ihre Fragen durchsuchen. Sie können diese Site auch an Ihre Bedürfnisse anpassen, um so Ihre Suche sinnvoll zu steuern.

Um mit der Suche zu beginnen, browsen Sie bitte zu der folgenden Website:
http://www.microsoft.com/support/

Microsoft Software Services

Setzen Sie sich mit den Fachleuten vom Microsoft-Kundendienst in Verbindung, die Sie bei der Lösung Ihres Problems gerne unterstützen.

Für weitere Information dazu, wie Sie Hilfestellung für die Behandlung von Problemen mit Microsoft Windows erhalten können, klicken Sie bitte auf Hilfethemen im Menü ? des Windows-Explorers. Klicken Sie in der Registerkarte Inhalt doppelt auf das Buch Problembehandlung und Verwaltung, um es zu öffnen. Klicken Sie dann doppelt auf das Buch Microsoft-Kundendienst, um sich Ihre Supportoptionen anzusehen.

Für weitere Information dazu, wie Sie Hilfestellung für die Behandlung von Problemen mit Microsoft Word erhalten können, klicken Sie bitte auf Info im Menü ? und klicken Sie dann auf Kundendienst.

Weitere Informationen über die Microsoft Software Services finden Sie im folgenden Artikel der Microsoft Knowledge Base:
102344 Microsoft Product Support Options Q&A

Microsoft Solution Provider

Microsoft Solution Provider sind unabhängige Organisationen, die mit Microsoft zusammenarbeiten, um gestützt auf entsprechende Technologien geschäftliche Probleme von Unternehmen aller Größen und Branchen zu lösen.

Fragen Sie bitte Ihre örtliche Microsoft-Niederlassung, wie Sie sich mit einem Microsoft Solution Provider in Verbindung setzen können. Um die für Sie zuständige Niederlassung zu finden, besuchen Sie bitte die Microsoft World Wide Offices-Website unter der folgenden Adresse:
http://www.microsoft.com/worldwide/default.htm



Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.

Eigenschaften

Artikel-ID: 290932 - Geändert am: Donnerstag, 7. September 2006 - Version: 2.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Word 2002 Standard Edition
Keywords: 
kbdta kbfaq kbhowto kbtshoot KB290932
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com