Remote Disk Management Has No Reconnect Functionality

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Article ID: 233402 - View products that this article applies to.
This article was previously published under Q233402
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SYMPTOMS

While you are performing remote disk administration using either the Computer Management (Compmgmt.msc) or Disk Management (Diskadmin.msc) snap-in, you may receive the following error message:
The object invoked had disconnected from its clients.
This occurs if the remote connection times out (the session is left idle for period of time), and you then try to perform a disk administration function.

CAUSE

The Disk Management console has no "reconnect" function. This is also apparent when you try to establish a remote session initially and you receive the generic console message "Failed connection to Logical Disk Manager Service." At this point you cannot retry the operation.

RESOLUTION

Your only option when either of the messages listed above occurs is to close the Disk Management or Computer Management console and restart it to try to establish a new remote connection.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Most of the Computer Management console functions (such as Event log, Device Manager, System Information, and Services) dynamically reconnect and continue to work if a time-out occurs without restarting.

Removable Storage Manager (RSM) has a Connect option that you can use to reconnect to the remote computer.

Properties

Article ID: 233402 - Last Review: October 21, 2013 - Revision: 3.2
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Datacenter Server
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kbnosurvey kbarchive kbprb KB233402

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