Help and Support Search Results Are Unreadable If Your User Interface Is Set to a User Interface That Is Not an English-Language User Interface

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Article ID: 309431 - View products that this article applies to.
This article was previously published under Q309431
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SYMPTOMS

When you use the Windows XP Help and Support tool, information that is displayed in the Search Results pane may be unreadable.

CAUSE

This problem can occur when the following conditions are true:
  • You are using a Windows XP Professional-based computer with the Multilingual User Interface (MUI) pack.
  • You are using a user interface (UI) that is not an English-language UI, for example, if you are using a Japanese UI.
  • Your language for non-Unicode programs setting does not match your UI language.
The search results pane is non-Unicode. The text for the search results is applied against the code page for the computer locale. If the current user's UI does not match the language for non-Unicode programs setting in the Regional and Language Options tool in Control Panel, the text that is displayed is unreadable.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date        Time   Version        Size     File name
   ------------------------------------------------------
   01-20-2003  11:12  5.1.2600.1158  696,832  Helpsvc.exe
For additional information about additional updates that you must apply for a complete solution, click the following article numbers to view the articles in the Microsoft Knowledge Base:
327405 Windows XP Documentation Update Can Help You Understand How to Make Your Computer More Secure
330901 Windows XP Documentation Update to Correct English Text in Japanese Help

WORKAROUND

To work around this problem:
  1. Click Start, and then click Control Panel.
  2. Click Date, Time, Language, and Regional Options.
  3. Click Regional and Language Options.
  4. Click the Advanced tab.
  5. Click the language that matches your UI in the Select a language to match the language version of the non-Unicode programs you want to use box.
  6. Restart your computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

Properties

Article ID: 309431 - Last Review: October 12, 2005 - Revision: 3.5
APPLIES TO
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbhotfixserver kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug kbui KB309431

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