Drive Letters of Mapped Network Drives Are Missing in Windows Explorer

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Article ID: 810087 - View products that this article applies to.
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SYMPTOMS

You may find that mapped drive letters to shared network folders are missing in Windows Explorer when you use the Work online without synchronizing changes over a virtual private network (VPN) connection.

CAUSE

This problem may occur if the following conditions are true:
  • You connect to your network by using a VPN connection over a dial-up connection to the Internet.
  • You map a drive letter to a shared folder on the network.
  • The shared folder contains files or folders (or both) that are configured for offline use.
In this situation, when you disconnect from and reconnect to your network, click the Offline Files icon in the notification area of the task bar, and then click Work online without synchronizing changes, the drive letter of the shared network folder that you mapped may no longer be listed in Windows Explorer.

Note that the actual drive mapping to the shared folder is retained. However, the icon that represents the drive mapping is not listed in Windows Explorer.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP

Date         Time   Version        Size     File name
-------------------------------------------------------
31-Jan-2003  00:57  5.1.2600.1161   44,032   Basesrv.dll      
21-Jan-2003  18:57  5.1.2600.1158  483,328  Winlogon.exe 

Windows XP 64-Bit Edition

Date         Time   Version        Size     File name
--------------------------------------------------------
31-Jan-2003  00:57  5.1.2600.1161  140,288   Basesrv.dll   
21-Jan-2003  18:55  5.1.2600.1158  647,168  Winlogon.exe

WORKAROUND

To work around this problem, access the mapped drive and its contents from the command prompt. To connect to the mapped drive from a command prompt:
  1. Click Start, and then click Run.
  2. Type cmd in the Open box, and then click OK.
  3. At the command prompt, type the drive letter of the mapped network drive, and then press ENTER. For example, if you mapped the shared network folder to drive Z, type Z:, and then press ENTER.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

Properties

Article ID: 810087 - Last Review: August 29, 2007 - Revision: 3.1
APPLIES TO
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug KB810087

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