Audio and video may no longer be synchronized after you issue a fast-forward command or a rewind command during DVD playback

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Article ID: 813347 - View products that this article applies to.
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SYMPTOMS

When you issue a fast-forward command or a rewind command during DVD playback, the audio may no longer be synchronized to the video. Other seek operations may cause the same problem.

CAUSE

After a seek operation is performed, the Portcls.sys system file no longer reports the correct audio playback position. This causes a timing problem with the clock that is used to synchronize the audio stream and the video stream. This problem occurs if both the following conditions are true:
  • The audio driver is Portcls WavePCI-based.
    This problem does not occur with the Portcls WaveCyclic-based audio driver.
  • The DVD playback application uses the DirectShow WaveAudio audio-rendering filter.
This problem does not occur with the DirectShow DirectSound audio-rendering filter.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name      Platform
   --------------------------------------------------------------------------
   19-Apr-2003  00:54  5.1.2600.1208     132,480  Portcls.sys    Windows XP

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

Properties

Article ID: 813347 - Last Review: February 27, 2014 - Revision: 5.2
APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional SP1
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbtshoot kbwinxpsp2fix kbwinxppresp2fix kbbug kbddk kbfix kbqfe kbwdm KB813347

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