Cannot Connect to a Network Share over a VPN Connection

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Article ID: 817069 - View products that this article applies to.
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SYMPTOMS

After you establish a virtual private network (VPN) connection with a server, you cannot connect to any shares on the server. You can ping the server by name and Internet Protocol (IP) address, but cannot connect to shares on the server. Net View and Net Use commands fail with one of the following error messages:
System error 121. The semaphore timeout period has expired
System error 53. The network path was not found.
System error 64. The specified network name is no longer available.

CAUSE

This problem occurs because the TCP window size for the TCP connection for the VPN client is 0 (zero).

RESOLUTION

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   17-Mar-2003  17:11  5.0.2195.6687     119,024  Afd.sys
   20-Mar-2003  09:14  5.0.2195.6602     108,816  Msafd.dll        
   20-Mar-2003  09:14  5.0.2195.6691     314,704  Tcpip.sys
   15-Jan-2003  10:56  5.0.2195.6655      16,240  Tdi.sys
   20-Mar-2003  09:14  5.0.2195.6601      17,680  Wshtcpip.dll     
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.

MORE INFORMATION

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product

Properties

Article ID: 817069 - Last Review: February 19, 2007 - Revision: 1.8
APPLIES TO
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwin2ksp4fix kberrmsg kbprb kbwin2000presp4fix kbfix kbbug KB817069

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