A Minimized Program Window That Is Hung (Is Not Responding) May Not Be Restored Correctly and a Second Minimized Window Appears

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Article ID: 817611 - View products that this article applies to.
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SYMPTOMS

A minimized window of a program that is hung (with a status of "Not Responding" in Windows Task Manager) may not be restored correctly when you click the Restore button. Also, while the program is not responding, a second minimized window may appear next to the original window. You can move the second window, but the first window remains where the screen has not been overwritten yet.

CAUSE

The Windows XP Ghost Window feature creates ghost windows on behalf of a program when the program does not respond correctly to window messages within several seconds and is considered to be hung. This feature may not correctly restore the properties of a minimized window, and may create a second minimized title bar window beside the original window but not overwrite it.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name    Platform
   --------------------------------------------------------------------
   15-Jul-2003  21:01  5.1.2600.1247   1,677,056  Win32k.sys   x86
   15-Jul-2003  21:01  5.1.2600.1247   5,619,840  Win32k.sys   IA-64

WORKAROUND

You can use the Application Compatibility Toolkit to create and install a custom Application Compatibility database to disable the Ghost Window feature for your program. To download the Application Compatibility Toolkit, visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/library/aa286552.aspx
To create a custom Application Compatibility database:
  1. Install and run the Compatibility Administrator tool (add the /x switch to the command line for advanced features).
  2. Right-click Custom Database, and then click New.
  3. Right-click the new database, and then click Rename.
  4. Type noghost as the name of the database.
  5. Right-click New Database, click Create New, and then click Application Fix. Type the name of the program to be fixed.
  6. Type the name of the program manufacturer.
  7. Locate and then click the appropriate program (.exe) file.
  8. Click Next.
  9. In the Compatibility Modes window, click None, and then click Next.
  10. In the Compatibility Fixes list, click NoGhost.
  11. Click either Test Run or Finish. Clicking Test Run starts the program with the Application Compatibility setting. Clicking Finish adds the compatibility fix to your database.
  12. On the File menu, click Save to save the database. Or, copy the database to the C:\Windows\AppPatch folder.
  13. Right-click the database, and then click Install. Or, run the sdbinst c:\windows\apppatch\noghost.sdb -q command to install the database.

MORE INFORMATION


The following information about the GetMessage function is documented for the Ghost Window feature in Windows XP. For more information, visit the following Microsoft Web site:
GetMessage Function
If a top-level window stops responding to messages for more than several seconds, the system considers the window to be hung and replaces it with a ghost window that has the same z-order, location, size, and visual attributes. This allows the user to move it, resize it, or even close the application. However, these are the only actions available because the application is actually hung. When in the debugger mode, the system does not generate a ghost window.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

Properties

Article ID: 817611 - Last Review: August 29, 2007 - Revision: 6.1
APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Media Center Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug KB817611

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