Roaming profiles are not saved when a user logs off a Microsoft Windows 2000-based computer or a Microsoft Windows XP-based computer

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Article ID: 819536 - View products that this article applies to.
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SYMPTOMS

Roaming profiles are not saved when a user logs off a Microsoft Windows 2000-based computer or a Microsoft Windows XP-based computer. The following error message is logged in the application event log:

Source: Userenv
Type: Error
Category: None
Event: 1000

Description: Windows cannot unload your registry file. If you have a roaming profile, your settings are not replicated. Contact your administrator. DETAIL - Access is denied. Build number ((2195)).

The following message may be logged in the Userenv.log folder:
USERENV(854.794) 16:20:10:312 MyRegUnLoadKey: Hive unload for S-1-5-21-2121617444-1749639941-654838779-1469 failed due to open registry key. Windows will try unloading the registry hive once a second for the next 60 seconds (max). USERENV(854.794) 16:21:10:500 MyRegUnLoadKey: Windows was not able to unload the registry hive. USERENV(854.794) 16:21:10:500 MyRegUnLoadKey: Failed to unmount hive 5 USERENV(854.794) 16:21:10:500 MyRegUnloadKey: Mutex released. Returning 0. USERENV(854.794) 16:21:10:500 UnloadUserProfile: Didn't unload user profile <err = 5> USERENV(854.794) 16:21:10:500 DumpOpenRegistryHandle: 2 user registry Handles leaked from \Registry\User\S-1-5-21-2121617444-1749639941-654838779-1469 USERENV(854.794) 16:21:10:500 LoadUserProfile: Releasing mutex. USERENV(854.794) 16:21:10:500 UnloadUserProfile: Leaving with a return value of 0

CAUSE

This problem may occur if the user logon script uses Windows Management Instrumentation (WMI) to enumerate a registry key. For example, this problem may occur if the user uses a Microsoft Visual Basic logon script that calls the EnumKey function and the EnumValues function to read values in the registry. The Winmgmt.exe process may not release a handle on a registry key. When the user logs off, Windows cannot unload the registry hive.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows 2000
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Apr-2003  15:18  1.50.1085.105     180,312  Stdprov.dll 
Windows XP Professional 64-bit Edition (Itanium)
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   13-Jun-2003  15:09  5.1.2600.1234     295,424  Stdprov.dll      IA-64
Windows XP, 32-bit x86-based versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   13-Jun-2003  15:09  5.1.2600.1234      81,408  Stdprov.dll 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

REFERENCES

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
836051 A Visual Basic script creates registry subkeys and values very slowly under the HKEY_CURRENT_USER subtree on a Windows XP-based computer
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 819536 - Last Review: October 25, 2006 - Revision: 4.7
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Tablet PC Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbscript kbprofiles kbwbem kbclientserver kbclient kbwin2000sp5fix kbwinxppresp2fix kbwin2000presp5fix kbpolicy kblogin kbevent kbuser kbqfe kbfix kbbug KB819536

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