PEAP authentication is not successful when you connect to a third-party RADIUS server

Article translations Article translations
Article ID: 885453
Expand all | Collapse all

On This Page

Symptoms

After you install Microsoft Windows XP Service Pack 2 (SP2), your Protected Extensible Authentication Protocol (PEAP) connection does not authenticate successfully. This failure occurs during an authentication attempt to a third-party Remote Authentication Dial-In User Service (RADIUS) server.

Note Sometimes the initial connection may authenticate successfully, but subsequent fast-connect authentication attempts may not connect successfully.

Cause

This issue occurs if your third-party RADIUS server uses a different method to calculate the Extensible Authentication Protocol (EAP) Type:Length:Value format (EAP-TLV) id than the method that Windows XP uses.

Note Windows XP SP2 added additional validity checking on the EAP-TLV data that is embedded in the PEAP packets.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows XP Service Pack 2 (SP2) installed to install this hotfix.

Restart information

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix is not replaced by any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name   Platform
   ----------------------------------------------------------------
   25-Sep-2004  01:39  5.1.2600.2523  112,128  Rastls.dll  x86

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

More information

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 885453 - Last Review: June 20, 2014 - Revision: 3.0
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbwinxpsp3fix kbwinxppresp3fix kbfix kbbug KB885453

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com