A program closes when you move the mouse pointer over the program file in the Open, Save, or Save As dialog box on a Windows XP Service Pack 2-based computer

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Article ID: 909486
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SYMPTOMS

You move the mouse pointer over a program file in the Open, Save, or Save As dialog box on a Microsoft Windows XP Service Pack 2 (SP2)-based computer. After you do this, the program abruptly closes.

Note For more information about how to reproduce this problem, see the "More Information" section.

CAUSE

This problem occurs if you use a program that implements the shell column provider feature on your computer. For example, when you install Adobe Reader 7, the shell column provider file (PDFshell.dll) is installed on your computer.

An access violation occurs because Windows tries to reference the pointer of the shell column provider without loading the shell column provider. Therefore, the program closes abruptly.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites.

Restart requirement

You must restart the computer after you apply this update.

Update replacement information

This update does not replace any other updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Shell32.dll6.0.2900.28008,452,60819-Nov-200503:52x86SP2SP2QFE
Xpsp3res.dll5.1.2600.280021,50419-Nov-200502:11x86SP2SP2QFE

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Steps to reproduce this problem

  1. On a Microsoft Windows XP SP2-based computer, you click Open, Save, or Save As on the File menu to open or to save a file in a program.
  2. You click Desktop in the Open, Save, or Save As dialog box.
  3. You move the mouse pointer over a file, and then close the dialog box after the tool tip file information is displayed. You open the Open, Save, or Save As dialog box again, and then move the mouse pointer over the same file.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

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Article ID: 909486 - Last Review: October 9, 2011 - Revision: 3.0
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbwinxppresp3fix kbwinxpsp3fix kbfix kbbug KB909486

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