The Licensing Diagnosis tool returns a value of “0” for the number of RDS CALs that are available in Windows Server 2008 R2

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Article ID: 980933 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • You install Remote Desktop Services (RDS) on a server that is running Windows Server 2008 R2.
  • You install a Windows Management Instrumentation (WMI) provider.
  • This WMI provider implements a WMI class that is derived from the Win32_ComputerSystem class.
  • This WMI provider overrides an instance of the Win32_ComputerSystem class.
  • You run the Licensing Diagnosis tool by using the Remote Desktop Session Host Configuration snap-in.
In this scenario, the Licensing Diagnosis tool returns a value of 0 for the number of RDS Client Access Licenses (CALs) that are available.

Note This reporting issue does not affect the ability of a client to request an RDS client access license.

CAUSE

The issue occurs because the Licensing Diagnosis tool cannot enumerate the instances of the Win32_ComputerSystem class because another class is derived from the Win32_ComputerSystem class. Therefore, the Licensing Diagnosis tool reports that the number of CALs that are available is 0.

Note The Licensing Diagnosis tool needs the Win32_ComputerSystem class to retrieve the number of RDS CALs that are available from a Remote Desktop license server.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There is no prerequisite to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Lsdiag.dll6.1.7600.20660245,76005-Mar-201008:07x86
Lsdiagres.dll6.0.0.089,60014-Jul-200901:28x64
Tsconfig.dll6.1.7600.206601,077,24805-Mar-201008:10x86
Lsdiag.dll6.1.7600.20660245,76005-Mar-201007:36x86
Lsdiagres.dll6.0.0.089,60014-Jul-200901:06x86
Tsconfig.dll6.1.7600.206601,077,24805-Mar-201007:33x86
For all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Lsdiag.dll6.1.7600.20660245,76005-Mar-201007:20x86
Lsdiagres.dll6.0.0.089,60014-Jul-200901:36IA-64
Tsconfig.dll6.1.7600.206601,077,24805-Mar-201007:23x86
Lsdiag.dll6.1.7600.20660245,76005-Mar-201007:36x86
Lsdiagres.dll6.0.0.089,60014-Jul-200901:06x86
Tsconfig.dll6.1.7600.206601,077,24805-Mar-201007:33x86

WORKAROUND

Workaround for Windows Server 2008 R2

To work around this issue, use the Remote Desktop Licensing Manager snap-in to obtain the correct number of CALs that are available for RDS. Do not use the Licensing Diagnosis tool.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
977686 The Licensing Diagnosis tool incorrectly reports that there are no available Terminal Services client access licenses in Windows Server 2008
For more information about RDS, visit the following Microsoft TechNet Web site:
What's new in Remote Desktop Services

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_81d2742b15e92df5b158040ec143feee_31bf3856ad364e35_6.1.7600.20660_none_1c25c1c06770eb2d.manifest
File versionNot applicable
File size1,114
Date (UTC)05-Mar-2010
Time (UTC)10:56
PlatformNot applicable
File nameAmd64_microsoft-windows-t..tion-snapin-nonmsil_31bf3856ad364e35_6.1.7600.20660_none_75659c833df71be6.manifest
File versionNot applicable
File size18,331
Date (UTC)05-Mar-2010
Time (UTC)11:11
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,450
Date (UTC)05-Mar-2010
Time (UTC)10:56
PlatformNot applicable
File nameX86_microsoft-windows-t..tion-snapin-nonmsil_31bf3856ad364e35_6.1.7600.20660_none_194700ff8599aab0.manifest
File versionNot applicable
File size18,327
Date (UTC)05-Mar-2010
Time (UTC)11:11
PlatformNot applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameIa64_016f0292f9b68bd0c71cd0b12cb94423_31bf3856ad364e35_6.1.7600.20660_none_ed6f4239d915e58a.manifest
File versionNot applicable
File size1,112
Date (UTC)05-Mar-2010
Time (UTC)10:56
PlatformNot applicable
File nameIa64_microsoft-windows-t..tion-snapin-nonmsil_31bf3856ad364e35_6.1.7600.20660_none_1948a4f58597b3ac.manifest
File versionNot applicable
File size18,329
Date (UTC)05-Mar-2010
Time (UTC)10:56
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,446
Date (UTC)05-Mar-2010
Time (UTC)10:56
PlatformNot applicable
File nameX86_microsoft-windows-t..tion-snapin-nonmsil_31bf3856ad364e35_6.1.7600.20660_none_194700ff8599aab0.manifest
File versionNot applicable
File size18,327
Date (UTC)05-Mar-2010
Time (UTC)10:56
PlatformNot applicable

Properties

Article ID: 980933 - Last Review: April 29, 2010 - Revision: 1.0
APPLIES TO
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Standard
Keywords: 
kbfix kbautohotfix kbhotfixserver kbsurveynew kbqfe kbexpertiseadvanced KB980933

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