"Cannot Open the File to Verify the Signature" Appears in Despool.log

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Article ID: 824722 - View products that this article applies to.
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SYMPTOMS

On a Systems Management Server (SMS) 2.0 primary site, you may notice a backlog of package (.pkg) files in the SMS\Inboxes\Despoolr.box folder. The SMS despooler component tries to process some instruction (.sni) files up to 100 times, and the following entries appear in Despool.log:
~Cannot open file C:\SMS\inboxes\despoolr.box\receive\2_gv3681.sni. Cause is 11

~Cannot open the file to verify the signature, Win32 error = 2

CAUSE

This problem may occur when another process (for example, an antivirus program) locks one of the instruction files or one of the package files when the SMS despooler tries to rename the file.

RESOLUTION

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have SMS Service Pack 5 (SP5) installed to apply this hotfix.

Restart Requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   ---------------------------------------------------------
   21-Jul-2003  11:28  2.0.1493.5146  1,630,624  Basesvr.dll 
Because of file dependencies, the most recent hotfix or feature that contains these files may also contain additional files.

How to Install the Hotfix

To Install the Hotfix Using the Hotfix Installer

Note This installation method is only for Intel-based computers.
  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Copy the Sms2.0-kb824722-SPN-x86-enu.exe hotfix file (where N is the service pack version) and the platform folders to the new folder.

    Note The update file must be located one folder level above the platform folders.
  3. From each primary and secondary site server in your environment, log on to your site server using an account that has administrative credentials.
  4. Quit SMS Administrator if it is running.
  5. Double-click the Sms2.0-kb824722-SPN-x86-enu.exe file.
  6. Follow the instructions in the wizard.

To Install the Hotfix Manually

  1. Create a folder in a location that is accessible to your SMS site servers.
  2. Click Start, click Run, and then type cmd in the Open box.
  3. At the command prompt, type SMS2.0-SPN-KB824722-X86-ENU.exe /x, where N is the service pack version.
  4. Extract the hotfixed files to the folder you just created.
  5. From each primary and secondary site server in your environment, log on to your site server using an account that has administrative credentials.
  6. Quit SMS Administrator if it is running.
  7. Stop all SMS services.
  8. Copy the updated Basesvr.dll file to the SMS installation folder.

    Note The SMS installation folder is SMS_Admin_Root\Bin\Platform, where SMS_Admin_Root is the folder containing your SMS site installation, and Platform is the computer architecture, such as "I386."
  9. Restart the SMS services.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

In typical operation, the SMS despooler receives an instruction file and a related data file (for example, an .sni file and a .pck file). The SMS despooler processes the instruction file and renames both files. If another process locks the .sni file or the .pck file, the SMS despooler cannot rename the file, and the SMS despooler logs the entries described in the "Symptoms" section earlier in this article.

Properties

Article ID: 824722 - Last Review: February 27, 2014 - Revision: 1.7
APPLIES TO
  • Microsoft Systems Management Server 2.0 Service Pack 5
Keywords: 
kbnosurvey kbarchive kbautohotfix kbqfe kbhotfixserver kbsoftwaredist kbfix kbbug kbsms200presp6fix KB824722

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