Replication may fail after a "dirty" system shutdown on a Windows Server 2003 R2-based computer that has DFSR installed

Article translations Article translations
Article ID: 943661 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

On a Windows Server 2003 R2-based computer that has Distributed File System Replication (DFSR) installed, replication may fail after a "dirty" system shutdown. For example, this problem may occur after a power outage or after a system failure.

When this problem occurs, the following events are logged in the DFSR event log:

Event ID 5014

Event Type: Warning
Event Source: DFSR
Event Category: None
Event ID: 5014
Date: Date
Time: Time
User: N/A
Computer: Computer name
Description:
The DFS Replication service is stopping communication with partner Partner name for replication group Group name due to an error. The service will retry the connection periodically.

Additional Information:
Error: 1726 (The remote procedure call failed.)
Connection ID: GUID
Replication Group ID: GUID

Event ID 2004

Event Type: Error
Event Source: DFSR
Event Category: None
Event ID: 2004
Date: Date
Time: Time
User: N/A
Computer: Computer name
Description:
The DFS Replication service stopped replication on volume Drive letter. This failure can occur because the disk is full, the disk is failing, or a quota limit has been reached. This can also occur if the DFS Replication service encountered errors while attempting to stage files for a replicated folder on this volume.

Additional Information:
Error: 9014 (Database failure)
Volume: GUID

CAUSE

The DFS Replication service incorrectly manages the DFSR database. This behavior causes an inconsistent status.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 R2 on the computer.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 R2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Dfsr.exe5.2.3790.30261,697,28015-Oct-200711:39x86
Windows Server 2003 R2 with Service Pack 2 (SP2), x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Dfsr.exe5.2.3790.41701,697,28015-Oct-200714:19x86
Windows Server 2003 R2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Dfsr.exe5.2.3790.30263,581,44015-Oct-200715:49x64
Windows Server 2003 R2 with SP2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Dfsr.exe5.2.3790.41703,581,44015-Oct-200715:59x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 943661 - Last Review: October 8, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
Keywords: 
kbautohotfix kbexpertiseinter kbwinserv2003postsp2fix kbbug kbfix kbhotfixserver kbqfe KB943661

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com