Dedicated dump files are unexpectedly truncated to 4 GB on a computer that is running Windows Server 2008 or Windows Vista and that has more than 4 GB of physical memory

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Article ID: 950858 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • On a computer that is running Windows Server 2008 or Windows Vista, you have more than 4 gigabytes (GB) of physical memory installed.
  • The system is configured to generate a full memory dump file.
  • The DedicatedDumpFile and DumpFileSize registry values are created. The value of the DumpFileSize parameter is larger than 4096.
In this scenario, the generated dump file is unexpectedly truncated to 4 GB.

Note To deploy, troubleshoot, and service large memory platforms, OEM partners and customers may have to create large dump files.

CAUSE

The issue is caused by the Crashdmp.sys module. An overflow issue occurs in this scenario, and this truncates the dump file.

RESOLUTION

Hotfix information for Windows Server 2008

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2008 installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2008, x86 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Crashdmp.sys6.0.6001.2214436,92027-Mar-200803:58x86
Windows Server 2008, Itanium-based version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Crashdmp.sys6.0.6001.2214473,78427-Mar-200804:32IA-64
Windows Server 2008, x64 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Crashdmp.sys6.0.6001.2214439,99227-Mar-200804:40x64

Hotfix information for Windows Vista

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Vista installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Crashdmp.sys6.0.6000.2080135,89627-Mar-200804:00x86
Windows Vista Service Pack 1, x86 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Crashdmp.sys6.0.6001.2214436,92027-Mar-200803:58x86
Windows Vista, x64 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Crashdmp.sys6.0.6000.2080139,99227-Mar-200804:13x64
Windows Vista Service Pack 1, x64 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Crashdmp.sys6.0.6001.2214439,99227-Mar-200804:40x64

MORE INFORMATION

By using the DedicatedDumpFile registry entry in Windows Server 2008 and in Windows Vista, a user can configure a registry setting to store a dump file in a location other than on the boot volume. The following information describes the DedicatedDumpFile and DumpFileSize registry entries, respectively:
Location: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl
Name: DedicatedDumpFile
Type: REG_SZ
Value: A dedicated dump file with the full path, such as c:\dedicateddumpfile.sys

Location: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl
Name: DumpFileSize
Type: REG_DWORD
Value: dump file size in megabyte.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 950858 - Last Review: May 30, 2008 - Revision: 3.1
APPLIES TO
  • Windows Server 2008 Standard
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Datacenter
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
Keywords: 
kbautohotfix kbexpertiseadvanced kbexpertiseinter kbhotfixserver kbqfe KB950858

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