WINS Server Sporadically Loses Name Resolution

Article translations Article translations
Article ID: 150520 - View products that this article applies to.
This article was previously published under Q150520
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

SYMPTOMS

A Windows NT Windows Internet Name Service (WINS) server may sporadically lose its ability to resolve NetBIOS names by means of WINS. This problem may also manifest itself as domain synchronization, browsing, or connectivity problems.

CAUSE

This problem can occur when a WINS server is configured to point to itself as the primary WINS server and the secondary WINS server is left blank. IPCONFIG /all may show the secondary WINS server to be its own IP address but no primary WINS server is listed. When this condition occurs, all WINS name resolution for this server is lost. This can effect browsing, domain synchronization and connectivity. However, clients pointing to this machine as a WINS server are unaffected. This condition may happen occasionally or not at all.

It is highly recommended that a WINS server point to itself as Primary and Secondary WINS in the TCP/IP configuration. If another configuration is used, you may experience random instability in making certain network connections.

For additional information, please see the following article(s) in the Microsoft Knowledge Base:

150737Setting Primary and Secondary WINS Server Options

WORKAROUND

On each WINS server, double-click the Network icon in Control Panel, and select TCP/IP Protocol, then Configure. Set the addresses of the primary and secondary WINS servers to be the same as the IP address of the computer itself (this will be listed above as "IP Address"). Having WINS servers pointing to other WINS servers as primary or secondary is discouraged.

STATUS

Microsoft has confirmed this to be a problem in Windows NT versions 3.5, 3.51, and 4.0. We are researching this problem and will post new information here in the Microsoft Knowledge Base as it becomes available.

Properties

Article ID: 150520 - Last Review: September 30, 2013 - Revision: 1.1
APPLIES TO
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0 Standard Edition
Keywords: 
kbnosurvey kbarchive KB150520

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com