Unable to Create Shortcuts on the Desktop

Article translations Article translations
Article ID: 177909 - View products that this article applies to.
This article was previously published under Q177909
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
Expand all | Collapse all

SYMPTOMS

When you attempt to create a new shortcut on the desktop, the Create Shortcut Wizard may not start, and a file named New Shortcut with a size of zero bytes may be created on the desktop.

CAUSE

This behavior can occur if a registry key is damaged or contains an incorrect value.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue, use Registry Editor to verify that the registry key listed below has the value listed, and if needed, edit the value to match the value listed.

Registry key:

   HKEY_CLASSES_ROOT\.lnk\ShellNew\Command
				


Value for Command:

   RunDLL32 AppWiz.Cpl,NewLinkHere %2
				


NOTE: If the Windows Desktop Update component is not installed on your computer, the following is the value for Command:

   RunDLL32 AppWiz.Cpl,NewLinkHere %1
				

Properties

Article ID: 177909 - Last Review: January 22, 2007 - Revision: 3.1
APPLIES TO
  • Microsoft Internet Explorer 4.01 128-Bit Edition
  • Microsoft Internet Explorer 4.0 128-Bit Edition
  • Microsoft Internet Explorer 1.0
  • Microsoft Internet Explorer 2.0
  • Microsoft Internet Explorer 3.0
  • Microsoft Internet Explorer 3.01
  • Microsoft Internet Explorer 3.02
  • Microsoft Internet Explorer 4.0 128-Bit Edition
  • Microsoft Internet Explorer 4.01 128-Bit Edition
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 3.2
  • Microsoft Internet Explorer 4.0 128-Bit Edition
  • Microsoft Windows 98 Standard Edition
Keywords: 
kbprb kbui KB177909
Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com