Error Message: Unable to Download an Appropriate Decompressor

Article translations Article translations
Article ID: 230687 - View products that this article applies to.
This article was previously published under Q230687
Expand all | Collapse all

SYMPTOMS

When you try to play a file with Microsoft Windows Media Player and the required decompressor is not installed on the computer, you may receive one of the following error messages:
Unable to download an appropriate decompressor. (Error=80040200)
-or-
One or more codecs required to open this content could not be found. (Error=C00D10D1)

CAUSE

This behavior can occur for any of the following reasons:
  • Microsoft Internet Explorer version 3.02 or later is not installed on your computer. Internet Explorer is required to install decompressors, which are files that enable you to play multimedia content. Although Internet Explorer is required to download decompressors, it does not have to be set up as the default browser.
  • Your Internet security options are set too high to enable decompressors to be downloaded.
  • Installation of the decompressor requires a restart of your computer but no restart occurred.
  • The codec required to play the file is missing or damaged.
  • You may be playing a file format that is not supported by Windows Media Player.
  • A sound device (audio driver) is not installed.

RESOLUTION

  • To install the latest version of Internet Explorer on your computer, go to the following Microsoft Web site:
    http://www.microsoft.com/windows/ie/downloads/default.mspx
    NOTE: Internet Explorer 5 is included with Microsoft Windows 98 Second Edition. Do not try to reinstall Internet Explorer 5 in Windows 98 Second Edition.
  • To lower the Internet security level to Medium, follow these steps:
    1. Click Start, point to Settings, and then click Control Panel.
    2. Double-click Internet.
    3. On the Security tab, click Internet.
    4. Under Security Level For This Zone, move the slider to Medium or lower.
    5. Click OK.
  • Restart your computer and try to play the file again.
If you still see this issue, you may need to troubleshoot the codecs on the computer. For additional information about verifying, installing and troubleshooting audio codecs, click the article numbers below to view the articles in the Microsoft Knowledge Base:
141801 Troubleshooting Audio Codecs in Windows 95
191533 Media Player Cannot Play .avi File Using Indeo 4.x Codec
234019 Windows Media Player Invalid File Format Error Message

MORE INFORMATION

A codec is an algorithm used to compress and decompress sound or video files.

Properties

Article ID: 230687 - Last Review: January 24, 2007 - Revision: 6.4
APPLIES TO
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
  • Microsoft Windows Media Player 9 Series
  • Microsoft Windows Media Player 9 Series for Windows XP
  • Microsoft Windows Media Player 8.01
  • Microsoft Windows Media Player 8.01
  • Microsoft Windows Media Player 7.1
  • Microsoft Windows Media Player 6.0
  • Microsoft Windows Media Player 6.1
  • Microsoft Windows Media Player 6.2
  • Microsoft Windows Media Player 6.4
  • Microsoft Windows Media Player 7.0
Keywords: 
kbnetwork kbenv kberrmsg kbprb kbprod2web KB230687

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com