New drive or mapped network drive not available in Windows Explorer

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Article ID: 297694 - View products that this article applies to.
This article was previously published under Q297694
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SYMPTOMS

When you:
  • create a new volume on a local disk.
  • plug in a removable disk with existing volumes.
  • plug in a removable drive (for example, a USB floppy drive or PCMCIA flash card).
  • add a physical hard disk or CD-ROM drive to your computer.
  • use Offline Files and specify items to be synchronized when you log on.
You may experience any of the following symptoms:
  • An existing mapped network drive is no longer available in Windows Explorer.
  • The new drive is not available in Windows Explorer.
  • The new drive appears in Windows Explorer, but when you open it the contents of the existing drive are displayed.
  • The existing drive appears in Windows Explorer, but when you open it the contents of the new drive are displayed.
  • After your computer starts, the network drive may be replaced by the new drive.
  • After you disconnect the new drive, the mapped network drive letter has the same logical drive letter that it had before you added the new drive.
  • You may receive the following error message when you start your computer:
    The local device name is already in use.
Note The new device (or drive) may appear in Device Manager or the Disk Management console.

CAUSE

This behavior occurs if you map a network drive to the first available drive letter after the drive letters for the local volumes and CD-ROM drives. When you install a new device or volume, Mount Manager, which assigns drive letters to volumes, does not recognize the mapped network drive and assigns the next available drive letter to the new device or volume. This causes a collision with the existing mapped network drive.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 installed on the computer.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with SP2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Mountmgr.sys5.1.2600.322242,36825-Sep-200711:23x86SP2SP2QFE
Ntkrnlmp.exe5.1.2600.32222,142,72025-Sep-200712:05x86SP2SP2QFE
Ntkrnlpa.exe5.1.2600.32222,062,84825-Sep-200711:26x86SP2SP2QFE
Ntkrpamp.exe5.1.2600.32222,020,86425-Sep-200711:26x86SP2SP2QFE
Ntoskrnl.exe5.1.2600.32222,185,85625-Sep-200712:07x86SP2SP2QFE

WORKAROUND

To prevent this issue from occurring, when you map a network drive, assign the highest available drive letter to the mapped network drive.

To work around this issue if the new volume appears in Disk Management, specify a different drive letter for the new device or volume. To do this, follow these steps:
  1. Right-click My Computer, and then click Manage.
  2. Under Computer Management (Local), click Disk Management.
  3. In the list of drives in the right pane, right-click the new drive and then click Change Drive Letter and Path(s).
  4. Click Change, and in the drop-down box, select a drive letter for the new drive that is not assigned to a mapped network drive.
  5. Click OK, and then click OK again.
Both the mapped network drives and the recently installed drive appear in Windows Explorer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

By default, Windows XP assigns mapped network drives to the highest available drive letter, starting with drive Z, to avoid drive letter collisions. However, by default, Windows 2000 assigns mapped network drives to the next available drive letter after the drive letters that are assigned to local volumes and CD-ROM drives.

After you install this hotfix, new drives that are attached to the system for the first time are assigned the next available drive letter from all local or mapped network drives. After a drive is attached to the system, the drive uses the same drive letter every time that the drive is reattached even if the drive letter was reused to map a network drive. However, if the drive letter was reused to map a network drive, a conflict with the drive letter occurs. This conflict can cause the drive to be unavailable.

Offline Files (CSC) synchronization maps a temporary drive to the first available drive letter. If a logon script uses the same drive letter for mapping a network drive, you receive the following error message:
error 85: The local device name is already in use.

Properties

Article ID: 297694 - Last Review: September 23, 2011 - Revision: 12.0
APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Media Center Edition 2005 Update Rollup 2
  • Microsoft Windows XP Tablet PC Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbenv kbhardware kbinfo kbnetwork KB297694

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