BUG: Error 1935 During Install of the .NET Framework

Article translations Article translations
Article ID: 308096 - View products that this article applies to.
This article was previously published under Q308096
Expand all | Collapse all

SYMPTOMS

When you try to install the .NET Framework, you receive an error 1935 (assembly install failure) error message if Mscoree.dll is in use before you start Setup.

CAUSE

This behavior occurs because Mscoree.dll is held in use for 10 minutes after you install (or remove) the assemblies. When you start another install, the installer tries to load its own version of Mscoree.dll to install the assemblies for the new program. Because another version of Mscoree.dll is already loaded, the failure occurs.

This is because of Windows Installer behavior on Windows NT platforms.

RESOLUTION

You can use either of the following methods to resolve this problem:
  • Restart your computer.

    -or-
  • Stop Windows Installer (msiservice).
To stop Windows Installer, follow these steps:
  1. Open Control Panel.
  2. Double-click Administrative Tools.
  3. Double-click Services.
  4. Right-click the Windows Installer service.
  5. Click Stop.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

Properties

Article ID: 308096 - Last Review: February 23, 2007 - Revision: 4.4
APPLIES TO
  • Microsoft .NET Framework 1.1
  • Microsoft .NET Framework 1.0, when used with:
    • Microsoft Windows NT 4.0
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows XP
Keywords: 
kbbug kberrmsg kbpending KB308096

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com