XADM: Permissions That Are Modified Manually Are Reset to the Default Values

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Article ID: 320007 - View products that this article applies to.
This article was previously published under Q320007
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SYMPTOMS

When you manually modify permissions in Exchange 2000, you may find that the permissions are reset to their default values when you perform either of the following tasks:
  • Reinstall Exchange 2000.
  • Apply an Exchange 2000 Server service pack to Exchange 2000 on a clustered server.

CAUSE

This behavior occurs if you manually modify permissions at the Exchange 2000 organization level or to the top-level public folder hierarchy (TLH) in Exchange 2000. For example, this behavior may occur when you perform the following procedure:
  1. Right-click a public folder in Exchange System Manager, click Properties, and then click the Security tab.
  2. Click to clear the Allow inheritable permissions from parent to propagate to this object check box, and then click Apply.
  3. Click the Everyone group.
  4. In the Permissions list, click to clear the Allow check box next to Create top level public folder, and then click OK.


Note that this behavior occurs only if you reinstall Exchange 2000 or if you apply a service pack to Exchange 2000 on a clustered server. You do not experience the behavior that is discussed in the "Symptoms" section of this article when you apply any post-Exchange 2000 Server Service Pack 3 (SP3) hotfixes to Exchange 2000 on a clustered server.

WORKAROUND

To work around this behavior, keep track of the permissions that you modify manually, and then reapply the permissions after you reinstall Exchange 2000 or after you apply a service pack to Exchange 2000 on a clustered server.

STATUS

This behavior is by design.

MORE INFORMATION

The following scenario is another example of when you may experience the behavior that is discussed in the "Symptoms" section of this article.
  1. Start Exchange System Manager on a clustered server.
  2. Right-click OrganizationName, and then click Properties.
  3. Click the Security tab.
  4. Click the Everyone group, and then click Remove.
  5. Apply an Exchange 2000 Server service pack.
For additional information about how to enable the Security tab for the organization object in Exchange 2000, click the following article number to view the article in the Microsoft Knowledge Base:
264733 XADM: How to Enable the Security Tab for the Organization Object
Note The behavior that is described in this article does not occur in Exchange Server 2003.

Properties

Article ID: 320007 - Last Review: October 24, 2013 - Revision: 3.1
APPLIES TO
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
Keywords: 
kbnosurvey kbarchive kbnofix kbbug KB320007

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