Windows Installer programs do not run on Legacy clients when you use “Run with administrative rights”

Article ID: 836882 - View products that this article applies to.
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SYMPTOMS

Microsoft Windows Installer programs (.msi files) may fail during execution when run as an Systems Management Server (SMS) advertisement on a SMS 2003 Legacy client.

CAUSE

This problem occurs when all the following conditions are true:
  • You configure an SMS 2003 program to run as a Windows Installer progam.
  • You select Run with administrative rights in the program properties.
  • You advertise the SMS 2003 program to a SMS 2003 Legacy client.

In this scenario, the client cannot load the SMSCliToknLocalAcct& account profile, and the program fails during installation because the program is executed by a local account that does not have a user profile associated with it.

If the program is executed with verbose logging enabled, the Windows Installer program will typically log error messages 1631 and 2755 in the MSI log that is produced during the installation attempt. Additionally, you may see errors that are similar to the following:
MSI (s) (5C:0C): Note: 1: 1402 2:
HKEY_USERS\S-1-5-21-3265930717-2988300877-17073675-1008\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders 3: 2
MSI (s) (5C:0C): Note: 1: 1402 2:
HKEY_USERS\S-1-5-21-3265930717-2988300877-17073675-1008\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders 3: 2
MSI (s) (5C:0C): Found shell folder by spelunking through the registry.
MSI (s) (5C:0C): Note: 1: 2103 2: 26

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   25-Dec-2003  10:05  2.50.2726.113     525,609  Apasetup.exe     
   25-Dec-2003  10:05                         67  Compversmsapm32.ini
   06-Aug-2000  09:51  2000.80.194.0     274,489  Ntwdblib.dll     
   23-Feb-2003  10:05  2.0.1493.5011     855,312  Preinst.exe      
   25-Dec-2003  10:05  2.50.2726.113     110,592  Progrm32.dll     

Hotfix installation information


To install this hotfix, follow these steps:
  1. Create a shared folder on a computer that your SMS site servers can access.
  2. Copy the SMS2003-RTM-KB836882-X86-ENU.exe update file to the new folder.
  3. From each SMS primary and secondary site server in your environment, use an account that has administrative credentials to log on to your site server.
  4. Quit the SMS Administrator console if it is running.
  5. Run the SMS2003-RTM-KB836882-X86-ENU.exe file, and then follow the instructions in the wizard.

WORKAROUND

If you can set the SMS 2003 advertised program to run with either the Whether or not a user is logged on option or the Only when no user is logged on option, you can use the Use Software Installation Account option with the Run with administrative rights option.

When you select the Use Software Installation Account option, the SMSCliToknLocalAcct& account is not used to run the program, and the Windows Installer program installs successfully. Additionally, the Software Installation Account can be used with the Run with user’s rights option, and does not use the SMSCliToknLocalAcct& account.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 836882 - Last Review: July 24, 2007 - Revision: 2.9
APPLIES TO
  • Microsoft Systems Management Server 2003
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbbug KB836882

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