IIS may not respond after you install MS04-021 on an IIS 4.0 server

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Article ID: 873401
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Symptoms

When you install the MS04-021 security update on a Microsoft Windows NT 4.0 server that is running Microsoft Internet Information Server (IIS) 4.0, and certain Internet Server API (ISAPI) filters are installed, the Inetinfo.exe process may not respond, and an access violation exception may occur.

On servers that are experiencing this problem, the Drwtsn32.log file contains a fault at the following line:
FAULT ->68c16296 39b8ac010000     cmp     [eax+0x1ac],edi        ds:000001ac=????????

Cause

This problem occurs when an ISAPI filter registers for the SF_NOTIFY_PREPROC_HEADERS notification and handles the request from this notification. In this case, IIS tries to access a non-existent metadata object, and an access violation occurs.

Resolution

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires Microsoft Windows NT 4.0 Service Pack 6a.

Note We recommend that you install MS04-021 on all Windows NT 4.0 servers before you install this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   16-Jul-2004  13:39  4.2.789.1         515,072  Adsiis.dll       
   16-Jul-2004  13:40  4.2.789.1         851,456  Asp.dll
   16-Jul-2004  13:39  4.2.789.1         140,288  Httpodbc.dll     
   16-Jul-2004  13:38  4.2.789.1         172,544  Iislog.dll       
   16-Jul-2004  13:38  4.2.789.1         490,496  Infocomm.dll
   16-Jul-2004  13:38  4.2.789.1          67,584  Iscomlog.dll     
   16-Jul-2004  13:39  4.2.789.1          95,232  Ssinc.dll        
   16-Jul-2004  13:39  4.2.789.1          61,440  Sspifilt.dll     
   16-Jul-2004  13:39  4.2.789.1         538,112  W3svc.dll        
   16-Jul-2004  13:39  4.2.789.1         219,136  Wam.dll     
				
Note Because of file dependencies, this hotfix requires Microsoft Windows NT 4.0 Service Pack 6a.

Status

Microsoft has confirmed that this is a problem in Windows NT 4.0.

More information

The following filters have been found to cause this problem:
  • Microsoft Proxy 2.0 Web Proxy filter
  • Entrust getAccess filter
  • Netegrity SiteMinder filter
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Properties

Article ID: 873401 - Last Review: November 2, 2013 - Revision: 2.0
Keywords: 
kbnosurvey kbarchive kbfix kbhotfixserver kbqfe KB873401

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