You cannot start a computer from a USB flash drive that is formatted to use the FAT32 file system

Article translations Article translations
Article ID: 954457 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

You format a USB flash drive to use the FAT32 file system. When you try to start the computer from this USB flash drive, the startup process stops responding, and the screen is black.

CAUSE

This issue occurs because the USB flash drive is listed as removable media. Therefore, the Windows operating system does not create a master boot record (MBR) on the USB flash drive when you format the flash drive to use the FAT32 file system. The USB flash drive is treated as a super floppy disk. The FAT32 startup code does not support starting a computer from a super floppy disk without an MBR.

The BIOS tries to transfer the control of the startup from the USB flash drive to the FAT32 startup code, even though the FAT32 startup code does not support this scenario.

WORKAROUND

To work around this issue, use the Diskpart command prompt utility to create and format the boot partition on the USB flash drive.

For more information about how to use Diskpart, click the following article number to view the article in the Microsoft Knowledge Base:
300415 A Description of the Diskpart Command-Line Utility

MORE INFORMATION

How to differentiate between the MBR and the boot sector

Currently, the Windows operating system uses signatures at offset 3 in the boot sector to determine whether the sector is a boot sector. These signatures do not appear in the MBR. The signatures are as follows:
  • FAT16: MSDOS5.0
  • FAT32: MSDOS5.0
  • NTFS: NTFS

How to determine whether the boot sector is FAT32, FAT16, or NTFS

To determine whether the USB flash drive was formatted by using the FAT32, FAT16, or NTFS file system, you must check two strings in the boot sector. If the strings contain FAT32,FAT16 or NTFS, the boot sector was formatted in that particular file system format.

Properties

Article ID: 954457 - Last Review: September 16, 2008 - Revision: 1.1
APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional 64-Bit Edition (Itanium)
  • Windows Vista Starter
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Windows Server 2008 Standard
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 for Itanium-Based Systems
Keywords: 
kbexpertiseinter kbfilesystems kbstartup kbformat kbtshoot kbprb KB954457

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com