Internet Explorer Opens a Blank Page with a Placeholder Icon Instead of a .pdf File in Adobe Acrobat Reader

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Article ID: 305153 - View products that this article applies to.
This article was previously published under Q305153
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SYMPTOMS

Internet Explorer may display a blank page with a placeholder icon instead of displaying a Portable Document Format (.pdf) file with Adobe Acrobat Reader.

CAUSE

This behavior occurs because the uniform resource identifier (URI) to the .pdf file does not end in ".pdf" (for example, the file is opened through script or the file is dynamically generated), and the content-type header (Multipurpose Internet Mail Extensions [MIME] type) that is returned by the server is "unknown/unknown" or no content-length header was returned. Note that previous versions of Internet Explorer that support Netscape-style plug-ins may open the .pdf file without a content-type header.

RESOLUTION

To work around this behavior, right-click the link to the .pdf file, and then click Save Target As to save the file on your computer. After you do this, you can double-click the locally saved .pdf file to open it in Adobe Acrobat Reader.

To resolve this behavior, contact the Web site author or administrator. Web site authors or administrators can resolve this problem if they configure their Web servers to send both a content-type header (MIME type) of "application/pdf" for .pdf files and an appropriate content-length header. (For information on doing this, consult the documentation for the Web server that is in use.)

To add or modify MIME types on Microsoft Internet Information Services 4.0 or 5.0, please see the following Microsoft Web site:
MIME Types in IIS
http://technet.microsoft.com/en-us/library/bb742440.aspx
For information on HTTP headers, see the following Microsoft Web site:
HTTP Headers Reference
http://msdn2.microsoft.com/en-us/library/aa287673(VS.71).aspx

STATUS

This behavior is by design.

MORE INFORMATION

For additional information about this behavior, click the article number below to view the article in the Microsoft Knowledge Base:
303401 Netscape-Style Plugins No Longer Work After Upgrading Internet Explorer

Properties

Article ID: 305153 - Last Review: March 29, 2007 - Revision: 5.4
APPLIES TO
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5 Service Pack 2
  • Microsoft Internet Explorer 6.0, when used with:
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Media Center Edition
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows XP Professional x64 Edition
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Datacenter Server
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows 2000 Server
    • Microsoft Windows NT Server 4.0 Standard Edition
    • Microsoft Windows NT Server 4.0, Terminal Server Edition
    • Microsoft Windows NT Workstation 4.0 Developer Edition
    • Microsoft Windows Millennium Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows 98 Standard Edition
Keywords: 
kbprb KB305153

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