アイコンがランダムに別のアイコンで置き換えられる

文書番号: 132668 - 対象製品
この記事は、以前は次の ID で公開されていました: JP132668
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 Microsoft Windows レジストリの説明
すべて展開する | すべて折りたたむ

現象

マイ コンピュータ、エクスプローラ、デスクトップ、またはクイック起動ツール バー内の一部のアイコンがランダムに別のアイコンに置き換えられることがあります。

原因

この現象は、アイコン キャッシュが正しく更新されない場合に発生することがあります。

解決方法

警告 : レジストリ エディタまたは別の方法を使用してレジストリを誤って変更すると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリの変更により発生した問題に関しては、一切責任を負わないものとします。レジストリの変更は、自己の責任において行ってください。
この問題を解決するには、以下のいずれかの方法を使用します。
  • F5 キーを押して、現在のフォルダのアイコンを更新します。
  • 正しく表示されないアイコンを含むウィンドウを閉じ、再び開きます。
  • コンピュータを再起動します。
  • ShellIconCache ファイルを再作成します。このファイルは、画面の表示色を変更すると自動的に再作成されます。以下の手順に従って、画面の表示色を新しい設定に変更してから、元の設定に戻します。
    1. デスクトップを右クリックし、[プロパティ] をクリックします。
    2. [設定] タブをクリックします。
    3. 表示色を現在の設定から新しい設定に変更します。たとえば、[最高 (32 ビット)] から [中 (16 ビット)] に変更します。
    4. [適用] をクリックしてから [はい] をクリックして変更を適用します。
    5. 表示色を元の設定に戻します。
    6. [適用] をクリックしてから [はい] をクリックして変更を適用します。
  • レジストリ エディタを使用して、次のレジストリ キーに文字列値 Max Cached Icons を追加し、値を 2000 に設定してから、コンピュータを再起動します。
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer
    依然としてアイコンが正しく表示されない場合は、ShellIconCache ファイルを削除します。Max Cached Icons の値のデータ範囲は 100 〜 4096 であり、デフォルト値は 500 です。

詳細

この問題の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
133733 コントロール パネルのアイコンが正しく表示されない

プロパティ

文書番号: 132668 - 最終更新日: 2007年5月21日 - リビジョン: 3.1
この資料は以下の製品について記述したものです。
  • Microsoft Windows NT Server 4.0, Terminal Server Edition Service Pack 4
  • Microsoft Windows NT Server 4.0, Terminal Server Edition Service Pack 5
  • Microsoft Windows NT Server 4.0, Terminal Server Edition Service Pack 6
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT 4.0 Service Pack 1
  • Microsoft Windows NT 4.0 Service Pack 2
  • Microsoft Windows NT 4.0 Service Pack 3
  • Microsoft Windows NT 4.0 Service Pack 4
  • Microsoft Windows NT 4.0 Service Pack 5
  • Microsoft Windows NT 4.0 Service Pack 6
  • Microsoft Windows NT 4.0 Service Pack 6a
  • Microsoft Windows NT Server 4.0 Enterprise Edition
  • Microsoft Windows NT 4.0 Service Pack 4
  • Microsoft Windows NT 4.0 Service Pack 5
  • Microsoft Windows NT 4.0 Service Pack 6
  • Microsoft Windows NT 4.0 Service Pack 6a
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Service Pack 1
  • Microsoft Windows XP Service Pack 2
キーワード:?
kbui kbprb KB132668
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック