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Symptoms

Assume that you try to run an x86-based version of an application on a Windows Server 2012-based server. You receive a Stop error message that resembles the following, if the application uses MPIO Pass Through IOCTLS.

STOP: 0x00000050 ( parameter1, parameter2, parameter3, parameter4 )


Notes

  • This Stop error indicates a PAGE_FAULT_IN_NONPAGED_AREA issue.

  • The parameters in this Stop error message vary, depending on the configuration of the computer.

  • Not all "0x00000050" Stop errors are caused by this issue.


Cause

This issue occurs when MPIO marshals the data buffer for the MPIO Pass Through IOCTL from the x86-based version of the system to the x64-based version. This occurs because of the incorrect interpretation of the x86-based IOCTL Input Buffer and an incorrect calculation of the size required for the x64-based version buffer.

How to obtain this update or hotfix

To resolve this issue, we have released hotfixes and updates for Windows Server 2012.

The update rollup fixes many other issues in addition to the issue that the hotfix fixes. We recommend that you use the update rollup. The update rollup is larger than the hotfix. Therefore, the update rollup takes longer to download.

Update for Windows Server 2012

The following update rollup is available.

For Windows Server 2012

Get update rollup 2975331

Hotfix for Windows Server 2012

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates. For more information about MPIO I/O control codes, go to the following Microsoft website:

MPIO I/O Control Codes

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows Server 2012 file information and notesImportant Windows 8 hotfixes and Windows Server 2012 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8/Windows Server 2012" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, milestone (RTM,SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:

    Version

    Product

    Milestone

    Service branch

    6.2.760 0.17xxx

    Windows Server 2012

    RTM

    GDR

    6.2.760 0.21xxx

    Windows Server 2012

    RTM

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x64-based versions of Windows Server 2012

File name

File version

File size

Date

Time

Platform

Mpio.sys

6.2.9200.17042

238,912

26-Jun-2014

04:39

x64

Mpio.sys

6.2.9200.21159

238,912

26-Jun-2014

04:35

x64

Additional file information

Additional file information for Windows Server 2012

Additional files for all supported x64-based versions of Windows Server 2012

File property

Value

File name

Amd64_mpio.inf_31bf3856ad364e35_6.2.9200.17042_none_7625a6a218f9f51f.manifest

File version

Not applicable

File size

2,090

Date (UTC)

26-Jun-2014

Time (UTC)

04:47

Platform

Not applicable

File name

Amd64_mpio.inf_31bf3856ad364e35_6.2.9200.21159_none_76ab75873219623b.manifest

File version

Not applicable

File size

2,090

Date (UTC)

26-Jun-2014

Time (UTC)

04:44

Platform

Not applicable


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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