Cómo solucionar problemas de una publicación en Publisher está dañada

Seleccione idioma Seleccione idioma
Id. de artículo: 198256 - Ver los productos a los que se aplica este artículo
Para obtener una versión de Microsoft Publisher 98 de este artículo, consulte 191131.
Expandir todo | Contraer todo

En esta página

Resumen

Si experimenta un comportamiento inesperado cuando se utiliza un publicación en Microsoft Publisher, la publicación puede estar dañado. Los síntomas de una publicación dañado son:
  • Recibe un error de página no válida, una protección general error o un mensaje de error de instrucción no válida.
  • Cuando intenta abrir la publicación, recibirá uno los siguientes mensajes de error:
    -Esto no es un Publicación de Publisher.
    -Publisher no puede abrir el tipo de archivo representado por <filename>.</filename>
    -Falta parte del archivo.
  • Recibe un mensaje de error de memoria o los recursos del sistema es insuficiente mensaje de error.
Nota Puede recibir uno de estos mensajes de error por motivos distintos que una publicación está dañada. Sin embargo, si este comportamiento produce sólo cuando se utiliza una publicación determinada, publicación esté dañado.

Más información

Para solucionar este problema, reinicie el equipo en lugar seguro Modo. A continuación, utilice los métodos de solución de problemas adecuados para su problema.

Nota Puesto que existen varias versiones de Microsoft Windows, los pasos siguientes pueden ser diferentes en su equipo. Si es así, consulte la documentación del producto para completarlos.

Reinicie el equipo en modo a prueba de errores

Para reiniciar el equipo en modo a prueba de errores, utilice el método apropiado para su versión de Microsoft Windows.
  1. Apagar y, a continuación, reinicie el equipo.
  2. Cuando aparezca el mensaje "Seleccione el sistema operativo desea iniciar", presione F8.
  3. En el Opciones avanzadas de Windows menú, utilice las teclas de dirección para seleccionar Modo a prueba de errores, y, a continuación, presione ENTRAR.
  4. Si tienes un equipo con inicio dual o un equipo de arranque múltiple, seleccione el sistema operativo apropiado en la lista y, a continuación, presione ENTRAR.
Para obtener más información acerca del modo a prueba de errores, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
315222Una descripción de las opciones de inicio en modo a prueba de errores en Windows XP
202485 Descripción del modo a prueba de errores en Windows 2000
180902 Cómo iniciar un equipo basado en Windows 98 en modo a prueba de errores

Intente abrir la publicación

Después de iniciar el equipo en modo a prueba de errores, intente abrir el ¡ ¡ publicación. Si no recibe un mensaje de error, un programa o un dispositivo que se carga cuando el equipo está en un grupo normal modo puede interferir con la publicación.

Si no se puede abrir la publicación

Si no se puede abrir la publicación después de iniciar el equipo en modo a prueba de errores, utilice los métodos siguientes en el orden en el que están presentado.

Pegue la publicación en el archivo de programa de Publisher

Es posible que pueda abrir la publicación pegándola en la Archivo de programa de Publisher. Para ello, siga estos pasos:
  1. Inicie el Explorador de Windows.
  2. Busque el archivo de publicación.
  3. Haga clic en el archivo de publicación y, a continuación, haga clic en Copia.
  4. Cierre el Explorador de Windows.
  5. Haga clic en Inicio, haga clic en Ejecutar, tipo de una de las líneas siguientes en el Abrir cuadro y, a continuación, haga clic en ACEPTAR:
    Para Publisher 2003
    C:\Program de programa\Microsoft Office\Office11
    Para Publisher 2002
    C:\Program de programa\Microsoft Office\Office10
    Para Publisher 2000
    C:\Program de programa\Microsoft Office\Office
  6. Haga clic en el MSPUB.exe archivo de programa y, a continuación, haga clic en Pegar.
Si no se puede abrir la publicación, vaya a la siguiente ALink ().

Haga doble clic en el archivo de la publicación en el Explorador de Windows

Para que haga doble clic en el archivo de la publicación en el Explorador de Windows, siga estos pasos:
  1. Haga clic en Inicio, seleccione Programasy, a continuación, haga clic en Explorador de Windows.
  2. Busque el archivo de publicación.
  3. Haga doble clic en el archivo de la publicación.
Si no se puede abrir la publicación, vaya a la siguiente ALink ().

Configurar Publisher para ocultar imágenes

Para configurar Publisher para ocultar imágenes, siga estos pasos:
  1. Inicie Publisher y, a continuación, abra una nueva publicación en blanco.
  2. En el Vista menú, haga clic en Presentación de imágenes en Publisher 2000 o haga clic en Imágenes en Publisher 2003 o Publisher 2002.
  3. Haga clic en Ocultar imágenesy, a continuación, haga clic en ACEPTAR.
  4. En el Archivo menú, haga clic en Abrir.
  5. Busque el archivo de publicación.
  6. Haga clic para activar la publicación y, a continuación, haga clic en Abrir.
Si puede abrir la publicación, es posible que la publicación contiene un objeto está dañado o marcador de posición de objetos. Para quitar o reemplazar un archivo objeto o marcador de posición de objeto, vaya al método siguiente.

Si no se puede abrir la publicación, vaya al método "Copiar la publicación en otro equipo".

Buscar y quitar un objeto está dañado o marcador de posición de objetos

Para buscar y quitar un objeto está dañado o un marcador de posición de objeto, siga estos pasos:
  1. En la publicación, haga clic en un marcador de posición de objeto, y a continuación, haga clic en Eliminar objeto.
  2. En el Archivo menú, haga clic en Guardar como.
  3. En el Nombre cuadro, escriba un nombre nuevo para la publicación y, a continuación, haga clic en Guardar.
  4. En el Vista menú, haga clic en Presentación de imágenes en Publisher 2000 o haga clic en Imágenes en Publisher 2003 o Publisher 2002.
  5. Haga clic en Presentación detallada, y a continuación, haga clic en ACEPTAR.

    Nota Si recibe un mensaje de error, vaya al paso 8.
  6. En el Archivo menú, haga clic en Cerrar.
  7. En el Archivo menú, haga clic en Abriry, a continuación, haga clic en la publicación que guardó en el paso 3.

    Si puede abrir la publicación, el objeto o el objeto marcador de posición que eliminó en el paso 1 está dañado. Ajustar el diseño para el objeto que falta o marcador de posición de objeto. Como alternativa, dibuje un objeto nuevo marcador de posición y reemplazar el objeto eliminado con uno que no está dañado. Para realizar Esto, utilice el método que sea adecuado para el origen de objeto.

    Desde la Galería de imágenes prediseñadas
    1. En el Insertar en el menú, señale a Imageny, a continuación, haga clic en Imágenes prediseñadas.
    2. En una de las categorías disponibles, haga clic en para insertar la imagen, el sonido o el clip de movimiento que desea.
    3. Guarde y cierre la publicación. A continuación, intente Vuelva a abrir la publicación.
    Desde una ubicación distinta de la Galería de imágenes prediseñadas
    1. Utilice la herramienta de marco de imagen para dibujar un marcador de posición de objeto nuevo.
    2. Haga clic en para seleccionar el marcador de posición, seleccione Imagen En la página Insertar y, a continuación, haga clic en Desde archivo.
    3. Busque la imagen que desea Insertar y, a continuación, haga clic para seleccionarlo.
    4. Haga clic en Insertar.
    5. Guarde y cierre la publicación. A continuación, intente Vuelva a abrir la publicación.
    Si no se puede abrir la publicación, repita el Método de "Configuración de Publisher para ocultar imágenes". A continuación, vaya al paso 8.
  8. Repita los pasos del 1 al 7 hasta que se puede abrir el publicación con el Presentación detallada opción habilitado.
  9. Cuando se puede abrir la publicación, utilice uno de los métodos siguientes:
    • Reemplazar la Eliminar objeto o el marcador de posición object con uno que no está dañado.
    • Ajustar el diseño para el objeto que falta o marcador de posición de objeto.
  10. En el Archivo menú, haga clic en Guardar.
Si todavía no se puede abrir la publicación, vaya al el método siguiente.

Mueva el archivo de la publicación a otro disco

Si el archivo de publicación se encuentra en un disco extraíble, como un disco flexible o un disco Zip, Windows no puede leer el archivo. En este escenario, copie el archivo en el disco duro.

Si no se puede copiar la archivo desde el disco extraíble, el archivo puede ser un vínculo cruzado con otros archivos o carpetas. Como alternativa, el archivo puede encontrarse en un sector dañado del disco. En ambos casos, continúe con el método de "Comprobación de errores de ejecución en el disco".

Copiar la publicación en otro equipo

En algunos casos, puede abrir una publicación dañada después de copiar la publicación en otro equipo que tiene instalado Publisher. Para ello, siga estos pasos:
  1. Inicie el Explorador de Windows.
  2. Busque el archivo de publicación.
  3. Haga clic en el archivo de publicación y, a continuación, haga clic en Copia.
  4. Utilice uno de los métodos siguientes para copiar la publicación en un segundo equipo:
    • Copie el archivo de publicación en un disco extraíble, como un disco flexible o un disco Zip. A continuación, copie la publicación de la disco extraíble en otro equipo.
    • Copie el archivo de publicación en otro equipo a través de un red.
  5. En el segundo equipo, inicie el Explorador de Windows.
  6. Busque y, a continuación, haga doble clic en el archivo de la publicación.
Si se puede abrir la publicación, examinar cada página para determinar si están presentes los marcadores de posición de objeto en blanco. Para cada uno marcador de posición de objeto en blanco que encuentre, haga clic en el archivo y, a continuación, haga clic en Eliminar. Guardar la publicación y el archivo de la publicación se vuelven a copiar en, a continuación el primer equipo.

Si no se puede abrir la publicación continúe con el método siguiente.

Ejecute la comprobación de errores en el disco

Ejecutar comprobación de errores para todos los errores en el disco de reparación. Indicar a comprobación de errores para reparar todos los archivos con vínculos cruzados y convierta los fragmentos perdidos para archivos.

Nota Aunque la comprobación de errores puede determinar que el archivo de la publicación con vínculos cruzados y, a continuación, reparar el archivo, este método no garantiza que Publisher puede leer el archivo después de comprobación de errores ha terminado de examinar y corrección de errores.

Para ejecutar la comprobación de errores, siga estos pasos:
  1. Cierre todos los programas que se están ejecutando.
  2. Haga doble clic en el Mi equipo icono en el escritorio.
  3. Haga clic en el disco local que va a comprobar y, a continuación, haga clic en Propiedades.
  4. En el Herramientas de ficha, haga clic en Comprobar ahora bajo Comprobación de errores.
  5. Bajo Compruebe las opciones de disco, haga clic para seleccionar la Examinar e intentar recuperar los sectores defectuosos casilla de verificación. A continuación, haga clic en Inicio.
  6. Cuando la comprobación de errores finalice el examen y corrección de errores, haga clic en Cerrar.
  7. Inicie Publisher y, a continuación, intente abrir el ¡ ¡ publicación.
Si no se puede abrir la publicación, vaya al método siguiente.

Intentar recuperar el texto de la publicación

Este método describe cómo recuperar el texto de su dañado publicación y cómo se inserta el texto recuperado en un nuevo en blanco ¡ ¡ publicación. A continuación, debe volver a crear el diseño y vuelva a insertar todos los objetos de la publicación está dañada en la nueva publicación.

Para recuperar el texto desde la publicación está dañado y, a continuación, insertar el texto en una nueva publicación, siga estos pasos:
  1. Inicie Publisher y, a continuación, crear una nueva publicación página completa en blanco.
  2. Utilice la herramienta de marco de texto en Publisher 2000 o la herramienta de cuadro de texto en Publisher 2003 o en Publisher 2002 para dibujar un marco de texto en la página en blanco.
  3. En el Insertar menú, haga clic en Archivo de texto.
  4. En el Tipo de archivo Haga clic enLos archivos de Publisher (*. pub).
  5. Haga clic en la publicación y, a continuación, haga clic en ACEPTAR.

    Si recibe un mensaje que indica cómo se ajusta el texto que va a insertar en la página, haga clic en .

Si puede abrir la publicación está dañada

Si puede abrir la publicación en modo a prueba de errores, utilice uno de los métodos siguientes para volver a crear la publicación.

Copiar páginas de la publicación está dañada en una nueva publicación

Para copiar las páginas de una publicación dañada en una nueva publicación, siga estos pasos:
  1. Inicie Publisher y, a continuación, abra el dañado ¡ ¡ publicación.
  2. Inicie otra instancia de Publisher.
  3. Crear una nueva publicación en blanco es la misma configuración que la publicación está dañada.
  4. En la publicación está dañada, seleccione todos los objetos en un página particular.
  5. En el Editar menú, haga clic en Copia.
  6. Presione ALT + TAB para cambiar a la nueva publicación.
  7. En el Editar menú, haga clic en Pegar.
  8. Repita los pasos del 4 al 7 hasta que se pegan todas las páginas en la nueva publicación.
Nota Si observa un comportamiento extraño en la nueva publicación después de copiar una página a la nueva publicación, que copia página probablemente contiene un objeto está dañado. En este escenario, utilice uno de los métodos siguientes para solucionar temporalmente este problema:
  • Copiar un objeto a la vez desde la página de problema en la nueva publicación para determinar qué objeto está dañado. A continuación, asegúrese de que no incluir el objeto dañado en la nueva publicación.
  • Vuelva a generar la página de problema en la nueva publicación.
Si todas las páginas de la publicación está dañada, vaya a la método siguiente.

Guardar la publicación en formato RTF (formato de texto enriquecido)

Si el daño a la publicación parece generalizado, guarde el publicación en formato RTF para recuperar el texto de la publicación. Para ello, siga estos pasos:
  1. Abra la publicación.
  2. Haga clic en un marco de texto.
  3. En el Guardar como tipo Haga clic enFormato de texto enriquecido (*.rtf).
  4. En el Nombre de archivo Escriba el nombre de archivo que desee.
  5. En el Guardar en Haga clic en la carpeta en la que desea guardar el texto de la publicación.
  6. Haga clic en Guardary, a continuación, haga clic en ACEPTAR.
  7. Cierra la publicación.
  8. En el Archivo menú, haga clic en Abrir.
  9. En el Tipo de archivo Haga clic enFormato de texto enriquecido (*.rtf).
  10. En la lista de archivos, haga clic en el texto de archivo que Has ahorrado en el paso 6.
  11. Haga clic en Abrir.
  12. Diseñar y dar formato al texto de forma que duplique cómo el texto se diseñan y con formato de la publicación está dañada.

Referencias

Para obtener más información acerca de cómo solucionar problemas de las publicaciones de Publisher está dañadas, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
315222Una descripción de las opciones de inicio en modo a prueba de errores en Windows XP
164519 Solución de problemas de errores de Kernel32.dll de Office en Windows 95
179095 Mensaje de error de vínculo de archivo al abrir Publisher

Propiedades

Id. de artículo: 198256 - Última revisión: miércoles, 16 de enero de 2013 - Versión: 5.0
La información de este artículo se refiere a:
  • Microsoft Office Publisher 2007
  • Microsoft Office Publisher 2003
  • ?
  • Microsoft Publisher 2002 Standard
  • Microsoft Publisher 2000 Standard
Palabras clave: 
kbopenfile kbcorrupt kbtshoot kberrmsg kbpending kbprb kbui kbmt KB198256 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 198256

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com