REVISIÓN: No se puede encontrar el archivo de salida al probar un BizTalk Server 2006 R2 o BizTalk Server 2009 se asignan en Visual Studio 2005

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Síntomas

Considere el siguiente escenario:
  • Crear una asignación de BizTalk mediante el uso de Microsoft Visual Studio 2005 en un equipo que ejecuta Microsoft BizTalk Server 2006 R2 o en BizTalk Server 2009.
  • Hacer referencia a un esquema de intercambio de datos electrónicos (EDI) en la asignación de BizTalk.
  • Establece la configuración de "Salida de comprobar asignación" "Nativa" en elPáginas de propiedadescuadro de diálogo del mapa.
  • Comprobar la asignación en Visual Studio.

    NotaPara obtener instrucciones detalladas acerca de cómo probar una asignación, consulte la sección "Más información".
En este caso, recibirá un mensaje similar al siguiente en la ventana de resultados:
Probar el éxito de mapa para el archivo de mapa<path of="" the="" map="" file=""></path>. El resultado se almacena en el siguiente archivo:<path of="" the="" output="" file=""></path>
Sin embargo, el archivo de salida no existe en la ruta de acceso que se describe en el mensaje.

Causa

Este problema se produce debido a un error en la extensión del esquema EDI. Cuando se establece el valor de "Salida de comprobar asignación" a "Nativo" en un mapa, se genera un archivo XML temporal. A continuación, en la extensión del esquema EDI se convierte el archivo en formato nativo. Sin embargo, la extensión del esquema EDI no encuentra el archivo XML temporal correctamente.

Solución

Información de actualización acumulativa

Revisión de información de la actualización acumulativa que resuelve este problema se incluye en el paquete de actualización acumulativa 2 para BizTalk Server 2009.

Para obtener más información acerca de cómo obtener el paquete de actualización acumulativa, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
2497794Paquete 2 de la actualización acumulativa para BizTalk Server 2009

La revisión que resuelve este problema se incluye en el paquete de actualización acumulativa 3 para BizTalk Server 2006 R2 SP1.

Para obtener más información acerca de cómo obtener el paquete de actualización acumulativa, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
2286501Paquete de actualización acumulativa 3 para Service Pack 1 de BizTalk Server 2006 R2
Para obtener más información acerca de las revisiones de BizTalk Server 2006 R2 SP1, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
974563Lista de correcciones urgentes de Microsoft BizTalk Server que se incluyen en el Service Pack 1 de BizTalk Server 2006 R2
Para obtener más información acerca de las revisiones de BizTalk Server, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
2003907Información de las revisiones de BizTalk Server

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Más información

Para obtener más información acerca de cómo probar una asignación, visite el siguiente sitio Web de Microsoft Developer Network (MSDN):
Probar una asignación

Propiedades

Id. de artículo: 2277313 - Última revisión: viernes, 18 de marzo de 2011 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft BizTalk Server 2006 R2 Branch
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Standard Edition
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2009 Standard
Palabras clave: 
kbqfe kbfix kbsurveynew kbexpertiseadvanced kbbtsmapper kbbiztalk2006r2presp2fix kbbiztalk2009presp1fix kbmt KB2277313 KbMtes
Traducción automática
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Haga clic aquí para ver el artículo original (en inglés): 2277313

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