É apresentada a mensagem de erro "Please insert the correct CD-ROM" ou o jogo deixa de responder no ecrã "Loading" quando inicia um jogo da Microsoft

Artigo: 228985 - Ver produtos para os quais este artigo se aplica.
Este artigo foi publicado anteriormente em PT228985
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Quando tentar iniciar um dos programas listados na secção "Aplica-se a", poderá detectar um dos seguintes sintomas quando a mensagem "A carregar" ou a mensagem "Aguarde enquanto o CD de nome do programa é verificado" for apresentada no ecrã:
  • O programa poderá deixar de responder (não reagir).
  • O jogo poderá terminar e o utilizador voltar ao ambiente de trabalho.
  • Poderá receber uma das seguintes mensagens de erro:
    Please insert the correct CD-ROM, select OK and restart application.
    O nome do programa causou um erro de página inválida no módulo nome do programa.icd
    O nome do programa causou um erro de página inválida no módulo dplayerx.dll
    IRQL_NOT_LESS_OR_EQUAL, ADDRESS 8000741A has base at 80001000 - hal.dll
    O nome do programa provocou um erro em ~DF394B.tmp
    Rukshuk causou um erro de página inválida no módulo rukshuk.exe
    EMPIRES2 causou um erro de página inválida no módulo Empires2.exe
    Clokspl causou um erro de página inválida no módulo Clokspl.exe.
    Cannot locate the CD-ROM. Please insert FS2004 Disc 4, select OK and restart application.
    O Nome do jogo encontrou um problema e tem de ser fechado. We are sorry for the inconvenience.
    Se clicar na hiperligação da caixa de diálogo, receberá a seguinte assinatura de erro:
    Appname:program.icd, appver:x.x.x.xxx, modname: programa.icd
Além disso, se tentar instalar um dos jogos listados na secção "Aplica-se a", poderá receber uma das seguintes mensagens de erro:
Failed to verify media. Installation cancelled.
Media authentication failed.

Causa

Este problema poderá ocorrer caso se verifique uma das seguintes condições:
  • Não está a utilizar o CD do jogo para iniciar o programa.
  • A unidade de CD é incompatível com o programa.
  • Está a utilizar uma cópia do CD do programa.
  • Não tem sessão iniciada no computador como administrador.
  • O programa ou programas estão a interferir com o arranque do jogo, que está em execução, mas não é visível.
  • Tem uma conta do Microsoft Windows XP Home que utiliza a "mudança rápida de utilizador".
  • A unidade de CD está a utilizar controladores desactualizados.
Nota: este problema ocorre em computadores com o Microsoft Windows XP Home e o Microsoft Windows XP Professional em execução. Quando o problema ocorre num computador baseado no Windows XP Professional, não ocorre devido à "mudança rápida de utilizador", mas poderá ocorrer devido a uma das restantes condições listadas anteriormente.

Resolução

Método 1: Limpe o disco

Limpe o CD ou o DVD. Para o fazer, utilize um kit de limpeza de CDs. Em alternativa, limpe cuidadosamente a superfície de leitura do CD com um pano macio de algodão, sem fibras. Não utilize toalhetes de papel. Os toalhetes de papel podem arranhar o plástico e deixar riscos. Quando limpar o CD, limpe do centro do disco para fora. Não utilize um movimento circular. Se o problema persistir, limpe o CD-ROM com um pano húmido ou com uma solução de limpeza para CDs ou DVDs. Seque cuidadosamente o CD antes de o introduzir na unidade. Se o problema persistir, avance para o método seguinte.

Método 2: Verificar se o CD do jogo está inserido na unidade de CD

Certifique-se de que o disco do jogo está inserido na unidade de CD. Insira o CD original do jogo na unidade de CD e reinicie o programa.
  • Microsoft Combat Flight Simulator 2:

    Se estiver a tentar jogar o Combat Flight Simulator 2, utilize o CD 2.
  • Microsoft Mech Warrior 4: Inner Sphere Mech Pak:

    Se estiver a tentar jogar o Mech Warrior 4: Inner Sphere Mech Pak, insira o Mech Warrior Vengeance 4 (CD 1) ou o Black Knight antes de iniciar o jogo.
  • Microsoft Flight Simulator 2004: A Century of Flight

    Se estiver a tentar jogar o Flight Simulator 2004: A Century of Flight, insira o CD 4.
  • Microsoft Zoo Tycoon: Complete Collection

    Se estiver a tentar jogar o Zoo Tycoon: Complete Collection, insira o CD 2.
Se o problema persistir, avance para o método seguinte.

Método 3: Instalar actualizações do SafeDisc

Para ver se necessita destas actualizações instaladas, siga estes passos:
  1. Insira o CD do jogo.
  2. Clique em Iniciar, clique em Executar, escreva cmd e clique em OK.
  3. Escreva a letra do CD e dois pontos e prima ENTER.

    Por exemplo, na maioria dos computadores, a letra da unidade de CD é D. Assim, escreva D: e prima ENTER.
  4. Escreva dir /a:h e prima ENTER.
Este comando apresenta os ficheiros ocultos do CD. Se existir um ficheiro denominado "SSIFSDAT.SYS", não necessitará destas actualizações instaladas para o jogo que está a utilizar. No entanto, a instalação destas actualizações poderá ter vantagens para outros jogos.

Correcção do SafeDisc do Windows XP para jogos Microsoft

Se estiver a utilizar o Windows XP e tiver a "mudança rápida de utilizador" activada, poderá necessitar de um ficheiro de actualização.

Para obter a actualização, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/en-us/download/details.aspx?id=2941
Nota Para instalar esta actualização, tem de iniciar sessão no Microsoft Windows com uma conta que tenha direitos de administração. Este ficheiro não é necessário para o Microsoft Windows 2000 e anteriores.

Correcção do controlador SafeDisc

Esta actualização foi concebida para o Microsoft Windows NT, o Windows 2000 e o Windows XP. Poderá ter de iniciar sessão como administrador para instalá-la. Se continuar a ter problemas na verificação do CD, está disponível uma actualização de melhoramento de compatibilidade.

Para transferir esta actualização, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/en-us/download/details.aspx?id=2941
A Microsoft fornece informações de contacto de outros fabricantes para o ajudar na obtenção de suporte técnico. Estas informações de contacto poderão ser alteradas sem aviso prévio. A Microsoft não garante o rigor das informações sobre o contacto destes fabricantes. Se o problema persistir, avance para o método seguinte.

Método 4: Viu os termos da licença de software da Microsoft?

Depois de instalar o jogo com êxito, deverá ver os termos da licença de software da Microsoft. O jogo tenta verificar o CD. Este processo é designado por ?verificação do CD?. Este processo ocorre normalmente antes de aceitar os termos da licença de software da Microsoft. Se não vir os termos da licença de software da Microsoft depois de instalar o jogo, a unidade não consegue ultrapassar o processo de verificação do CD. O processo de verificação do CD garante que está a utilizar um CD legítimo e não uma cópia. Em alguns computadores, as unidades de CD não conseguem ultrapassar o processo de verificação do CD.

Importante: em alguns dos jogos listados na secção "Aplica-se a", o ecrã dos termos da licença de software da Microsoft é apresentado durante a instalação. Se tiver conseguido aceitar os termos da licença de software da Microsoft durante a instalação, mas continuar a detectar os sintomas descritos na secção "Sintomas", siga as instruções constantes deste artigo. Caso não se lembre se viu os termos da licença de software da Microsoft, ou se não pretender remover e reinstalar o jogo, poderá determinar se aceitou os termos da licença de software da Microsoft. Para o fazer, siga estes passos:
  1. Clique em Iniciar, aponte para Executar e escreva regedit.
  2. Expanda HKEY_CURRENT_USER.
  3. Expanda Software.
  4. Expanda Microsoft e expanda Microsoft Games.
  5. Expanda a pasta do jogo e clique na subpasta uma vez.
O nome desta subpasta deverá ter um número. Por exemplo, 01, 02, 03 ou eula.

Anote o que observar junto de FIRSTRUN, no painel direito. Se vir o número 0x00000001, aceitou os termos da licença de software da Microsoft e este não será o problema. Se vir o número 0x00000000, em que o último dígito é zero, a unidade de CD está a ter problemas na verificação do CD do jogo.

Para resolver este problema, utilize os seguintes métodos, pela ordem em que são apresentados.

Método 5: Desactivar ou alterar o modo de compatibilidade

  1. Clique com o botão direito do rato no ícone de atalho do programa e clique em Propriedades.
  2. No separador Compatibilidade, clique para desmarcar a caixa de verificação Executar este programa em modo de compatibilidade para.

    Em alternativa, no separador Compatibilidade, seleccione o modo de compatibilidade Windows 2000.
  3. Clique em OK.
  4. Inicie o programa utilizando o atalho modificado.
Reduzir esta imagemExpandir esta imagem

Se o problema persistir, avance para o método seguinte.

Método 6: Esvaziar a pasta Temp

Para esvaziar a pasta Temp, siga os passos adequados à sua versão do Microsoft Windows.

Windows 98 ou Windows Millennium Edition

  1. Clique em Iniciar, clique em Executar, escreva temp na caixa Abrir e clique em OK.
  2. No menu Editar, clique em Seleccionar tudo.
  3. No menu Ficheiro, clique em Eliminar e clique em Sim para todos.

Windows XP ou Windows 2000

Nota A pasta Temp do Windows XP que o programa de configuração do jogo está a tentar utilizar encontra-se na pasta específica de um utilizador, como Unidade\Documentos e Definições\Nome de Utilizador\Definições Locais\Temp.
  1. Clique em Iniciar, clique em Executar, escreva %temp% na caixa Abrir e clique em OK.
  2. No menu Editar, clique em Seleccionar tudo.
  3. No menu Ficheiro, clique em Eliminar e clique em Sim para todos.
Se o problema persistir, avance para o método seguinte.

Método 7: Reiniciar o computador utilizando um procedimento de arranque limpo

Quando inicia o Microsoft Windows, alguns programas são normalmente iniciados de forma automática e executados em segundo plano. Estes programas poderão interferir com o jogo. Estes programas podem incluir programas antivírus e utilitários de sistema. Quando efectua um procedimento de arranque limpo, impede que estes programas sejam iniciados automaticamente. Para concluir este procedimento, tem de iniciar sessão como administrador ou como membro do grupo de administradores. Se o computador estiver ligado a uma rede, as definições da política de rede poderão também impedir o utilizador de concluir este procedimento.

Para reiniciar o computador utilizando um procedimento de arranque limpo, siga estes passos quando utilizar o Windows XP.

Nota: poderá ocorrer uma perda temporária da funcionalidade de alguns serviços quando efectuar estes passos. Restaurar as definições também restaurará a funcionalidade, mas poderá provocar o ressurgimento do comportamento ou da mensagem de erro original.
  1. Clique em Iniciar, clique em Executar, escreva msconfig na caixa Abrir e clique em OK.
  2. No separador Geral, clique em Arranque selectivo.
  3. Em Arranque selectivo, clique para desmarcar as seguintes caixas de verificação:
    • Processar ficheiro System.ini
    • Processar ficheiro Win.ini
    • Carregar itens de arranque
  4. No separador Serviços, clique para seleccionar a caixa de verificação Ocultar todos os serviços da Microsoft e clique em Desactivar todos.
  5. Clique em OK e em Reiniciar.
Para efectuar um procedimento de arranque limpo, clique em Reproduzir para visualizar a transmissão de multimédia em sequência de demonstração.
Para voltar a um arranque normal depois de efectuar um procedimento de arranque limpo, clique em Reproduzir para visualizar a transmissão de multimédia em sequência de demonstração.
Para obter mais informações ou para ver passos para outros sistemas operativos, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
331796 Como efectuar um procedimento de arranque limpo para impedir que programas em segundo plano interfiram com um jogo ou com um programa actualmente em utilização
Se o problema persistir, avance para o método seguinte.

Método 8: Instalar e iniciar o jogo a partir de outra unidade de CD ou de DVD

Se este problema persistir, a unidade de CD poderá não ter capacidade para ler o CD do jogo correctamente.

Tente instalar o jogo a partir de outra unidade de CD ou DVD no mesmo computador ou noutro computador. Se a instalação tiver êxito e conseguir iniciar o jogo neste teste, o problema poderá residir no facto de a unidade de CD ou DVD original não conseguir ler o CD do jogo.

Método 9: Procurar emuladores de CD (CDs virtuais) instalados no computador

Um emulador de CD cria unidades de CD virtuais nos sistemas Windows. Poderá vê-las na janela O meu computador ou utilizando o Explorador do Windows. Apesar de as unidades de CD virtuais poderem parecer unidades de CD físicas dentro do sistema operativo, existem diferenças significativas em relação a uma unidade de CD ou DVD real. Em vez de ser um componente de hardware que o utilizador instala no computador, um emulador de CD copia CDs como um ficheiro de imagem para o disco rígido.

Como posso reconhecer uma unidade de CD virtual instalada num computador?

Abra O meu computador e conte o número de unidades de CD, DVD, CDRW. Conte o número de unidades de CD fisicamente instaladas no computador. Também pode expandir a janela do Gestor de dispositivos para ver quantos dispositivos de CD tem instalados.

Para o fazer, siga estes passos:
  1. Clique em Iniciar, aponte para Definições e clique em Painel de controlo.
  2. Faça duplo clique em Sistema.
  3. Se estiver a utilizar um computador baseado no Microsoft Windows 98 ou no Microsoft Windows Millennium (Me), clique no separador Gestor de dispositivos.

    Se estiver a utilizar um computador baseado no Microsoft Windows 2000 ou no Microsoft Windows XP, clique no separador Hardware e clique em Gestor de dispositivos.
  4. Expanda CD-ROM ou expanda Unidades de DVD/CD-ROM.
  5. Conte as unidades listadas.
  6. Feche todas as janelas que estejam abertas no ambiente de trabalho.
Depois de saber quantas unidades tem no Gestor de dispositivos, examine o computador e conte as unidades de CD que tem no computador observando a caixa.

Lembre-se que poderá ter de abrir uma tampa na parte frontal do computador para ver as unidades físicas instaladas. Também poderão existir unidades externas ligadas através de USB ou SCSI. Se existirem mais unidades de CD listadas em O meu computador do que as ligadas ou instaladas no computador, tem provavelmente uma unidade de CD virtual ou um emulador de CD instalado.

Método 10: Iniciar sessão como Administrador (apenas no Microsoft Windows NT, Microsoft Windows 2000 e Microsoft Windows XP)

Se estiver a utilizar o Windows NT, o Windows 2000 ou o Windows XP, termine a sessão no computador e, em seguida, inicie sessão novamente como um utilizador com direitos de Administrador.

Se o problema persistir, avance para o método seguinte.

Método 11: Alterar o modo de transferência DMA para o modo PIO (Windows XP)

  1. No Windows XP, clique em Iniciar e clique em Painel de controlo.
  2. Faça duplo clique em Sistema, clique no separador Hardware e clique em Gestor de dispositivos.

    Se não vir o Sistema, clique em Mudar para a vista clássica no painel esquerdo.
  3. Faça duplo clique em Controladores IDE ATA/ATAPI, faça duplo clique em Canal IDE secundário e clique no separador Definições avançadas.

    Nota: se não vir o separador Definições avançadas, o computador tem provavelmente uma unidade SCSI. As opções do modo de transferência DMA não estão disponíveis para unidades SCSI.
  4. Em Dispositivo 0, seleccione Somente PIO na caixa Modo de transferência. Se tiver mais do que uma unidade de CD ou de DVD, seleccione também Somente PIO na caixa Modo de transferência de Dispositivo 1.

    Nota: se o Modo actual de transferência do Dispositivo 0 ou do Dispositivo 1 indicar Não aplicável, esse dispositivo não está a ser utilizado. Altere apenas os dispositivos que não indiquem Não aplicável. Se ambos os dispositivos indicarem Não aplicável, a unidade de CD ou de DVD está no canal IDE primário.
  5. Faça duplo clique em Canal IDE primário.
  6. No separador Definições avançadas, em Dispositivo 1, seleccione DMA se disponível na caixa Modo de transferência.

    Nota: o Dispositivo 0 é provavelmente a unidade de disco rígido e não deverá ser alterada.
  7. Clique em OK.
  8. Reinicie o computador.

Reduzir esta imagemExpandir esta imagem

Método 12: Verificar a existência de vírus no computador

O jogo poderá terminar, gerar uma mensagem de erro ou deixar de responder, durante o início ou quando estiver a jogar, se o computador estiver infectado por vírus.

Importante: se já tiver um programa antivírus instalado no computador, actualize-o com os ficheiros de assinaturas mais recentes antes de efectuar a verificação do computador. A maioria das empresas de software que criam programas antivírus disponibilizam um novo ficheiro de assinaturas todos os meses. Depois de obter os ficheiros de assinaturas mais recentes, efectue a verificação do computador. Para obter ajuda relativamente à obtenção de ficheiros de assinaturas antivírus, contacte o fabricante do software antivírus.

Se não tiver software antivírus instalado, veja uma lista de fornecedores de software antivírus. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
49500 Lista de fornecedores de software antivírus
Existem vários programas de detecção de vírus online gratuitos que poderá utilizar para verificar a existência de vírus no sistema; por exemplo, visite o seguinte Web site da Symantec:
http://security.symantec.com
Pode ajudar a impedir que os vírus infectem o computador e se propaguem a outros computadores. Para obter mais informações sobre como pode ajudar a inocular o computador contra vírus informáticos, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/pt-pt/security/default.aspx
Se o problema persistir, avance para o método seguinte.

Método 13: Remover spyware

Spyware é software que recolhe informações pessoais sem o seu conhecimento ou permissão. Poderá ser alvo de spyware ou de outro software não desejado se transferir música a partir de programas de partilha de ficheiros, transferir jogos gratuitos de sites que não considere fidedignos ou transferir outro software de uma origem desconhecida. O spyware poderá afectar o jogo e o processo de arranque.

Para saber mais sobre os sintomas de spyware e outro software não desejado, como remover spyware e como ajudar a proteger o computador, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/pt-pt/security/default.aspx

Método 14: Configurar os elementos essenciais do McAfee

  1. Maximize Bomb Shelter.
  2. Na caixa de diálogo Bomb Shelter, clique em Properties.
  3. No grupo Error Protection, clique em Advanced.
  4. No separador Advanced Properties, clique para desmarcar a caixa de verificação Write Protect VMM.
  5. Clique em Apply ou em OK e clique em OK em todos os ecrãs seguintes.
Se o problema persistir, avance para o método seguinte.

Método 15: Transferir a versão de firmware mais recente para a unidade de CD/DVD

Contacte o fabricante de hardware da unidade de CD para obter e instalar a versão mais recente do firmware.
Para mais informações sobre informações de contacto de fabricantes de hardware e software, visite o seguinte Web site da Microsoft: http://support.microsoft.com/gp/oemphone/pt A Microsoft fornece informações de contacto de outros fabricantes para o ajudar na obtenção de suporte técnico. Estas informações de contacto poderão ser alteradas sem aviso prévio. A Microsoft não garante o rigor das informações sobre o contacto destes fabricantes.

Para ver se estão disponíveis actualizações de controladores aplicáveis, visite o seguinte Web site da Microsoft:
http://www.update.microsoft.com/windowsupdate/v6/vistadefault.aspx?ln=pt-pt
Clique em Reproduzir para ver esta transmissão de multimédia em sequência de demonstração.

Mais Informação

Dado que os jogos Microsoft listados na secção "Aplica-se a" são programas protegidos contra cópia, tem de inserir o CD do jogo na unidade de CD para executar o programa.

Isto também se verifica se copiar o conteúdo do CD do jogo para um disco rígido, um servidor ou outro dispositivo de armazenamento e, em seguida, instalar o jogo a partir do mesmo.

Para obter mais informações sobre como resolver problemas relacionados com erros de leitura de CDs no Windows 95, Windows 98 e Windows Millennium Edition, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
218617 Como resolver problemas de leitura em unidades CD-ROM ou DVD-ROM

Para obter ajuda relativamente a problemas de unidade de CD ou DVD no Windows Vista, visite a seguinte página Web da Microsoft:
Corrigir problemas nos quais a sua unidade de CD ou DVD não lê nem grava dados no Windows

Propriedades

Artigo: 228985 - Última revisão: quarta-feira, 13 de Março de 2013 - Revisão: 40.0
A informação contida neste artigo aplica-se a:
  • Microsoft Age of Empires II: The Conqueror's Expansion
  • Microsoft Age of Empires II Gold Edition
  • Microsoft Age of Empires III
  • Microsoft Age of Empires III : The WarChiefs
  • Microsoft Age of Mythology
  • Microsoft Age of Mythology: The Titans
  • Microsoft Age of Mythology Gold
  • Microsoft Baseball 2001
  • Microsoft Casino
  • Microsoft Combat Flight Simulator 2: WWII Pacific Theater
  • Microsoft Combat Flight Simulator 3: Battle for Europe
  • Microsoft Crimson Skies
  • Microsoft Dungeon Siege
  • Microsoft Dungeon Siege: Legends of Aranna
  • Microsoft Dungeon Siege 2.0
  • Fable: The Lost Chapters PC
  • Microsoft Flight Simulator 2000 Standard Edition
  • Microsoft Flight Simulator 2000 Professional Edition
  • Microsoft Flight Simulator 2002 Standard Edition
  • Microsoft Flight Simulator 2002 Professional Edition
  • Microsoft Flight Simulator 2004 Century of Flight
  • Microsoft Freelancer
  • Microsoft Gears of War (PC)
  • Microsoft Golf 2001
  • Microsoft Halo PC 1.0
  • Microsoft Impossible Creatures
  • Microsoft Links LS 2000
  • Microsoft Links 2001 Standard Edition
  • Microsoft MechCommander 2
  • Microsoft MechWarrior 4: Vengeance
  • Microsoft MechWarrior 4: Mercenaries
  • Microsoft Metal Gear Solid
  • Microsoft Midtown Madness
  • Microsoft NBA Inside Drive 2000
  • Microsoft Rise of Nations
  • Microsoft Rise of Nations: Gold Edition
  • Microsoft Rise of Nations: Rise of Legends
  • Microsoft Rise of Nations: Thrones and Patriots
  • Microsoft Starlancer
  • Microsoft eMbedded Visual C++ 4.0
  • Microsoft Viva Pinata (PC)
  • Microsoft Zoo Tycoon 2
  • Microsoft Zoo Tycoon Complete Collection
  • Microsoft Zoo Tycoon: Dinosaur Digs 1.0
  • Microsoft Zoo Tycoon: Marine Mania
  • Microsoft Zoo Tycoon 2: African Adventure
  • Microsoft Zoo Tycoon 2: Dino Danger
  • Microsoft Zoo Tycoon 2: Endangered Species
  • Microsoft Zoo Tycoon 2: Marine Mania
  • Microsoft Fable III for PC
Palavras-chave: 
dftsdahomeportal kbhowto kbarttypeshowme kberrmsg kbprb kbsetup KB228985

Submeter comentários