FIX: subproceso contador aumenta rápidamente cuando se utiliza el adaptador de WCF de SQL Server las ubicaciones de recepción en BizTalk Server 2006 R2 o BizTalk Server 2009

Seleccione idioma Seleccione idioma
Id. de artículo: 2300507
Expandir todo | Contraer todo

En esta página

Síntomas

Considere el siguiente escenario:

  • Usa Windows Communications Foundation (WCF) mediante programación en un equipo que ejecuta Microsoft BizTalk Server 2006 R2 o Microsoft BizTalk Server de 2009.
  • Crear una ubicación de recepción que utiliza el adaptador de SQL Server desde el paquete de adaptador de BizTalk 2.0 para la recepción de mensajes.
En este escenario, puede experimentar los síntomas siguientes:
  • Instancias de orquestación que se encuentran en laDeshidratadasestado del sistema.
  • La ubicación de recepción no procesa los mensajes nuevos.
  • Exclusivo bloqueos aparecen en las tablas de base de datos, y encuentra errores en el seguimiento DTC.
  • Es posible que vea el DTCXact transacción abra cuando el programa se ejecuta DBCC OPENTRAN.

Además, si supervisa laProcess\ThreadCount $ BTSNTSvccontador en Monitor de rendimiento, es posible que vea el valor de número de subprocesos aumenta rápidamente.

Causa

Este problema se produce porque el valor de tiempo de espera de WCF no se sincroniza con el tiempo de espera de recepción cuando no hay ningún dato para sondear. Además, WCF abre un canal nuevo y espera a que los mensajes en el canal nuevo. Esto puede provocar una situación de pérdida de memoria.

Solución

Para resolver este problema, aplique este hotfix.

Obtener más información acerca de esta revisión.

Información de la revisión

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a sistemas que experimenten el problema descrito en este artículo. Esta revisión es posible que realicen pruebas adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si no aparece en esta sección, póngase en contacto con el servicio de cliente de Microsoft y soporte técnico para obtener la revisión.

NotaSi, además de aparecer problemas o si necesita solucionar un problema, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión en cuestión. Para obtener una lista completa de servicio al cliente de Microsoft y soporte técnico de números de teléfono o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
NotaEl formulario "Descarga de revisión disponibles" muestra los idiomas para los que la revisión está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Debe tener el WCF LOB adaptador SDK Service Pack 2 (SP2) instalado para aplicar este hotfix.

Información de reinicio

No es necesario que reinicie el equipo después de aplicar este hotfix.

Información de archivo

Versión de el inglés de esta revisión tiene los atributos de archivo (o atributos de archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre hora UTC y la hora local, utilice elZona horariaen la ficha delFecha y horaelemento de panel de control.

WCF LOB SDK de adaptador de Service Pack 2 (x 86 en)
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempoPlataforma
Microsoft.ServiceModel.Channels.dll3.0.5308.0280,44803-Ago-201002: 56x 86
WCF LOB SDK de adaptador de Service Pack 2 (x 64 compatibles)
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempoPlataforma
Microsoft.ServiceModel.Channels.dll3.0.5308.0276,35203-Ago-201002: 59x 64


Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "Se refiere a:".

Propiedades

Id. de artículo: 2300507 - Última revisión: viernes, 03 de septiembre de 2010 - Versión: 1.0
Palabras clave: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbprb kbexpertiseinter kbbtsadapters kbbiztalk2009presp1fix kbmt KB2300507 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2300507

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com