Article ID: 2379016 - View products that this article applies to.
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SYMPTOMS

When you start a computer that is running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 Service Pack (SP2), the computer stops responding and appears to hang at the "Applying User Settings" or "Applying Computer Settings" stage of the logon process.

You may experience that the "network connections" folder is empty. Additionally, the following services may not start at startup.

Note These services are set to the "Automatic" startup type.
  • Print Spooler
  • Terminal Services
  • Server service
  • Remote Registry
  • Windows Management Instrumentation (WMI)
  • Distributed Transaction Coordinator
  • Any services that are related to applications
Note This issue typically occurs after you install a server certificate and then configure Secure Sockets Layer (SSL) on the computer. For example, you install a SSL server certificate in Internet Information Services (IIS) 7.0 and then enable HTTPS on your website to use the certificate.

CAUSE

This issue occurs because of a deadlock in the Service Control Manager database.

The Service Control Manager tries to start the HTTP.sys service and then puts a lock in place in the Service Control Manager database. Then, HTTP.sys makes a call that requires Cryptographic Services during startup. Then, a request is sent to start Cryptographic Services. However, a lock is already in place in the Service Control Manager database. Therefore, a deadlock occurs.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Vista Service Pack 2 (SP2) or Windows Server 2008 Service Pack 2 (SP2).

For more information about how to obtain a Windows Vista service pack, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack
For more information about how to obtain a Windows Server 2008 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
968849 How to obtain the latest service pack for Windows Server 2008

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Vista and Windows Server 2008 file information notes
Important Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

Click here to view or hide detailed information

WORKAROUND

Workaround for Windows Vista and for Windows Server 2008

To have us work around the issue for you, go to the "Fix it for me" section. If you prefer to work around the issue yourself, go to the "Let me fix it myself" section.

Fix it for me



To work around the issue automatically, click the Fix it button or link. In the File Download dialog box, click Run, and then follow the steps in the Fix it Wizard.


Fix this problem
Microsoft Fix it 50564

Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD, and then run it on the computer that has the problem.



Let me fix it myself


Note The following method can be used in Windows Safe Mode when you are not able to log on successfully to install the hotfix or fixit.

To work around the issue without installing the hotfix, create a DependOnService registry key to modify the behavior of HTTP.sys. This makes HTTP.sys depend on crytosvc service to be started first. To do this, follow these steps:
  1. Click Start
    Collapse this imageExpand this image
    Start button
    , type regedit in the Start Search box, and then press ENTER.
    Collapse this imageExpand this image
    UAC
    If you are prompted for an administrator password or for confirmation, type the password, or provide confirmation.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP
  3. On the Edit menu, point to New, and then click Multi-string Value.
  4. Type DependOnService, and then press ENTER.
  5. Right-click DependOnService, and then click Modify.
  6. In the Value data box, type CRYPTSVC, and then click OK.
  7. Exit Registry Editor.
  8. Restart the computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Click here to view or hide detailed information

Properties

Article ID: 2379016 - Last Review: March 26, 2012 - Revision: 12.0
APPLIES TO
  • Windows Server 2008 Service Pack 2, when used with:
    • Windows Server 2008 Datacenter without Hyper-V
    • Windows Server 2008 Enterprise without Hyper-V
    • Windows Server 2008 for Itanium-Based Systems
    • Windows Server 2008 Foundation
    • Windows Server 2008 Standard without Hyper-V
    • Windows Server 2008 Datacenter
    • Windows Server 2008 Enterprise
    • Windows Server 2008 Standard
    • Windows Web Server 2008
  • Windows Vista Service Pack 2, when used with:
    • Windows Vista Business
    • Windows Vista Business 64-bit Edition
    • Windows Vista Enterprise
    • Windows Vista Ultimate
    • Windows Vista Enterprise 64-bit Edition
    • Windows Vista Ultimate 64-bit Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter kbgraphxlink kbcip KB2379016

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