You cannot configure a Wi-Fi Protected Setup device from a computer that is running Windows 7

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Article ID: 2387530 - View products that this article applies to.
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SYMPTOMS

When you try to connect the computer to a Wi-Fi Protected Setup (WPS) device, Windows 7 may not offer an option to configure the device. This offer is usually in the form of a wizard, a prompt, a button displayed on the desktop or sometimes a request for a PIN. Taking this action along with pushing a button on the external device will help the device connect to your computer or network. Without this interaction the connection may fail..

CAUSE

This issue occurs because Windows 7 does not follow the Wi-Fi Protected Setup (WPS) standard. The Wi-Fi Protected Setup specification version 1.0h of the Wi-Fi Alliance requires devices to ignore unrecognized attributes. A device that uses nonstandard attributes may send a message that contains an attribute that Windows 7 does not recognize. In this situation, Windows 7 does not ignore the unrecognized attribute that is present in the message that Windows 7 receives as expected. Therefore, an interoperability issue occurs and the device cannot be configured.

RESOLUTION

To resolve this issue, click the link below for how to install Windows 7 Service Pack 1 (SP1):

Service Pack Center

Note: If the Windows 7 (SP1) has already been installed, you do not need to install this hotfix. If you do not wish to, or are unable to install Windows 7 SP1, follow the instructions below to install this update.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article.
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If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites to apply this hotfix.

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You may have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows 7 file information note
Important Windows 7 and Windows Server 2008 R2 updates are included in the same packages.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    Collapse this tableExpand this table
    VersionProductMilestoneService branch
    6.1.760 0.16xxxWindows 7 and Windows Server 2008 R2RTMGDR
    6.1.760 0.20xxxWindows 7 and Windows Server 2008 R2RTMLDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows 7" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Fdwcn.dll6.1.7600.1638581,92014-Jul-200901:15x86
Wcnapi.dll6.1.7600.1638586,52814-Jul-200901:16x86
Wcncsvc.dll6.1.7600.16661276,99221-Aug-201005:36x86
Wcncsvc.mofNot applicable3,80110-Jun-200921:21Not applicable
Wcneapauthproxy.dll6.1.7600.1638520,48014-Jul-200901:16x86
Wcneappeerproxy.dll6.1.7600.1638520,99214-Jul-200901:16x86
Fdwcn.dll6.1.7600.1638581,92014-Jul-200901:15x86
Wcnapi.dll6.1.7600.1638586,52814-Jul-200901:16x86
Wcncsvc.dll6.1.7600.20787276,48021-Aug-201006:52x86
Wcncsvc.mofNot applicable3,80110-Jun-200921:21Not applicable
Wcneapauthproxy.dll6.1.7600.1638520,48014-Jul-200901:16x86
Wcneappeerproxy.dll6.1.7600.1638520,99214-Jul-200901:16x86
For all supported x64-based versions of Windows 7
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Fdwcn.dll6.1.7600.16385101,37614-Jul-200901:40x64
Wcnapi.dll6.1.7600.16385120,83214-Jul-200901:41x64
Wcncsvc.dll6.1.7600.16661367,10421-Aug-201006:38x64
Wcncsvc.mofNot applicable3,80110-Jun-200920:39Not applicable
Wcneapauthproxy.dll6.1.7600.1638524,57614-Jul-200901:41x64
Wcneappeerproxy.dll6.1.7600.1638525,08814-Jul-200901:41x64
Fdwcn.dll6.1.7600.16385101,37614-Jul-200901:40x64
Wcnapi.dll6.1.7600.16385120,83214-Jul-200901:41x64
Wcncsvc.dll6.1.7600.20787366,59221-Aug-201007:24x64
Wcncsvc.mofNot applicable3,80110-Jun-200920:39Not applicable
Wcneapauthproxy.dll6.1.7600.1638524,57614-Jul-200901:41x64
Wcneappeerproxy.dll6.1.7600.1638525,08814-Jul-200901:41x64
Fdwcn.dll6.1.7600.1638581,92014-Jul-200901:15x86
Wcnapi.dll6.1.7600.1638586,52814-Jul-200901:16x86
Wcncsvc.dll6.1.7600.16661276,99221-Aug-201005:36x86
Wcneapauthproxy.dll6.1.7600.1638520,48014-Jul-200901:16x86
Wcneappeerproxy.dll6.1.7600.1638520,99214-Jul-200901:16x86
Fdwcn.dll6.1.7600.1638581,92014-Jul-200901:15x86
Wcnapi.dll6.1.7600.1638586,52814-Jul-200901:16x86
Wcncsvc.dll6.1.7600.20787276,48021-Aug-201006:52x86
Wcneapauthproxy.dll6.1.7600.1638520,48014-Jul-200901:16x86
Wcneappeerproxy.dll6.1.7600.1638520,99214-Jul-200901:16x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7

Click here to view or hide detailed files information

Properties

Article ID: 2387530 - Last Review: September 2, 2011 - Revision: 6.0
APPLIES TO
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Enterprise
  • Windows 7 Professional
  • Windows 7 Ultimate
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter kbcip KB2387530

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