Applies ToWindows Server 2008 R2 Datacenter Windows Server 2008 R2 Enterprise Windows Server 2008 R2 for Itanium-Based Systems Windows Server 2008 R2 Foundation Windows Server 2008 R2 Standard Windows Server 2008 R2 Web Edition Windows 7 Enterprise Windows 7 Home Basic Windows 7 Home Premium Windows 7 Professional Windows 7 Starter Windows 7 Ultimate

Not sure if this is the right fix? We've added this issue to our memory dump diagnostic which can confirm.

Symptoms

On a computer that is running Windows Server 2008 R2 or Windows 7, one of the following Stop errors is returned when you create a snapshot of a volume:

STOP: 0x0000007E (parameter1, parameter2, parameter3, parameter4) SYSTEM_THREAD_EXCEPTION_NOT_HANDLED Stop 0x00000050 (parameter1 , parameter2 , parameter3 , parameter4 ) PAGE_FAULT_IN_NONPAGED_AREA

For example, you may experience this issue after you enable shadow copy functionality on a volume that is configured with a secondary Data Protection Manager (DPM) server for backup.Notes

  • The parameters in this error message vary, depending on the configuration of the computer.

  • Not all "0x0000007E" or "0x00000050" Stop errors are caused by this problem.

Cause

This issue occurs because of a race condition in the Volume Shadow Copy driver (Volsnap.sys). This race condition may occur when the volume size changes during the snapshot creation process.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:

  • Windows 7

  • Windows 7 Service Pack 1 (SP1)

  • Windows Server 2008 R2

  • Windows Server 2008 R2 Service Pack 1 (SP1)

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information notes

Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    Version

    Product

    SR_Level

    Service branch

    6.1.7600.20xxx

    Windows 7 and Windows Server 2008 R2

    RTM

    LDR

    6.1.7601.21xxx

    Windows 7 and Windows Server 2008 R2

    SP1

    LDR

  • GDR service branches contain only those fixes that are widely released to address widespread, very important issues. LDR service branches contain hotfixes in addition to widely released fixes.

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 7

File name

File version

File size

Date

Time

Platform

Volsnap.sys

6.1.7600.20861

245,120

18-Dec-2010

05:35

x86

Volsnap.sys

6.1.7601.21624

245,632

18-Dec-2010

08:06

x86

For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Volsnap.sys

6.1.7600.20861

295,296

18-Dec-2010

06:13

x64

Volsnap.sys

6.1.7601.21624

295,808

18-Dec-2010

08:56

x64

For all supported IA-64-based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Volsnap.sys

6.1.7600.20861

676,224

18-Dec-2010

05:23

IA-64

Volsnap.sys

6.1.7601.21624

676,736

18-Dec-2010

09:41

IA-64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7

File name

X86_volume.inf_31bf3856ad364e35_6.1.7600.20861_none_162850b776798766.manifest

File version

Not applicable

File size

2,083

Date (UTC)

18-Dec-2010

Time (UTC)

05:54

Platform

Not applicable

File name

X86_volume.inf_31bf3856ad364e35_6.1.7601.21624_none_183cee4b737ccf93.manifest

File version

Not applicable

File size

2,083

Date (UTC)

18-Dec-2010

Time (UTC)

08:27

Platform

Not applicable

Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

Amd64_volume.inf_31bf3856ad364e35_6.1.7600.20861_none_7246ec3b2ed6f89c.manifest

File version

Not applicable

File size

2,087

Date (UTC)

18-Dec-2010

Time (UTC)

06:48

Platform

Not applicable

File name

Amd64_volume.inf_31bf3856ad364e35_6.1.7601.21624_none_745b89cf2bda40c9.manifest

File version

Not applicable

File size

2,087

Date (UTC)

18-Dec-2010

Time (UTC)

09:21

Platform

Not applicable

Additional files for all supported IA-64-based versions of Windows Server 2008 R2

File name

Ia64_volume.inf_31bf3856ad364e35_6.1.7600.20861_none_1629f4ad76779062.manifest

File version

Not applicable

File size

2,085

Date (UTC)

18-Dec-2010

Time (UTC)

06:48

Platform

Not applicable

File name

Ia64_volume.inf_31bf3856ad364e35_6.1.7601.21624_none_183e9241737ad88f.manifest

File version

Not applicable

File size

2,085

Date (UTC)

18-Dec-2010

Time (UTC)

09:55

Platform

Not applicable

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