Se produce un error en una consulta LDAP paginada en la segunda página y las páginas que siguen en Windows Server 2008 R2

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Síntomas

Tenga en cuenta la situación siguiente:
  • Tiene un servidor de LDAP (Lightweight Directory Access Protocol) o el controlador de dominio que se está ejecutando Windows Server 2008 R2.
  • Realiza una consulta LDAP paginada contra el controlador de dominio.
  • Utilice elcreateTimeStampomodifyTimeStampatributo en el filtro de consulta.
  • El resultado de la consulta abarca varias páginas.
En este escenario, la consulta LDAP paginada produce un error en la segunda página y las páginas que siguen a la segunda página.

A continuación se ofrece un ejemplo:
  • Implementar un controlador de dominio que ejecuta Windows Server 2008 R2.
  • Implementar un servidor de Microsoft Exchange Server 2007 en un equipo y, a continuación, habilita Microsoft Office Outlook Web Access.
  • Puede configurar la suficiente información de usuario para permitir que más de una página de resultados de una búsqueda de global de direcciones (GAL) de la lista.
  • Introduzca un término de búsqueda que va a devolver más de una página de resultados.
  • Intenta desplazarse a través de varias páginas de los resultados de búsqueda de GAL.
En este escenario, no podrá desplazarse hacia atrás por los resultados y recibirá el siguiente mensaje de error:

No se pudo conectar a un servidor de directorio. Si el problema persiste, póngase en contacto con el soporte técnico para su organización.

Causa

El problema ocurre porque algunos filtros de búsqueda se cambian de forma incorrecta en las consultas LDAP paginada.

Solución

Información de la revisión

Hay un hotfix compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema que se describe en este artículo. Aplíquela sólo a los sistemas que experimenten el problema descrito en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a que la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, no hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si no aparece en esta sección, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

NotaSi se producen de problemas adicionales o si necesita solucionar un problema, es posible que deba crear una solicitud de servicio independiente. Los costos de soporte técnico usuales se aplicarán a las cuestiones y problemas que no reúnan los requisitos para esta revisión en cuestión. Para obtener una lista completa de los números de teléfono de soporte y servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
NotaEl formulario de "Descarga de revisión disponible" muestra los idiomas para los que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe estar ejecutando el sistema operativo siguiente:

  • Windows Server 2008 R2
  • Service Pack 1 (SP1) de Windows Server 2008 R2

Información del registro

Para utilizar la revisión, no es necesario cambiar el registro.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de hotfix

Esta revisión no sustituye a ninguna revisión publicada previamente.

Información de archivo

La versión global de esta revisión instala los archivos que tienen los atributos que aparecen en las tablas siguientes. Las fechas y las horas de estos archivos se muestran en hora Universal coordinada (UTC). Las fechas y las horas de estos archivos en el equipo local se muestran en horario local junto con la diferencia de horario de verano (DST) actual. Además, las fechas y las horas pueden cambiar cuando realiza ciertas operaciones en los archivos.
Notas sobre la información de archivo de Windows Server 2008 R2
ImportanteLas correcciones urgentes de Windows 7 y Windows Server 2008 R2 se incluyen en los mismos paquetes. Sin embargo, se enumeran las revisiones en la página de solicitud de revisión en ambos sistemas operativos. Para solicitar el paquete de revisiones que se aplica a uno o ambos sistemas operativos, seleccione la revisión que aparece bajo "Windows 7 o Windows Server 2008 R2" en la página. Siempre hacen referencia a la sección "Aplicable A" en los artículos para determinar el sistema operativo real que se aplica cada revisión.
  • Los archivos que se aplican a un producto específico, SR_Level (RTM, SPn), y la rama de servicio (LDR, GDR) se puede identificar examinando los números de versión del archivo tal como se muestra en la tabla siguiente.
    Contraer esta tablaAmpliar esta tabla
    VersiónProductoSR_LevelRama de servicio
    6.1.7600.20xxxWindows Server 2008 R2RTMLDR
    6.1.7601.21xxxWindows Server 2008 R2SERVICE PACK 1LDR
  • Los archivos MANIFEST (.manifest) y los MUM (.mum) que se instala para cada entorno estánla lista por separadoen la sección "información de archivos adicionales para Windows Server 2008 R2". MUM y archivos de manifiesto y los archivos de catálogo (.cat) de seguridad asociados, son extremadamente importantes para mantener el estado de los componentes actualizados. Los archivos de catálogo de seguridad, para el que no se muestran los atributos, están firmados con una firma digital de Microsoft.
Para todas las versiones de 64 compatibles de Windows Server 2008 R2 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño del archivoFechaTiempoPlataforma
Ntdsa.MOFNo se puede aplicar227,76510-Jun-200920: 34No se puede aplicar
Ntdsai.dll6.1.7600.208612,723,32818-Dic-201009: 06x 64
Ntdsa.MOFNo se puede aplicar227,76505-Nov-201001: 54No se puede aplicar
Ntdsai.dll6.1.7601.216242,723,32818-Dic-201008: 51x 64

Solución

ImportanteEsta sección, el método o la tarea se explican los pasos que le indicarán cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para mayor protección, copia de seguridad del registro antes de modificarlo. A continuación, puede restaurar el registro si surge algún problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo hacer copia de seguridad y restaurar el registro en Windows

Para evitar el problema, debe crear una subclave del registro en el servidor LDAP. Para ello, siga estos pasos:
  1. Haga clic enInicio
    Contraer esta imagenAmpliar esta imagen
    botón Inicio
    , tipoRegediten elBuscar programas y archivoscuadro y, a continuación, presione ENTRAR.
    Contraer esta imagenAmpliar esta imagen
    UAC
    Si se le pida una contraseña de administrador, escriba la contraseña. Si se le pida confirmación, proporcione una confirmación.
  2. Busque y, a continuación, haga clic en la siguiente subclave del registro:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NTDS\Parameters
  3. En elEditarmenú, elijaNuevoy, a continuación, haga clic enValor de cadena.
  4. TipoHeurística DSA, y, a continuación, presione ENTRAR.
  5. Con el botón secundarioHeurística DSAy, a continuación, haga clic enModificar.
  6. En elInformación del valorcuadro, escriba000000000001y, a continuación, haga clic enACEPTAR.
  7. Salga del Editor del registro.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Más información

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Información adicional de archivos

Información adicional de archivos para Windows Server 2008 R2

Archivos adicionales para todas las versiones de 64 compatibles de Windows Server 2008 R2 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoAmd64_149ee8c9e20c2afd3347ba6c7b8f3a51_31bf3856ad364e35_6.1.7601.21624_none_e08641138148d4a0.manifest
Versión del archivoNo se puede aplicar
Tamaño del archivo716
Fecha (UTC)21-Dic-2010
Hora (UTC)14: 00
PlataformaNo se puede aplicar
Nombre de archivoAmd64_ffed5210101de2b65fbc8adf4e82aac4_31bf3856ad364e35_6.1.7600.20861_none_bb751eb51b570fad.manifest
Versión del archivoNo se puede aplicar
Tamaño del archivo716
Fecha (UTC)21-Dic-2010
Hora (UTC)14: 00
PlataformaNo se puede aplicar
Nombre de archivoAmd64_microsoft-windows-d...toryservices-ntdsai_31bf3856ad364e35_6.1.7600.20861_none_4d5676a6ebe4c26e.manifest
Versión del archivoNo se puede aplicar
Tamaño del archivo3,531
Fecha (UTC)18-Dic-2010
Hora (UTC)06: 54
PlataformaNo se puede aplicar
Nombre de archivoAmd64_microsoft-windows-d...toryservices-ntdsai_31bf3856ad364e35_6.1.7601.21624_none_4f6b143ae8e80a9b.manifest
Versión del archivoNo se puede aplicar
Tamaño del archivo3,531
Fecha (UTC)18-Dic-2010
Hora (UTC)09: 27
PlataformaNo se puede aplicar

Propiedades

Id. de artículo: 2468316 - Última revisión: jueves, 10 de febrero de 2011 - Versión: 1.0
La información de este artículo se refiere a:
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
Palabras clave: 
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Traducción automática
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Haga clic aquí para ver el artículo original (en inglés): 2468316

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