REVISIÓN: Tarda más de un minuto para desproteger un archivo en un servidor que ejecuta Visual Studio Team System 2008 Team Foundation Server Service Pack 1

Seleccione idioma Seleccione idioma
Id. de artículo: 2479245 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando desprotege un archivo desde un servidor que ejecuta Microsoft Visual Studio Team System 2008 Team Foundation Server Service Pack 1, que tarda más de un minuto para completar la desprotección.

Causa

Este problema se produce porque elPrc_ichecklockstatsusprocedimiento almacenado se ejecuta muy lentamente en el nivel de datos de Team Foundation Server.

Solución

ImportanteSi está ejecutando en el mismo equipo que el nivel de aplicación de TFS Team Explorer, Team Build o el Proxy de TFS, también necesitará instalar la revisión que se describe en el siguiente artículo de Knowledge Base:
974596No se reduce el tamaño de la base de datos de TfsVersionControl tanto como se esperaba al ejecutar el comando "tf destroy" en Microsoft Visual Studio 2008 Team Foundation Server

Información de la revisión

Hay un hotfix compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Esta revisión sólo se aplican a sistemas que experimenten el problema descrito en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a que la próxima actualización de software que contenga este hotfix.

Para resolver este problema inmediatamente, póngase en contacto con los servicios de soporte técnico de Microsoft para obtener la revisión. Para obtener una lista completa de los números de teléfono de soporte y servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
NotaEn casos especiales, los costos derivados normalmente llamadas de soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft determina que una actualización específica resolverá el problema. Los costos de soporte técnico usuales se aplicarán a las cuestiones y problemas que no reúnan los requisitos para la actualización en cuestión.

Para descargar este hotfix desde MSDN Code Gallery, visite el siguiente sitio Web de Microsoft:
http://Code.msdn.Microsoft.com/KB2479245

NotaLa Galerie de Code muestra los idiomas para los que la revisión está disponible. Si no ve su idioma en la lista, es porque la página de recursos de la Galería de códigos no está disponible para ese idioma.

Como alternativa, puede descargar este hotfix desde el siguiente sitio Web de Microsoft Connect:
¿https://Connect.Microsoft.com/VisualStudio/downloads/downloaddetails.aspx?DownloadID = 33579

Requisitos previos

Para aplicar este hotfix, debe tener Visual Studio Team System 2008 Team Foundation Server Service Pack 1 instalado.

Información de reinicio

Tendrá que reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de hotfix

Esta revisión no sustituye a ninguna revisión publicada previamente.

Información de archivo

La versión en inglés (Estados Unidos) de esta revisión instala los archivos que tienen los atributos que aparecen en las tablas siguientes. Las fechas y las horas de estos archivos se muestran en hora Universal coordinada (UTC). Se muestran las fechas y las horas de estos archivos en el equipo local en horario local junto con la diferencia de horario de verano (DST) actual. Además, las fechas y las horas pueden cambiar cuando realiza ciertas operaciones en los archivos.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempoPlataforma
Microsoft.TeamFoundation.Client.dll9.0.30729.5086458,75212-Ene-201118: 00x 86
Microsoft.TeamFoundation.Common.dll9.0.30729.5086331,77612-Ene-201118: 00x 86
Microsoft.TeamFoundation.databaseinstaller.dll9.0.30729.50864,399,10412-Ene-201118: 00x 86
Microsoft.TeamFoundation.dll9.0.30729.50861,060,86412-Ene-201118: 00x 86
Microsoft.TeamFoundation.Server.Admin.dll9.0.30729.5086163,84012-Ene-201118: 00x 86
Microsoft.TeamFoundation.WorkItemTracking.Client.dll9.0.30729.5086516,09612-Ene-201118: 00x 86
Microsoft.TeamFoundation.VersionControl.Common.dll9.0.30729.5086249.85612-Ene-201118: 00x 86
Microsoft.TeamFoundation.VersionControl.Common.Integration.dll9.0.30729.508632.76812-Ene-201118: 00x 86
Microsoft.VisualStudio.TeamSystem.Integration.dll9.0.30729.5086208,89612-Ene-201118: 00x 86
TFSAdminUtil.exe9.0.30729.508667,41612-Ene-201118: 00x 86



Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Más información

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 2479245 - Última revisión: miércoles, 02 de marzo de 2011 - Versión: 3.0
La información de este artículo se refiere a:
  • Microsoft Visual Studio Team System 2008 Team Foundation Server Service Pack 1
Palabras clave: 
kbexpertiseinter kbprb kbsurveynew kbfix kbbug kbqfe kbhotfixserver kbmt KB2479245 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2479245

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com