REVISIÓN: Actualizar datos no se produce diariamente en PowerPivot de SQL Server 2008 R2 para SharePoint si se establecen las horas de trabajo para terminar el día siguiente

Seleccione idioma Seleccione idioma
Id. de artículo: 2490555 - Ver los productos a los que se aplica este artículo
Microsoft distribuye las revisiones de Microsoft SQL Server 2008 R2 como un archivo descargable. Debido a que las revisiones son acumulativas, cada versión nueva contiene todas las revisiones y revisión de todas las revisiones de seguridad que se incluyeron con la anterior de SQL Server 2008 R2.
Expandir todo | Contraer todo

En esta página

Síntomas

Tenga en cuenta la situación siguiente:
  • Instalar y configurar Microsoft SQL Server 2008 R2 PowerPivot para SharePoint en un equipo.
  • Publicar o cargar un libro de Excel (PowerPivot) en la Galería de PowerPivot.
  • Configurar la configuración de aplicación del servicio de PowerPivot para definir el horario de oficina que traspasan los límites de un día. Por ejemplo, especificar la hora de inicio de la hora de la empresa a6: 00 A.M.y la hora de finalización2: 00 A.M.el siguiente día.
  • Habilita la actualización de datos de un libro.
  • Programar la actualización de datos para ejecutarse diariamente y, a laDespués del horario laboralhora de comienzo más temprana.
En este escenario, los datos actualiza todos los días en lugar de todos los días.

Causa

Este problema se produce porque PowerPivot de Microsoft SQL Server para SharePoint controla la programación siguiente no funcione correctamente.

Solución

Información sobre la actualización acumulativa

SQL Server 2008 R2

La solución a este problema se lanzó por primera vez en la actualización acumulativa (6). Para obtener más información acerca de cómo obtener este paquete de actualización acumulativa para SQL Server 2008 R2, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
2489376Paquete de actualización acumulativa 6 para SQL Server 2008 R2
NotaDebido a que las generaciones son acumulativas, cada nueva versión de revisión contiene todas las revisiones y revisión de todas las revisiones de seguridad que se incluyeron con la anterior de SQL Server 2008 R2. Le recomendamos que considere la posibilidad de aplicar la versión más reciente de revisión que contenga este hotfix. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
981356Compilaciones de SQL Server 2008 R2 se publicaron después del lanzamiento de SQL Server 2008 R2

Solución

Para resolver este problema, aplique la actualización acumulativa si cumple una de las siguientes condiciones:

  • No tiene una aplicación de servicios de PowerPivot.
  • Puede colocar la aplicación de servicio de PowerPivot existente y, a continuación, puede crear uno nuevo.

Si ya dispone de una aplicación de servicios de PowerPivot, y si no se puede quitar y, a continuación, cree uno nuevo, ejecute la siguiente secuencia de comandos de Transact-SQL para evitar este problema. Esta secuencia de comandos actualiza el[DataRefresh].[ProcessNextScheduledRun]procedimiento almacenado con respecto a la base de datos de aplicación de servicio de PowerPivot.
IF OBJECT_ID ( '[DataRefresh].[ProcessNextScheduledRun]', 'P' ) IS NOT NULL 
    DROP PROCEDURE [DataRefresh].[ProcessNextScheduledRun];
GO

-- The caller should update the [NextProcessDate] and set the status to 'P'.
CREATE PROCEDURE [DataRefresh].[ProcessNextScheduledRun]
@AllotedServerName [nvarchar] (256)
AS
	DECLARE @CurrentTime datetime;
	DECLARE @CurrentDate datetime;
	SET @CurrentTime = GETDATE();
	SET @CurrentDate = [DataRefresh].[DateOnly](@CurrentTime);
	SET @CurrentTime = [DataRefresh].[TimeOnly](@CurrentTime);
	-- Caller will calculate virtual run window and cancel the run that missed it.
	UPDATE [DataRefresh].[Runs] SET [RunStartTime]=GETDATE(), ResultKey='Q', ServerName=@AllotedServerName
		OUTPUT inserted.*
		WHERE [RunID] 
			in (SELECT TOP 1 [RunID]
					FROM [DataRefresh].[Runs] 
					WHERE ResultKey='W'
						AND 
						(
							(
				-- AfterBusinessHour cases that haven't been loaded to verify IT overridden business hours.
				-- To handle IT overridden business hours, we will process after business hours schedules immediately 
				-- and set [ProcessStartTime] and [ProcessEndTime] for the schedule and create other schedules if it is necessary.
								[ProcessStartTime] IS NULL 
							) 
							OR
							(	-- None AfterBusinessHour cases
								ProcessEndTime IS NULL 
								AND ( @CurrentTime>=[DataRefresh].[TimeOnly]([ProcessStartTime]) OR DATEDIFF(Day, ProcessDate, @CurrentDate)>=1)
							)
							OR 
							(
								-- BusinessHours setting crosses the day boundary.
								[DataRefresh].[TimeOnly]([ProcessStartTime])<[DataRefresh].[TimeOnly]([ProcessEndTime])
								AND (
										DATEDIFF(Day, ProcessDate, @CurrentDate)>1 
										OR
										(DATEDIFF(Day, ProcessDate, @CurrentDate)>=0 AND @CurrentTime>=[DataRefresh].[TimeOnly]([ProcessStartTime]))
									)
							)
							OR
							(
								-- BusinessHours setting within the day boundary.
								[DataRefresh].[TimeOnly]([ProcessStartTime])>[DataRefresh].[TimeOnly]([ProcessEndTime])
								AND ( @CurrentTime>=[DataRefresh].[TimeOnly]([ProcessStartTime]) OR DATEDIFF(Day, ProcessDate, @CurrentDate)>=1)
							)
							-- The following case has been coverred.
							--OR
							--(
							--	-- Very old runs that haven't been picked up.
							--	DATEDIFF(Day, ProcessDate, @CurrentDate)>1
							--)
						)
					ORDER BY [ProcessDate] ASC
				)
GO

GRANT EXECUTE ON [DataRefresh].[ProcessNextScheduledRun] TO [GeminiService_DataRefresh]
GO

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Referencias

Para obtener más información acerca de cómo crear y configurar una aplicación de servicios de PowerPivot, visite el siguiente sitio Web de Microsoft Developer Network (MSDN):
Cómo crear y configurar una aplicación de servicios de PowerPivot

Para obtener más información acerca de cómo programar un PowerPivot de datos de la actualización, visite el siguiente sitio Web de Microsoft Developer Network (MSDN):
Cómo programar una actualización de datos PowerPivot

Para obtener más información sobre el modelo de servicio Incremental para SQL Server, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
935897Un modelo de servicio Incremental está disponible desde el equipo de SQL Server para entregar revisiones para problemas detectados
Para obtener más información acerca del esquema de nomenclatura para las actualizaciones de SQL Server, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
822499Nuevo esquema de nomenclatura para los paquetes de actualización de software de Microsoft SQL Server
Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 2490555 - Última revisión: lunes, 21 de febrero de 2011 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft SQL Server 2008 R2 PowerPivot for Microsoft Excel 2010
  • Excel Services in Microsoft SharePoint Server 2010
Palabras clave: 
kbqfe kbfix kbsurveynew kbexpertiseadvanced kbmt KB2490555 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2490555

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com