REVISIÓN: "Error de Proxy 502. Se ha producido un error desconocido mientras se procesaba el certificado. (-2146893017) "error al intentar obtener acceso a un sitio Web a través de HTTPS en Forefront TMG 2010 si está habilitada...

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Id. de artículo: 2501777 - Ver los productos a los que se aplica este artículo
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Síntomas

Tenga en cuenta la situación siguiente:
  • Para habilitar la característica de inspección HTTPS en Microsoft Forefront Threat Management puerta de enlace (TMG) 2010.
  • Intente utilizar una dirección URL HTTPS para tener acceso a un sitio Web que requiere un certificado de cliente a través de Forefront TMG 2010.
  • Agregue el sitio Web a la lista de Excepciones de destino para la inspección de HTTPS.
En este escenario, no se puede acceder al sitio Web y recibe el mensaje de error siguiente:
502 Error de proxy. Se ha producido un error desconocido mientras se procesaba el certificado. (-2146893017)

Causa

Este problema se produce porque Forefront TMG 2010 envía un certificado de cliente vacía en el servidor web en el protocolo de enlace SSL.

Cuando se envía una solicitud que contiene un certificado de cliente vacía, algunos servidores web aceptan y negociar el certificado de cliente. Sin embargo, otros servidores web pueden devolver un error SSL cuando el servidor web recibe un certificado de cliente vacía y controlar el error de servidor de Forefront TMG es notcorrectly. Por lo tanto, se genera el mensaje de error que se menciona en la sección "Síntomas".

Nota Un ejemplo de un servidor web que acepta y vuelve a negociar un certificado de cliente vacía es un servidor web IIS.

Solución

Para resolver este problema, siga estos pasos:
  1. Instalar la actualización de software que se describe en el siguiente artículo de Microsoft Knowledge Base (KB):
    2498770 Actualización de software 1 paquete acumulativo de actualizaciones 3 para Forefront Threat Management Gateway (TMG) 2010 Service Pack1
  2. Ejecute la secuencia de comandos que se encuentra en el siguiente artículo:

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Referencias

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
982550 REVISIÓN: Aparece un mensaje de Error cuando intenta tener acceso a un servidor web que requiere un certificado de cliente si está habilitada la inspección HTTPS de Forefront TMG 2010: "código de Error: Error de Proxy 502. El mensaje recibido fue inesperado o con formato incorrecto. (-2146893018) "
Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 Descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 2501777 - Última revisión: sábado, 23 de noviembre de 2013 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft Forefront Threat Management Gateway 2010 Service Pack 1 sobre las siguientes plataformas
    • Microsoft Forefront Threat Management Gateway 2010 Enterprise
    • Microsoft Forefront Threat Management Gateway 2010 Standard
Palabras clave: 
kbfix kbexpertiseinter kbsurveynew kbqfe kbmt KB2501777 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2501777

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