Iniciar sesión con Microsoft
Iniciar sesión o crear una cuenta
Hola:
Seleccione una cuenta diferente.
Tiene varias cuentas
Elija la cuenta con la que desea iniciar sesión.

Síntomas

Imagine la siguiente situación:

  • En Microsoft Commerce Server Catalog Manager 2009, se crea un variante producto agregando una propiedad de variante a un producto. La lista de precios para el producto de la variante difiere del precio de lista original del producto.

  • Utilice el formato de tipo de exportación completa para exportar el catálogo a un archivo XML.

  • Importar el archivo XML exportado en el catálogo mediante el formato de tipo de reemplazar .

  • Cambiar la asociación de la categoría del producto. Para ello, agregue y, a continuación, seleccione una categoría en la ficha Asociaciones de categoría .

En este escenario, se restablece la lista de precios del producto variante recién agregado en el precio de lista original del producto. Nota El problema también se produce si utiliza API de Commerce Server para realizar estas acciones.

Causa

El problema se produce porque el archivo XML de catálogo de producto de variante exportado no contiene las propiedades de precio y precio de lista originales. Al importar el archivo de catálogo XML con el formato de tipo de reemplazar , propiedades del precio del producto original se utilizan para rellenar las propiedades perdidas en el producto de variante.

Solución

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix. Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión. Nota Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Notas de instalación

Si utiliza Commerce Server 2009 Template Pack para SharePoint 2010, descargue e instale el paquete de hotfix que tiene la etiqueta "CS2009TP_KB2532193". Si utiliza Microsoft Commerce Server 2009 RTM, descargue e instale el paquete de hotfix que tiene la etiqueta "CS2009RTM_KB2532193".

Requisitos previos

La lista siguiente contiene los requisitos previos para el paquete de hotfix:

  • Microsoft Commerce Server 2009

Requisitos de reinicio

No es necesario que reinicie el equipo después de aplicar este hotfix. Sin embargo, debe reiniciar servicios de Internet Information Server (IIS) y la aplicación Commerce Server Catalog importar Host COM + después de aplicar este hotfix. Para reiniciar IIS, abra un símbolo del sistema, escriba el comando siguiente y, a continuación, presione ENTRAR:

IISRESET /RESTART Nota Este procedimiento se detiene y reinicia todos los servicios IIS que se ejecutan.

Información de reemplazo

Esta revisión no sustituye a ninguna revisión publicada previamente.

Información sobre los archivos

La versión global de esta revisión usa un paquete de Microsoft Windows Installer para instalar la revisión. Las fechas y las horas de estos archivos se muestran en hora Universal coordinada (UTC) en la tabla siguiente. Al ver la información del archivo, la fecha se convierte en hora local. Para conocer la diferencia entre la hora UTC y la hora local, use la pestaña Zona horaria del elemento Fecha y hora del Panel de control.

Para el paquete de plantillas de Microsoft Commerce Server 2009 para SharePoint 2010

Nombre de archivo

Versión de archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Cspatchhelper.exe

6.0.4171.513

16,224

12-Apr-2011

14:22

x86

Microsoft.catalogserver.dll

6.0.4171.513

763,760

12-Apr-2011

14:22

x86

Microsoft.commerceserver.runtime.dll

6.0.4171.513

849,792

12-Apr-2011

14:22

x86

Microsoft.commerceserver.catalog.dll

6.0.4171.513

960,384

12-Apr-2011

13:58

x86

Para Commerce Server 2009

Nombre de archivo

Versión de archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Cs2009hotfixhelper.exe

6.0.4171.46

12,136

06-Apr-2011

12:03

x86

Microsoft.catalogserver.dll

6.0.4171.46

763,760

06-Apr-2011

12:03

x86

Microsoft.commerceserver.runtime.dll

6.0.4171.46

849,792

06-Apr-2011

12:03

x86

Microsoft.commerceserver.catalog.dll

6.0.4171.46

960,384

06-Apr-2011

11:42

x86

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft recogidos en la sección "Se aplica a".

¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.

Las comunidades le ayudan a formular y responder preguntas, enviar comentarios y leer a expertos con conocimientos extensos.

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a su experiencia?
Si presiona Enviar, sus comentarios se usarán para mejorar los productos y servicios de Microsoft. El administrador de TI podrá recopilar estos datos. Declaración de privacidad.

¡Gracias por sus comentarios!

×