Symptomen
Neem het volgende scenario:
-
U kunt de volgende software installeren op een computer:
-
Eclips 3.5, 3.6 Eclips of een product dat is gebaseerd op een van deze versies.
-
Microsoft Visual Studio Team Explorer overal 2010 Service Pack 1 (SP1) voor Eclips
-
Windows Internet Explorer 9
-
-
Met Team Explorer overal 2010 kunt u verbinding maken met een server Team Foundation Server (TFS).
-
U probeert op te slaan of een werkitem dat enkele HTML-besturingselementen bevat weergeven.
In dit scenario wordt het opslaan of mislukt weergeven. Bovendien wordt het volgende foutbericht weergegeven:
FailedJava.lang.reflect.InvocationTargetException opslaan
Oorzaak
Dit probleem treedt op vanwege een wijziging in de JavaScript-engine die is geïntroduceerd in Internet Explorer 9. De wijziging conflicten de code aanroepen in Eclips versies waarin dit probleem optreedt. Dit conflict veroorzaakt een failaure in een functie voor het artikel dat een besturingselement wordt ingediend in Team Explorer overal 2010 SP1 RTF-tekst bevat. Daarom verschijnt het foutbericht.
Oplossing
Informatie over de hotfix
De hotfix kan worden gedownload vanaf de volgende website van Microsoft Download Center: het hotfix-pakket nu downloaden. Voor meer informatie over het downloaden van Microsoft-ondersteuningsbestanden klikt u op het volgende artikel in de Microsoft Knowledge Base:
119591 Microsoft-ondersteuningsbestanden downloaden via online services Microsoft heeft dit bestand gecontroleerd op virussen. Hierbij is gebruikgemaakt van software voor virusdetectie die volledig bijgewerkt was op de datum dat het bestand beschikbaar werd gesteld. Het bestand is opgeslagen op beveiligde servers die onbevoegde wijzigingen aan het bestand verhinderen. Opmerking Ga als volgt te werk om deze hotfix te installeren:
-
Sla het bestand Tfseclipseplugin, updatesitearchive, 10.1.0, qfe1.zip van het hotfix-pakket in een lokale map.
-
Eclips starten.
-
Klik in het menu Help op Nieuwe Software installeren.
-
Klik op Toevoegen.
-
Lokaal Team Explorer plug-in archief typt in het vak naam en klik vervolgens op archiveren.
-
Selecteer het bestand Tfseclipseplugin-updatesitearchive-10.1.0-qfe1.zip die u hebt opgeslagen in een lokale map en klik vervolgens op OK.
-
Klik in het dialoogvenster installeren op het selectievakje dat met het Team Explorer overal uit de lijst met functies correspondeert.
-
Klik tweemaal op volgende .
-
Accepteer de licentievoorwaarden voor Microsoft-Software en klik op volgende.
-
Klik op Voltooien.
Download en bekijkt u de volgende Microsoft-webpagina voor meer informatie over het installeren van de invoegtoepassing voor Team Foundation Server en de Client voor de opdrachtregel:
Speciale vereisten
Deze hotfix wilt installeren, moet u Microsoft Visual Studio Team Explorer overal 2010 Service Pack 1 (SP1) is geïnstalleerd op een computer hebben.
Opstartinformatie
U moet een Eclips opnieuw nadat u deze hotfix hebt toegepast.
Informatie over het vervangen van hotfixes
Deze hotfix vervangt geen eerder uitgebrachte hotfix.
Bestandsgegevens
De algemene versie van deze hotfix heeft de bestandskenmerken (of recentere bestandskenmerken) die in de volgende tabel worden weergegeven. De datums en tijden voor deze bestanden worden weergegeven in Coordinated Universal Time (UTC). Wanneer u de bestandsinformatie weergeeft, wordt deze naar lokale tijd geconverteerd. Om het verschil tussen UTC en lokale tijd op te zoeken, gebruikt u het tabblad tijdzone in het onderdeel datum en tijd in het Configuratiescherm.
Bestandsnaam |
Bestandsversie |
Bestandsgrootte |
Datum |
Tijd |
---|---|---|---|---|
Tfseclipseplugin-updatesitearchive-10.1.0-qfe1.zip |
Niet van toepassing |
12,854,618 |
24-May-2011 |
07:17 |
Tijdelijke oplossing
Om dit probleem op te lossen kunt als volgt te werk gaan:
-
Open de map Eclips programma.
-
Zoek en open Eclipse.ini in een teksteditor. Gebruik bijvoorbeeld Kladblok om het bestand te openen.
-
Voeg de volgende regel aan het einde van het bestand:
-Dcom.microsoft.tfs.client.common.ui.controls.generic.html.htmleditor.disable=
-
Sla het bestand Eclipse.ini en start Eclips.
Status
Microsoft heeft bevestigd dat dit probleem zich kan voordoen in de Microsoft-producten die worden vermeld in de sectie Van toepassing op.