Cuando se intenta tener acceso a archivos en un recurso compartido de red, el Explorador de Windows deja de responder en un equipo que ejecuta Windows 7

Seleccione idioma Seleccione idioma
Id. de artículo: 2550581 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Tenga en cuenta la situación siguiente:
  • Dispone de una red compartir que se aloja en un equipo que ejecuta Windows Server 2008 o Windows Server 2008 R2 en un entorno de red.
  • Asigne una unidad al recurso compartido de red en un equipo cliente que ejecuta Windows 7.
  • Abra algunas aplicaciones para consultar los atributos extendidos de los archivos del recurso compartido de red.
  • Abra el Explorador de Windows y, a continuación, haga clic en la unidad asignada para examinar los archivos.
En este escenario, el Explorador de Windows deja de responder durante aproximadamente 35 segundos.

Causa

Este problema se produce porque el recurso de bloque (FCB) del control de archivo inesperadamente bloqueado antes de que el cliente envía el CreateFile y QueryInformation solicitudes al servidor. Por lo tanto, el cliente no puede controlar la solicitud de notificación de salto de operación de bloqueo que es devuelto por el servidor. Este comportamiento hace que el redirector de Windows dejar de responder temporalmente.

Solución

Información de la revisión

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplicar esta revisión sólo a sistemas que experimenten el problema descrito en este artículo. Esta revisión podría ser sometida a pruebas adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a que la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si no aparece en esta sección, póngase en contacto con servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o cualquier solución de problemas es necesario, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las cuestiones y problemas que no reúnan los requisitos para esta revisión en cuestión. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe ejecutar Windows 7 o el Service Pack 1 (SP1) de Windows 7.

Para obtener más información acerca de cómo obtener un service pack de Windows 7, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
976932Información acerca de Service Pack 1 para Windows 7 y Windows Server 2008 R2

Información del registro

Para utilizar la revisión de este paquete, no es necesario realizar cambios en el registro.

Requisito de reinicio

No es necesario reiniciar el equipo después de aplicar esta revisión.

Información de reemplazo de hotfix

Esta revisión no sustituye a ninguna revisión publicada previamente.

Información de archivo

La versión global de esta revisión instala los archivos que tienen los atributos que se enumeran en las tablas siguientes. Las fechas y las horas de estos archivos se muestran en hora Universal coordinada (UTC). Se muestran las fechas y las horas de estos archivos en el equipo local en horario local junto con la diferencia de horario de verano (DST) actual. Además, las fechas y las horas pueden cambiar cuando realiza ciertas operaciones en los archivos.
Nota de información de archivo de Windows 7
Importante Las actualizaciones de Windows 7 y Windows Server 2008 R2 se incluyen en los mismos paquetes.
  • Los archivos que se aplican a un producto, hito (RTM, SPn) y servicio (LDR, GDR) pueden identificarse mediante el examen de los números de versión del archivo tal como se muestra en la tabla siguiente:
    Contraer esta tablaAmpliar esta tabla
    VersiónProductoSR_LevelRama de servicio
    6.1.760 0. 21xxxWindows 7 y Windows Server 2008 R2RTMLDR
    6.1.760 1. 21xxxWindows 7 y Windows Server 2008 R2SERVICE PACK 1LDR
  • Los archivos MANIFEST (.manifest) que se instalan para cada entorno están la lista por separado en la sección "información adicional de archivos para Windows 7". Archivos de manifiesto y la seguridad asociado (.cat), archivos de catálogo, son extremadamente importantes mantener el estado de los componentes actualizados. Los archivos de catálogo de seguridad para los que no se enumeran los atributos, están firmados con una firma digital de Microsoft.
Para todas las versiones 86 de Windows 7 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempoPlataforma
Mrxsmb20.sys6.1.7600.2100997,28015-Jul-201102: 22x 86
Mrxsmb20.sys6.1.7601.2177196,76815-Jul-201103: 11x 86
Para todas las versiones de 64 compatibles de Windows 7 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempoPlataforma
Mrxsmb20.sys6.1.7600.21009128,51215-Jul-201102: 44x 64
Mrxsmb20.sys6.1.7601.21771128.00015-Jul-201102: 28x 64

Estado

Microsoft ha confirmado que se trata de un problema en los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Más información

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Información adicional de archivos

Información adicional sobre archivos para Windows 7

Archivos adicionales para todas las versiones 86 de Windows 7 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoX86_1f59fe4fdfceb3e01bba793db9bbb9d7_31bf3856ad364e35_6.1.7601.21771_none_cf8d4f747adbe9b6.manifest
Versión del archivoNo es aplicable
Tamaño de archivo701
Fecha (UTC)15-Jul-2011
Hora (UTC)19: 41
PlataformaNo es aplicable
Nombre de archivoX86_98b647fa3a1fa51fb2310a7badab99d6_31bf3856ad364e35_6.1.7600.21009_none_2c74a1f8c9dd944c.manifest
Versión del archivoNo es aplicable
Tamaño de archivo701
Fecha (UTC)15-Jul-2011
Hora (UTC)19: 41
PlataformaNo es aplicable
Nombre de archivoX86_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7600.21009_none_8b954ab203f2c10a.manifest
Versión del archivoNo es aplicable
Tamaño de archivo4,035
Fecha (UTC)15-Jul-2011
Hora (UTC)07: 57
PlataformaNo es aplicable
Nombre de archivoX86_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7601.21771_none_8d281dd20158f293.manifest
Versión del archivoNo es aplicable
Tamaño de archivo4,035
Fecha (UTC)15-Jul-2011
Hora (UTC)16: 06
PlataformaNo es aplicable
Archivos adicionales para todas las versiones de 64 compatibles de Windows 7 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoAmd64_9daacb8cea32acd8d5055bc816fd9268_31bf3856ad364e35_6.1.7601.21771_none_886b99e558b7d15c.manifest
Versión del archivoNo es aplicable
Tamaño de archivo705
Fecha (UTC)15-Jul-2011
Hora (UTC)19: 41
PlataformaNo es aplicable
Nombre de archivoAmd64_ccd7361afe03337ae4a53c63ccdced80_31bf3856ad364e35_6.1.7600.21009_none_5e836a5ec8fbdeff.manifest
Versión del archivoNo es aplicable
Tamaño de archivo705
Fecha (UTC)15-Jul-2011
Hora (UTC)19: 41
PlataformaNo es aplicable
Nombre de archivoAmd64_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7600.21009_none_e7b3e635bc503240.manifest
Versión del archivoNo es aplicable
Tamaño de archivo4,039
Fecha (UTC)15-Jul-2011
Hora (UTC)08: 53
PlataformaNo es aplicable
Nombre de archivoAmd64_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7601.21771_none_e946b955b9b663c9.manifest
Versión del archivoNo es aplicable
Tamaño de archivo4,039
Fecha (UTC)15-Jul-2011
Hora (UTC)07: 06
PlataformaNo es aplicable

Propiedades

Id. de artículo: 2550581 - Última revisión: miércoles, 10 de agosto de 2011 - Versión: 1.0
La información de este artículo se refiere a:
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows 7 Starter
Palabras clave: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced kbmt KB2550581 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2550581

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com