FIX: Performance decreases when a server that is running BizTalk Server processes a large batch of messages after you customize the settings of the "Large Message Threshold" option and of the "Large Message Fragment size" option

Article translations Article translations
Article ID: 2563979 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario:
  • You customize the settings of the Large Message Threshold option and of the Large Message Fragment size option.
  • An incoming BizTalk batch includes many messages.

In this scenario, the server that is running Microsoft BizTalk Server experiences decreased performance when the server processes the messages.

For example, you keep the following default settings for a BizTalk group:
Large Message Threshold (bytes): 1,000,000

Large Message Fragment size (bytes): 102,400
The server that is running BizTalk Server 2009 receives a batch of 9,000 messages. In this example, it takes 2 minutes for the server to finish processing all the messages.

Now, you specify the following settings in the BizTalk group:
Large Message Threshold (bytes): 10,000,000

Large Message Fragment size (bytes): 1,000,000
When the server that is running BizTalk Server 2009 receives the same batch of 9,000 messages, it now takes 7 minutes for the server to finish processing all the messages.

CAUSE

This problem occurs because unnecessary delete operations occur for message properties that are already deleted.

RESOLUTION

Cumulative update information

BizTalk Server 2009

The fix for this issue was first released in cumulative update package 3 for BizTalk Server 2009. For more information about how to obtain this cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2557149 Cumulative update package 3 for BizTalk Server 2009
For BizTalk Server 2010
The hotfix that resolves this issue is included in cumulative update package 2 for BizTalk Server 2010.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2573000 Cumulative update package 2 for BizTalk Server 2010

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how to resolve performance issues, visit the following Microsoft Developer Network (MSDN) website:
Maintaining Performance
For more information about how to configure global properties for your BizTalk Server group, visit the following MSDN website:
How to Modify Group Properties
For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
2003907 Information about BizTalk Server hotfixes

Properties

Article ID: 2563979 - Last Review: August 31, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2009 Standard
Keywords: 
kbqfe kbfix kbexpertiseinter kbsurveynew kbbiztalk2009presp1fix KB2563979

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com