You cannot reestablish a Remote Desktop Services session to a Windows Server 2008 R2-based server

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Article ID: 2661332 - View products that this article applies to.
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Symptoms

Consider the following scenario:
  • You establish a Remote Desktop Services session to a Windows Server 2008-based server from a client computer.
  • You disconnect the Remote Desktop Services session.
  • You try to reestablish the Remote Desktop Services session.
In this scenario, you cannot reestablish the Remote Desktop Services session. Additionally, you receive the following error message:
The task you are trying to do can't be completed because Remote Desktop Services is currently busy. Please try again in a few minutes. Other users should still be able to log on.

Cause

This issue occurs because of a deadlock situation that occurs between the Csrss.exe process and some applications (for example, Microsoft Excel or Microsoft Visio).

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.1.760 0 . 21xxxWindows Server 2008 R2RTMLDR
    6.1.760 1 . 21xxxWindows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32k.sys6.1.7600.211483,148,28810-Feb-201204:04x64
Win32k.sys6.1.7601.219203,148,28810-Feb-201204:00x64
For all supported IA-64–based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Win32k.sys6.1.7600.211487,448,57610-Feb-201203:22IA-64
Win32k.sys6.1.7601.219207,441,40810-Feb-201203:26IA-64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_181f364f374823978a560bf859e4c355_31bf3856ad364e35_6.1.7600.21148_none_f4e4198e1f301a60.manifest
File versionNot applicable
File size1,038
Date (UTC)10-Feb-2012
Time (UTC)10:57
PlatformNot applicable
File nameAmd64_3bbb2aa1d33cf1a87bf7e24a8f0e9e51_31bf3856ad364e35_6.1.7600.21148_none_c167844965aeb88f.manifest
File versionNot applicable
File size698
Date (UTC)10-Feb-2012
Time (UTC)10:57
PlatformNot applicable
File nameAmd64_3d4168a4a22399d2af903a5fc89e7eae_31bf3856ad364e35_6.1.7601.21920_none_ea41a380938b2127.manifest
File versionNot applicable
File size698
Date (UTC)10-Feb-2012
Time (UTC)10:57
PlatformNot applicable
File nameAmd64_58c14173c1719bb4fae436610b810b67_31bf3856ad364e35_6.1.7600.21148_none_8920cb0be536b020.manifest
File versionNot applicable
File size698
Date (UTC)10-Feb-2012
Time (UTC)10:57
PlatformNot applicable
File nameAmd64_a0f664cb91431b430d4e5463948cc9c4_31bf3856ad364e35_6.1.7601.21920_none_8d3aa9fdec7f7a4f.manifest
File versionNot applicable
File size698
Date (UTC)10-Feb-2012
Time (UTC)10:57
PlatformNot applicable
File nameAmd64_a9ec2c91e6b2a8ff934030f87f587346_31bf3856ad364e35_6.1.7601.21920_none_2df95054949182ae.manifest
File versionNot applicable
File size1,038
Date (UTC)10-Feb-2012
Time (UTC)10:57
PlatformNot applicable
File nameAmd64_microsoft-windows-win32k_31bf3856ad364e35_6.1.7600.21148_none_15a02c40cd326e9e.manifest
File versionNot applicable
File size42,090
Date (UTC)10-Feb-2012
Time (UTC)06:57
PlatformNot applicable
File nameAmd64_microsoft-windows-win32k_31bf3856ad364e35_6.1.7601.21920_none_17945092ca4fa1d5.manifest
File versionNot applicable
File size42,090
Date (UTC)10-Feb-2012
Time (UTC)06:56
PlatformNot applicable
File nameWow64_microsoft-windows-win32k_31bf3856ad364e35_6.1.7600.21148_none_1ff4d69301933099.manifest
File versionNot applicable
File size4,178
Date (UTC)10-Feb-2012
Time (UTC)05:57
PlatformNot applicable
File nameWow64_microsoft-windows-win32k_31bf3856ad364e35_6.1.7601.21920_none_21e8fae4feb063d0.manifest
File versionNot applicable
File size4,178
Date (UTC)10-Feb-2012
Time (UTC)05:49
PlatformNot applicable
Additional files for all supported IA-64–based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameIa64_93f1ce1e24009c611e1ddc92f7bae303_31bf3856ad364e35_6.1.7600.21148_none_7b60287d5e6538f5.manifest
File versionNot applicable
File size1,036
Date (UTC)10-Feb-2012
Time (UTC)10:57
PlatformNot applicable
File nameIa64_f5f9a1235e89b1fd279fdcd2c75a00a8_31bf3856ad364e35_6.1.7601.21920_none_dd947b66f5671a53.manifest
File versionNot applicable
File size1,036
Date (UTC)10-Feb-2012
Time (UTC)10:57
PlatformNot applicable
File nameIa64_microsoft-windows-win32k_31bf3856ad364e35_6.1.7600.21148_none_b98334b314d30664.manifest
File versionNot applicable
File size42,088
Date (UTC)10-Feb-2012
Time (UTC)06:51
PlatformNot applicable
File nameIa64_microsoft-windows-win32k_31bf3856ad364e35_6.1.7601.21920_none_bb77590511f0399b.manifest
File versionNot applicable
File size42,088
Date (UTC)10-Feb-2012
Time (UTC)06:48
PlatformNot applicable
File nameWow64_microsoft-windows-win32k_31bf3856ad364e35_6.1.7600.21148_none_1ff4d69301933099.manifest
File versionNot applicable
File size4,178
Date (UTC)10-Feb-2012
Time (UTC)05:57
PlatformNot applicable
File nameWow64_microsoft-windows-win32k_31bf3856ad364e35_6.1.7601.21920_none_21e8fae4feb063d0.manifest
File versionNot applicable
File size4,178
Date (UTC)10-Feb-2012
Time (UTC)05:49
PlatformNot applicable

Properties

Article ID: 2661332 - Last Review: January 4, 2013 - Revision: 2.0
Applies to
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 for Itanium-Based Systems
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter KB2661332

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