Controlador de pantalla dejó de responder y ha recuperado el mensaje de Error en Windows Vista o Windows 7

Id. de artículo: 2665946 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Su PC puede bloquearse o dejara de responder temporalmente, y recibirá el mensaje de error siguiente:
Controlador de pantalla dejó de responder y se ha recuperado

Causa

Este comportamiento puede ocurrir por uno o varios de los siguientes motivos:

  • Es posible que deba instalar las actualizaciones más recientes para el controlador de pantalla
  • Efectos visuales o demasiados programas ejecutándose en segundo plano pueden ser ralentizar su PC
  • La GPU tarda más tiempo del permitido para mostrar los gráficos del Monitor
Nota: Si utiliza una tarjeta de vídeo más antigua, no puede haber un controlador de vídeo es totalmente compatible con la versión de Windows.

Solución

Para resolver este problema, siga los pasos descritos en los métodos comenzando con el método 1 y, a continuación, continuar con el método 2 si esa solución no resuelve el problema.

Método 1: Instalar las actualizaciones más recientes

Es posible que deba configurar Windows Update para descargar e instalar las actualizaciones recomendadas automáticamente. Instalar cualquier actualización importante, recomendada y opcional, puede actualizar las características del sistema y otro software que puede ayudarle a solucionar los problemas de hardware. Para actualizar el controlador de pantalla más reciente para el hardware de gráficos mediante Windows Update, haga clic en el vínculo específico para su versión de Windows y siga los pasos descritos en la que artículo:

Actualizar un controlador de hardware que no funciona correctamente en Windows 7

Actualizar un controlador de hardware que no funciona correctamente en Windows Vista

Si instala las actualizaciones más recientes no se resuelve el problema, continúe con el método 2.

Método 2: Investigar los posibles problemas con efectos visuales o programas en segundo plano

Tener varios programas, las ventanas del explorador o los mensajes de correo electrónico abiertos al mismo tiempo puede utilizar una memoria y causar problemas de rendimiento. Pruebe a cerrar todos los programas y ventanas que no está utilizando.

También puede ajustar su PC para mejorar el rendimiento al deshabilitar algunos de los efectos visuales. Aquí es cómo ajustar todos los efectos visuales para un mejor rendimiento:
  1. Abrir información de rendimiento y herramientas haciendo clic en el botón Inicio y, a continuación, haga clic en Panel de Control. En el cuadro de búsqueda, escriba la información de rendimiento y herramientasy, a continuación, en la lista de resultados, haga clic en información de rendimiento y herramientas.
  2. Haga clic en efectos de ajuste visuales, si se le pide una contraseña de administrador o una confirmación, escriba la contraseña o proporcione una confirmación.
  3. Haga clic en la ficha Efectos visuales , haga clic en Ajustar para mejorar el rendimientoy, a continuación, haga clic en Aceptar.
    Nota: Para una opción menos drástica, seleccione que permitir que Windows elija lo que es mejor para mi equipo).

Método 3: Aumentar el tiempo de procesamiento de GPU ajustando el valor del registro de tiempo de espera de detección y recuperación

Tiempo de espera de detección y recuperación es una característica de Windows que puede detectar cuándo ha tomado más de lo esperado para completar una operación de hardware de adaptador de vídeo o un controlador en su PC. Cuando esto sucede, Windows intenta recuperar y restablecer el hardware de gráficos. Si la GPU es capaz de recuperar y restablecer el hardware de gráficos en el tiempo permitido (2 segundos), su sistema puede dejar de responder y mostrar el error "controlador de pantalla dejó de responder y se ha recuperado."

Dar la característica de detección de tiempo de espera y recuperación más tiempo para completar esta operación ajustando el valor del registro, puede resolver este problema.

Importante Esta sección, el método o la tarea contiene pasos que le indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para una mayor protección, copia de seguridad del registro antes de modificarlo. A continuación, puede restaurar el registro si surge algún problema. Para obtener más información acerca de cómo hacer copia de seguridad del registro en Windows 7, consulte Copia de seguridad del registro

Para que modifique el valor del registro para usted, vaya a la "Corregir para mí"sección. Si prefiere modificar el valor del registro usted mismo, vaya a la "Voy a arreglarlo yo mismo"sección.

Corregir para mí

Para solucionar este problema automáticamente, haga clic en el Arreglarlo botón o vínculo. A continuación, haga clic en Ejecutar en el Descarga de archivos diálogo cuadro y siga los pasos del Asistente para corregirlo .


Solucionar el problema
Microsoft Fix it 50848


Notas
  • Este asistente sólo puede estar en inglés. Sin embargo, la corrección automática también funciona para otras versiones de idioma de Windows.
  • Si no está en el equipo que tiene el problema, guarde la corrección se solución a una unidad flash o un CD y, a continuación, se ejecuta en el equipo que tiene el problema.




Voy a arreglarlo yo mismo

  1. Salga de todos los programas basados en Windows.
  2. Haga clic en Inicio, escriba regedit en el cuadro de búsqueda y, a continuación, haga doble clic en regedit.exe en los resultados anteriores. Si se le pide una contraseña de administrador o una confirmación, escriba la contraseña o proporcione una confirmación.
  3. Busque y, a continuación, haga clic en la siguiente subclave del registro:
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\GraphicsDrivers
  4. En el menú Edición , haga clic en nuevoy, a continuación, seleccione el valor del Registro siguiente en el menú desplegable específico para su versión de Windows (32 bits o 64 bits):

    Para Windows de 32 bits
    1. Seleccione el valor DWORD (32 bits) .
    2. Escriba TdrDelay como el nombre y haga clic en ENTRAR.
    3. Haga doble clic en TdrDelay y añadir 8 para los datos de valor y haga clic en Aceptar.

    ParaWindows de 64 bits

    1. Seleccione valor QWORD (64-bit) .
    2. Escriba TdrDelay como el nombre y haga clic en ENTRAR.
    3. Haga doble clic en TdrDelay y añadir 8 para los datos de valor y haga clic enAceptar.
  5. Cierre el editor del registro y, a continuación, reinicie el equipo para que los cambios surtan efecto.

Más información

Para obtener más información acerca de la detección de tiempo de espera y recuperación, vea Detección de tiempo de espera y recuperación de GPU mediante WDDM.

Propiedades

Id. de artículo: 2665946 - Última revisión: viernes, 18 de mayo de 2012 - Versión: 5.0
La información de este artículo se refiere a:
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Palabras clave: 
kbfixme kbmsifixme kbmt KB2665946 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2665946

Enviar comentarios