Lägga till ADPermission-cmdlet med parametern en domänkontrollant misslyckas i en miljö med Exchange Server 2010

Artikelöversättning Artikelöversättning
Artikel-id: 2698899 - Visa produkter som artikeln gäller.
Visa alla | Dölj alla

Symptom

Tänk dig följande situation:
  • Du har två domäner (domän a och domän B) i en miljö med Microsoft Exchange Server 2010.
  • Du kan distribuera en server Exchange Server 2010 postlåda i domän a och skapa ett användarkonto i domän B.
  • Försök att ge användarbehörighet till en postlåda i domän A. Detta gör du kör den Lägg till ADPermission cmdlet och ange en global katalogserver i domän b till domänkontrollant.
I det här scenariot cmdlet misslyckas och följande felmeddelande visas:
Användare kunde inte hittas. Kontrollera att du har skrivit korrekt.
+ CategoryInfo: InvalidArgument: (:)) [Lägg till-ADPermission], ManagementObjectNotFoundException
+ FullyQualifiedErrorId: Fel-IDMicrosoft.Exchange.Management.RecipientTasks.AddADPermission

Orsak

Det här problemet beror på Exchange-servern inte använder den globala katalogservern när Active Directory-sessionen skapas när role-based access control (RBAC) scope-verifieringsprocessen är klar.

Lösning

Lös problemet genom att installera följande samlade:
2706690 Beskrivning av Samlad uppdatering 4 för Exchange Server 2010 Service Pack 2

Status

Microsoft har bekräftat att detta är ett problem i Microsoft-produkterna i avsnittet "Gäller".

Mer Information

Mer information om Aktivera Mailbox -cmdlet gå till följande Microsoft-webbplats:
Allmän information om att aktivera Mailbox-cmdlet
Mer information om Lägg till ADPermission cmdlet gå till följande Microsoft-webbplats:
Allmän information om cmdlet Lägg till ADPermission

Egenskaper

Artikel-id: 2698899 - Senaste granskning: den 16 augusti 2012 - Revision: 3.0
Informationen i denna artikel gäller:
  • Microsoft Exchange Server 2010 Service Pack 2 på följande plattformar
    • Microsoft Exchange Server 2010 Enterprise
    • Microsoft Exchange Server 2010 Standard
Nyckelord: 
kbqfe kbfix kbsurveynew kbexpertiseinter kbmt KB2698899 KbMtsv
Maskinöversatt
VIKTIGT: Denna artikel är översatt av Microsofts automatiska översättningsprogram och inte av en mänsklig översättare. För att Du skall ha åtkomst till alla artiklar i Knowledge Base på Ditt föredragna språk så är en del artiklar översatta av människor och en del artiklar av översättningsprogram. Tänk på att en artikel som är översatt av ett översättningsprogram inte alltid är perfekt. Artikeln kan innehålla fel ord, grammatik eller meningsbyggnad, ungefär som en utländsk talare kan göra misstag när han eller hon pratar med Dig på Ditt språk. Microsoft ansvarar inte för eventuella felaktigheter i översättningen, fel eller skador som orsakats av någon felöversättning av innehållet eller våra kunders användande av det översatta innehållet. Microsoft uppdaterar kontinuerligt mjukvaran för översättningsprogrammet.
Den engelska versionen av artikeln är följande: 2698899

Ge feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com