FIX: Een gebruiker geen toegang tot een server 2010 TFS nadat u de gebruiker en de SID-geschiedenis naar een ander domein migreren

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 2741905 - Bekijk de producten waarop dit artikel van toepassing is.
Alles uitklappen | Alles samenvouwen

Op deze pagina

Symptomen

Neem het volgende scenario:
  • U kunt een gebruiker toevoegen aan een domein (1).
  • U kunt een server met Microsoft Visual Studio Team Foundation Server (TFS) 2010 toevoegen naar een ander domein (domein 2).

    Opmerking 2 Vertrouwd domein 1.
  • U toevoegen de gebruiker aan de server TFS. De gebruiker nu toegang tot de server TFS.
  • U migreert de gebruiker en de geschiedenis van hun security identifier (SID) van 1 domein naar domein 2.
In dit scenario kan de gebruiker niet langer domeinreferenties 1 gebruiken voor toegang tot de server TFS.

OpmerkingDit gebeurt binnen 24 uur na de migratie.

Oorzaak

Dit probleem treedt op vanwege een synchronisatiekwestie tijdens de dagelijkse synchronisatietaak op de server TFS. Wanneer dit probleem optreedt, worden de TFS-server de 1 domeingebruikersaccount als ongeldig gemarkeerd.

Oplossing

Informatie over hotfixes

Een ondersteunde hotfix is nu beschikbaar bij Microsoft. Het is echter bedoeld om alleen het probleem dat in dit artikel wordt beschreven. Deze alleen van toepassing op systemen waarop dit specifieke probleem zich voordoet.

U kunt dit probleem oplossen door contact op met Microsoft Customer Support Services om de hotfix te verkrijgen. Een volledige lijst met telefoonnummers van Microsoft Customer Support Services en informatie over kosten van ondersteuning vindt u op de volgende Microsoft-website:
http://support.Microsoft.com/contactus/?ws=support
Opmerking In speciale gevallen kunnen kosten die normaal aan ondersteuningsoproepen verbonden zijn, worden geannuleerd als een medewerker van Microsoft productondersteuning van mening is dat een specifieke update de oplossing van uw probleem is. De normale ondersteuningskosten blijven gelden voor extra ondersteuningsvragen die niet in aanmerking voor de specifieke update in kwestie komen.

Vereisten

Deze hotfix moet u Visual Studio Team Foundation Server 2010 Service Pack 1 op de computer geïnstalleerd hebben.

Opnieuw opstarten

U moet de computer opnieuw opstarten nadat u deze hotfix installeert als de bestanden waarin dit probleem optreedt tijdens de installatie worden gebruikt. Wij raden aan dat u alle onderdelen die betrekking hebben op Microsoft Visual Studio 2010 sluiten voordat u deze hotfix installeert.

Informatie over bestanden

De algemene versie van deze hotfix heeft de bestandskenmerken (of recentere bestandskenmerken) die in de volgende tabel worden weergegeven. De datums en tijden voor deze bestanden worden weergegeven in Coordinated Universal Time (UTC). Wanneer u de bestandsinformatie weergeeft, wordt deze naar lokale tijd geconverteerd. Gebruiken om het verschil tussen UTC en lokale tijd, de Tijdzone tabblad de Datum en tijd een item in het Configuratiescherm.

Voor alle ondersteunde versies van Visual Studio Team Foundation Server 2010
Deze tabel samenvouwenDeze tabel uitklappen
BestandsnaamBestandsversieBestandsgrootteDatumTijdPlatform
Microsoft.teamfoundation.Admin.dll10.0.40219.43025,618,01626-Okt-20129: 11x 86
Microsoft.teamfoundation.build.server.dll10.0.40219.430445,54426-Okt-20129: 11x 86
Microsoft.teamfoundation.build.server.plugins.dll10.0.40219.43046,72026-Okt-20129: 11x 86
Microsoft.teamfoundation.Framework.server.dll10.0.40219.4301,103,47226-Okt-20129: 11x 86
Microsoft.teamfoundation.server.Deploy.tfcollection.dll10.0.40219.430562,31226-Okt-20129: 11x 86
Microsoft.teamfoundation.server.dll10.0.40219.430221,79226-Okt-20129: 11x 86
Microsoft.teamfoundation.Servicing.dll10.0.40219.43066,66426-Okt-20129: 11x 86
Microsoft.teamfoundation.testmanagement.adapter.dll10.0.40219.43093,82426-Okt-20129: 11x 86
Microsoft.teamfoundation.versioncontrol.server.dll10.0.40219.430618,11226-Okt-20129: 11x 86
Microsoft.teamfoundation.versioncontrol.server.plugins.dll10.0.40219.43026,76826-Okt-20129: 11x 86
Microsoft.teamfoundation.versioncontrol.server.proxy.dll10.0.40219.43090,24826-Okt-20129: 11x 86
Microsoft.teamfoundation.Warehouse.dll10.0.40219.4303,526,76026-Okt-20129: 11x 86
Microsoft.teamfoundation.workitemtracking.server.dataaccesslayer.dll10.0.40219.430589,99226-Okt-20129: 11x 86
Microsoft.teamfoundation.workitemtracking.server.dataservices.dll10.0.40219.430143,52026-Okt-20129: 11x 86

Workaround

U kunt dit probleem omzeilen de identiteit domein 1 vervangen door de identiteit domein 2 binnen de TFS-server en vervolgens toegang krijgen tot de server TFS met behulp van de referenties voor het domein 2. Typ hiertoe de volgende opdracht bij een opdrachtprompt:
Identiteiten TFSConfig/Change /fromdomain:domain1 /todomain:domain2 /account:AccountName /toaccount:AccountName
Opmerking Als de identiteit van het domein 1 alleen toegang tot de server TFS via het Windows-groepslidmaatschap heeft, kan de beheerder TFS toegang verlenen tot de identiteit van het domein 2 hebben.

Status

Microsoft heeft bevestigd dat dit een probleem in de Microsoft-producten die worden vermeld in de sectie is 'Van toepassing op'.

Meer informatie

Ga naar de volgende MSDN-website voor meer informatie over de opdracht identiteiten :
Algemene informatie over de opdracht identiteiten

Eigenschappen

Artikel ID: 2741905 - Laatste beoordeling: dinsdag 27 november 2012 - Wijziging: 1.0
De informatie in dit artikel is van toepassing op:
  • Microsoft Visual Studio Team Foundation Server 2010 Service Pack 1 op de volgende platformen
    • Microsoft Visual Studio Team Foundation Server 2010
Trefwoorden: 
kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced kbmt KB2741905 KbMtnl
Automatisch vertaald artikel
BELANGRIJK: Dit artikel is vertaald door de vertaalmachine software van Microsoft in plaats van door een professionele vertaler. Microsoft biedt u professioneel vertaalde artikelen en artikelen vertaald door de vertaalmachine, zodat u toegang heeft tot al onze knowledge base artikelen in uw eigen taal. Artikelen vertaald door de vertaalmachine zijn niet altijd perfect vertaald. Deze artikelen kunnen fouten bevatten in de vocabulaire, zinsopbouw en grammatica en kunnen lijken op hoe een anderstalige de taal spreekt en schrijft. Microsoft is niet verantwoordelijk voor onnauwkeurigheden, fouten en schade ontstaan door een incorrecte vertaling van de content of het gebruik ervan door onze klanten. Microsoft past continue de kwaliteit van de vertaalmachine software aan door deze te updaten.
De Engelstalige versie van dit artikel is de volgende: 2741905

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com