Article ID: 2785586 - View products that this article applies to.
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Symptoms

Consider the following scenario:
  • You have a custom module that is based on the Microsoft .NET Framework.
  • The custom module runs in Internet Information Services (IIS) 8.0 on a computer that is running Windows 8 or Windows Server 2012.
  • The Microsoft IIS Application Request Routing (ARR) 2.5 feature is enabled.
In this scenario, ARR intermittently freezes and no longer serves any requests.

Cause

This issue occurs because of a deadlock situation that occurs in ARR.

Resolution

Download information

To download the hotfix, go to the following Microsoft Download Center website:

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Download
Download the package now.

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

To apply this hotfix, you must have IIS 8.0 installed in Windows 8 or Windows Server 2012. 

Restart requirement

You do not have to restart the computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Requestrouter.dll7.1.1742.0299,98415-Dec-201211:03x86
Requestrouter.dll7.1.1742.0321,48815-Dec-201211:03x64
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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Workaround

To work around this issue, restart the corresponding application pool.

Properties

Article ID: 2785586 - Last Review: November 18, 2013 - Revision: 2.0
Applies to
Keywords: 
kbfix atdownload kbsurveynew kbexpertiseadvanced KB2785586

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