Virtual machine enters a paused state or a CSV volume goes offline when you try to create a backup of the virtual machine on a Windows Server 2012-based failover cluster

Article translations Article translations
Article ID: 2799728 - View products that this article applies to.
Important The hotfix that corresponds to KB 2799728 has been included with the hotfix KB 2878635, which contains all fixes that were previously included in KB 2799728.
Expand all | Collapse all

On This Page

Symptoms

Consider the following scenario:
  • You enable the Cluster Shared Volumes (CSV) feature on a Windows Server 2012-based failover cluster.
  • You create a virtual machine on a CSV volume on a cluster node.
  • You start the virtual machine.
  • You try to create a backup of the virtual machine on the CSV volume by using Microsoft System Center Data Protection Manager (DPM).
In this scenario, one of the following issues occurs:
  • The backup is created, and the virtual machine enters a paused state.
  • The CSV volume goes offline. Therefore, the virtual machine goes offline, and the backup is not created.
Additionally, the following events are logged in the Cluster log and System log respectively:

Software snapshot creation on Cluster Shared Volume(s) ('volume location') with snapshot set id 'snapshot id' failed with error 'HrError(0x80042308)(2147754760)'. Please check the state of the CSV resources and the system events of the resource owner nodes.

Log Name: System
Source: Microsoft-Windows-FailoverClustering
Date: Date and time
Event ID: 5120
Task Category: Cluster Shared Volume
Level: Error
Keywords:
User: SYSTEM
Computer: Computer name
Description: Cluster Shared Volume 'Volume1' ('name’) is no longer available on this node because of 'STATUS_IO_TIMEOUT(c00000b5)'. All I/O will temporarily be queued until a path to the volume is reestablished.


Log Name: System
Source: Microsoft-Windows-FailoverClustering
Date: Date and time
Event ID: 5142
Task Category: Cluster Shared Volume
Level: Error
Keywords:
User: SYSTEM
Computer: Computer name
Description: Cluster Shared Volume 'Volume3' ('Cluster Disk 4') is no longer accessible from this cluster node because of error 'ERROR_TIMEOUT(1460)'. Please troubleshoot this node's connectivity to the storage device and network connectivity.


Note This issue also occurs when you try to create a snapshot of the virtual machine by using backup software that uses the Microsoft Software Shadow Copy Provider.

Cause

The virtual machine enters a paused state because the Ntfs.sys driver incorrectly reports the available space on the CSV volume when the backup software tries to create a snapshot of the CSV volume. Additionally, the CSV volume goes offline because it does not resume from a paused state after an I/O delay issue or error occurs.

Note The CSV volume is resilient.

Resolution

Hotfix Replacement Information

The hotfix that corresponds to KB 2799728 has been superseded with the hotfix KB 2878635, which contains all fixes that were previously included in KB 2799728. You should use the hotfix KB 2878635 to fix the issues described in KB 2799728. For more information, click the following article number to view the article in the Microsoft Knowledge Base:  
2878635 Update is available that improves the resiliency of the cloud service provider in Windows Server 2012: December 2013  

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 2799728 - Last Review: January 10, 2014 - Revision: 8.0
Applies to
  • Windows Server 2012 Datacenter
  • Windows Server 2012 Standard
Keywords: 
kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced KB2799728

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com