Symptomen
Overweeg het volgende scenario:
-
U gebruikt een toepassing uitvoerbare bestanden openen via het netwerk vanaf een clientcomputer waarop Windows 7 of Windows Server 2008 R2 wordt uitgevoerd.
-
Deze toepassing wordt ook meer Schakel opportunistisch vergrendelen (oplock) via het netwerk bestanden geopend.
-
Een ander proces probeert toegang te krijgen tot een gedeeld bestand dat al in de toepassing wordt geopend via het netwerk.
-
Vraagt de server dat de client-computer verbreken van de oplock.
In dit scenario afbreken clientcomputer de oplock niet. Daarom blijft het gedeelde bestand openen op de server en andere clients dat bestand niet gebruiken.
Oorzaak
Dit probleem treedt op omdat de memorymanager op de client objecten die uitvoerbaar bevat en wordt niet gesloten. Echter, de server beschouwt de uitvoerbare objecten worden gesloten en wordt gebruikgemaakt van de bestands-ID voor het nieuwe bestand met een andere. Dit veroorzaakt een conflict van de id-bestand. Dus wanneer het break oplock-aanvraag verzendt, verwerkt de clientcomputer het vorige uitvoerbare object in plaats van het nieuwe bestand.
Oplossing
Informatie over de hotfix
De hotfix voor dit probleem is opgenomen in 2732673. Het probleem oplossen door update voor 2732673 in het volgende artikel in de Microsoft Knowledge Base:
2732673 foutbericht 'Uitgestelde schrijfbewerkingen zijn mislukt' wanneer u PST-bestanden worden opgeslagen op een netwerkserver waarop Windows Server 2008 R2
Vereisten
Deze hotfix kan alleen worden geïnstalleerd op systemen met Windows 7 Service Pack 1 (SP1) of Windows Server 2008 R2 SP1.
Voor meer informatie over het verkrijgen van een servicepack van Windows 7 of Windows Server 2008 R2, klikt u op het volgende artikelnummer om het artikel in de Microsoft Knowledge Base weer te geven:
976932 informatie over servicepack 1 voor Windows 7 en Windows Server 2008 R2
Informatie over het register
Bij uitvoeren van deze hotfix, hoeft u geen wijzigingen aan te brengen in het register.
Opnieuw opstarten
Nadat u deze hotfix hebt geïnstalleerd, moet u de computer opnieuw opstarten.
Informatie over het vervangen van hotfixes
Deze hotfix vervangt geen eerder uitgebrachte hotfix.
Status
Microsoft heeft bevestigd dat dit probleem kan optreden in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.
Meer informatie
Voor meer informatie over terminologie voor software-updates klikt u op het volgende artikelnummer om het artikel in de Microsoft Knowledge Base weer te geven:
824684 beschrijving van de standaardterminologie die wordt gebruikt om software-updates voor Microsoft te beschrijven