Mensaje de error cuando se ejecute Regsvr32.exe en Windows de 64 bits

Seleccione idioma Seleccione idioma
Id. de artículo: 282747 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Cuando intenta ejecutar Regsvr32.exe para registrar una biblioteca de vínculos dinámicos (DLL) de 32 bits en una versión de 64 bits de Windows, recibirá el mensaje de error siguiente:
Nombre de archivoDLL no es un archivo ejecutable y no se registra ningún asistente de registro para este tipo de archivo.

Causa

Este comportamiento se produce porque el archivo Regsvr32.exe en la carpeta System32 es una versión de 64 bits. Al ejecutar Regsvr32 para registrar un archivo DLL, está utilizando la versión de 64 bits de forma predeterminada.

Solución

Para resolver este problema, ejecute Regsvr32.exe desde la carpeta %SystemRoot%\Syswow64. Por ejemplo, escriba los comandos siguientes para registrar la DLL:
CD \windows\syswow64
regsvr32 c:\nombreDeArchivo.dll

Estado

Este comportamiento es por diseño.

Más información

La carpeta Syswow64 contiene las versiones de 32 bits de los archivos de programa de Windows y los archivos DLL.
Nota: es un artículo de "PUBLICACIÓN RÁPIDA" creado directamente por la organización de soporte técnico de Microsoft. La información aquí contenida se proporciona como está, como respuesta a problemas que han surgido. Como consecuencia de la rapidez con la que lo hemos puesto disponible, los materiales podrían incluir errores tipográficos y pueden ser revisados en cualquier momento sin previo aviso. Vea las Condiciones de uso para otras consideraciones

Propiedades

Id. de artículo: 282747 - Última revisión: domingo, 10 de marzo de 2013 - Versión: 4.0
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows Advanced Server, Limited Edition
Palabras clave: 
kberrmsg kbprb kbmt KB282747 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 282747

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com