How to use outline levels to create a table of contents (TOC) in Word 2003 and in Word 2002

Article translations Article translations
Article ID: 285050 - View products that this article applies to.
This article was previously published under Q285050
Expand all | Collapse all

On This Page

SUMMARY

The table of contents (TOC) is a common feature of professional documents. In Microsoft Office Word 2003 and in Microsoft Word 2002, you can create a table of contents without using styles.

In Word 2003 and in Word 2002, you do have to use heading styles, custom styles, or TC fields to create a table of contents. You can now use outline levels to build a table of contents without changing the appearance of your text. The built-in heading styles apply specific formatting and the outline levels apply an "invisible" format. This article describes how to use outline levels to create a table of contents.

Insert Table of Contents Field

To use outline levels to create a table of contents, follow these steps.

To insert a TOC field:
  1. Start Word, and then open your document.
  2. Click an empty paragraph where you want to insert the table of contents.
  3. On the Insert menu, point to Reference, and then click Index and Tables.
  4. Click the Table of Contents tab, and then click Show Outlining Toolbar.
  5. In the Index and Tables dialog box, select the options that you want to apply to your table of contents, and then click OK.

    You receive the following message:
    To add or remove items in the table of contents:

    1. Select text in your document.
    2. Click the outline level in the toolbar to make the text appear in the table of contents.
    NOTE: If the text contained in your document is not marked to be included in a TOC, you receive the following error message, which appears in your document instead of the TOC:
    Error! No table of contents entries found.
  6. Click OK.

Create Table of Contents

Mark the text that you want to include in your table of contents with an outline level. Use one or more of the following methods to mark text that you want to include in your table of contents.

Use Outline Levels to Mark Text

  1. Select any text in your document that you want to include in your TOC.
  2. On the Outlining toolbar, select the level that you want in the Outline Level box.

    For example, if you want to include the heading "Widow and Orphan" in your TOC, select these words, and then apply the level that you want on the Outlining toolbar:
    Widow and Orphan

    A widow is the last line of a paragraph printed by itself at the top of a page. An orphan is the first line of a paragraph printed by itself at the bottom of a page.
  3. Click Update TOC on the Outlining toolbar to update the table of contents.
  4. In the Update Table of Contents dialog box, click Update the entire table, and then click OK.

Use Outline Levels with a Style Separator to Mark Text

When you apply an outline level to selected text that is part of a larger paragraph, the whole paragraph is displayed in the table of contents. You can use style separators to apply outline levels to a single word or phrase in a paragraph so that only that word or phrase appears in the table of contents. For more information about this feature, see the "More Information About Style Separators" section of this article.

Before you can use the style separator feature, you have to add the Style Separator button to your Formatting toolbar. To do this, follow these steps:
  1. Click Customize on the Tools menu.
  2. On the Commands tab, click All Commands in the Categories list.
  3. Select InsertStyleSeparator in the Commands list, and then drag InsertStyleSeparator to the Formatting toolbar.
  4. Click Close to close the Customize dialog box.


Use style separators in one of the following ways:
  • Apply outline levels to lead-in text. To do this, follow these steps:
    1. While you are typing, when you reach a point where you want to change the outline level, click the Style Separator button.

      When you click the Style Separator button, the insertion point moves to the right of the separator, so that you can continue typing. You now have text, in one paragraph, delineated by the style separator.
    2. Select the text to the left of the separator. On the Outlining toolbar, select the level that you want in the Outline Level box.
    Use style separators to add a single word or phrase in a paragraph to the TOC. To do this, follow these steps:

    1. While you are typing, when you reach a word or phrase in a paragraph that you want to include in the TOC, click the Style Separator button.

      When you click the Style Separator button, the insertion point moves to the right of the separator, so that you can continue typing.
    2. Type the word or phrase that you want to include in the TOC, and then click the Style Separator button again.
    3. Select the word or phrase that you want to include in the TOC. On the Outlining toolbar, select the level that you want in the Outline Level box.
    Insert the style separator between two existing paragraphs.

    You can use the style separator between two existing paragraphs, so that the first paragraph becomes the lead-in text and appears in the TOC. The second paragraph is the remainder of the text and does not appear in the TOC. To do this, follow these steps:
    1. Create two paragraphs of text. Place text that you want to have appear in the TOC in the first paragraph. Place the remainder of the text in the second paragraph.
    2. Position the insertion point in the first paragraph, and then click the Style Separator button.

      The two paragraphs appear to become a single paragraph. The paragraph mark at the end of the first paragraph becomes a style separator. You now have a single, compound paragraph, which shows up as two separate paragraphs in Outline View, but is printed as a single paragraph.
    3. Select the text to the left of the separator. On the Outlining toolbar, select the level that you want in the Outline Level box.

Change or Remove a Heading in a Table of Contents

To view an applied outline level, do one of the following:
  • On the Format menu, click Reveal Formatting. The Reveal Formatting task pane appears. Select the text that has an outline level applied to it in your document.

    Notice that exact formatting details appear in the Reveal Formatting task pane. (The outline level appears under Paragraph.)

    -or-
  • Select the text that has the outline level applied. On the Outlining toolbar, view the Outline Level box for the applied outline level.

    NOTE: If the Outlining toolbar is not displayed, point to Toolbars on the View menu, and then click to select Outlining.
To change or remove a heading in your table of contents, apply a new outline level to the marked text. To do this, follow these steps:

  1. Select the marked text. On the Outlining toolbar, select the level that you want in the Outline Level box. (Click Body text to remove the outline level formatting.)
  2. Click Update TOC on the Outlining toolbar to update the TOC.
  3. In the Update Table of Contents dialog box click Update the Entire table, and then click OK.
NOTE: If you click Show/Hide on the standard toolbar, you see that there are no special characters in the paragraph to indicate outline levels applied to the text. However, the text that is marked with an outline level appears in the document's table of contents.

More Information About Style Separators

The style separator is a new feature of Microsoft Word. Style separator tags allow you to do the following:

  • Apply outline levels to lead-in text so that only the lead-in text appears in the table of contents.
  • Apply outline levels to a single word or phrase in a paragraph so that only that word or phrase appears in the table of contents.
  • Apply heading styles to a single word or phrase in a paragraph so that only that word or phrase appears in the table of contents.
  • Include two styles in a single paragraph so that the lead-in paragraph appears in the table of contents.
The style separator is a hidden paragraph mark that serves as a delineator between separate styles applied in a document. The style separator mark is visible only when you view non-printing characters. To view the style separator, click Options on the Tools menu. On the View tab, click to select the All check box under Formatting Marks, and then click OK.

IMPORTANT NOTE: The style separator is a special form of a hidden paragraph mark, so documents created in Word 2003 and in Word 2002 with style separators appear the same in Word 2000 and in Microsoft Word 97, unless you click to select the Show All check box. If you select the Show All check box in earlier versions of Word, the style separator hidden paragraph mark will appear as a normal paragraph mark, and the document will repaginate. You can delete the style separator, whether visible or not, just like any other character. When you do this, the formatting of the text after the separator assumes the formatting of the text before the separator, as expected. Also, when you view documents created in Word 2003 or in Word 2002 with style separators in earlier Word versions, do not click to select Show All.

NOTE: The functionality of outline levels is lost if you save the document in a version of Word earlier than Word 2002.




REFERENCES

For more information about creating a table of contents, click Microsoft Word 2002 Help on the Help menu, type create a table of contents from an outline in the Office Assistant or the Answer Wizard, and then click Search to view the topic.


For more information about how to use the Lead-in Emphasis feature to create a table of contents, click the following article number to view the article in the Microsoft Knowledge Base:
285059 How to create a table of contents by marking text in Word 2003 and in Word 2002
For more information about how to create table of content entries with no page numbers, click the following article number to view the article in the Microsoft Knowledge Base:
319821 How to create table of contents entries without a page number in Word 2003 and in Word 2002




Properties

Article ID: 285050 - Last Review: March 23, 2006 - Revision: 3.2
APPLIES TO
  • Microsoft Word 2002 Standard Edition
  • Microsoft Office Word 2003
Keywords: 
kbnewfile kbhowtomaster KB285050

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com